Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование таблицы формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование таблицы формулой (Формулы/Formulas)
Формирование таблицы формулой
perven Дата: Суббота, 09.03.2019, 08:12 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте друзья.
С праздником вас.

Появился такой непростой вопрос, который сложен тем, что его нужно решить при помощи именно формулы.

Суть такая:
На листе идет несколько небольших таблиц:
C29:E39, I29:K39, N29:O39.

Как эти таблицы - формулой вписать в большой диапазон C4:R18 , с тем расчетом чтобы при добавлении к правому краю таблицы - нового столбца (с индексом 1,2,3... и т.д. по строке 29) - этот столбец также включался бы в диапазон C4:R18 ?

То есть если в столбец F - ставить какие-то данные и присвоить по строке 29 - индекс 1 (что означает его принадлежность к первой таблице) - то этот столбец впишется в диапазон C4:R18 - четвертым столбцом.
А вся скомпонованная таблица в этом диапазоне - расширится вправо на один столбец.
К сообщению приложен файл: 0889338.xls(52.0 Kb)
 
Ответить
СообщениеЗдравствуйте друзья.
С праздником вас.

Появился такой непростой вопрос, который сложен тем, что его нужно решить при помощи именно формулы.

Суть такая:
На листе идет несколько небольших таблиц:
C29:E39, I29:K39, N29:O39.

Как эти таблицы - формулой вписать в большой диапазон C4:R18 , с тем расчетом чтобы при добавлении к правому краю таблицы - нового столбца (с индексом 1,2,3... и т.д. по строке 29) - этот столбец также включался бы в диапазон C4:R18 ?

То есть если в столбец F - ставить какие-то данные и присвоить по строке 29 - индекс 1 (что означает его принадлежность к первой таблице) - то этот столбец впишется в диапазон C4:R18 - четвертым столбцом.
А вся скомпонованная таблица в этом диапазоне - расширится вправо на один столбец.

Автор - perven
Дата добавления - 09.03.2019 в 08:12
Nic70y Дата: Суббота, 09.03.2019, 08:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5182
Репутация: 1125 ±
Замечаний: 0% ±

Excel 2013
апдейт, забыл закрепить один диапазон в формуле, исправил:
№№
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(29:29;СТОЛБЕЦ(A1));"")
таблицы
Код
=ЕСЛИ(C$4<>"";ИНДЕКС(30:30;ПОИСКПОЗ(C$4;$29:$29;)+СЧЁТЕСЛИ($C$4:C$4;C$4)-1)&"";"")
К сообщению приложен файл: 18.xlsx(14.8 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 09.03.2019, 08:25
 
Ответить
Сообщениеапдейт, забыл закрепить один диапазон в формуле, исправил:
№№
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(29:29;СТОЛБЕЦ(A1));"")
таблицы
Код
=ЕСЛИ(C$4<>"";ИНДЕКС(30:30;ПОИСКПОЗ(C$4;$29:$29;)+СЧЁТЕСЛИ($C$4:C$4;C$4)-1)&"";"")

Автор - Nic70y
Дата добавления - 09.03.2019 в 08:21
perven Дата: Суббота, 09.03.2019, 10:05 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, большое спасибо
 
Ответить
СообщениеNic70y, большое спасибо

Автор - perven
Дата добавления - 09.03.2019 в 10:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование таблицы формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!