Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование с условием (Формулы/Formulas)
Суммирование с условием
Kaiyr Дата: Вторник, 12.03.2019, 11:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Дан список териитории штата Индии. Численность носителей родного языка. У каждого языка есть свой подязык. Поэтому в сумме территория дает почти в два раза выше чем на самом деле. Почти употребляется так как 124 OTHERS не повторяется. Надо посчитать процент каждого родного языка по территориям. Для этого надо посчитать сумму каждого Area name.

Мой файл в сокращенном виде прикреплен.
К сообщению приложен файл: _-___.xlsx(14.5 Kb)


Активный участник Википедии, могу проконсультировать. Также по казахской генеалогии и программам.

Сообщение отредактировал Kaiyr - Вторник, 12.03.2019, 12:36
 
Ответить
СообщениеДан список териитории штата Индии. Численность носителей родного языка. У каждого языка есть свой подязык. Поэтому в сумме территория дает почти в два раза выше чем на самом деле. Почти употребляется так как 124 OTHERS не повторяется. Надо посчитать процент каждого родного языка по территориям. Для этого надо посчитать сумму каждого Area name.

Мой файл в сокращенном виде прикреплен.

Автор - Kaiyr
Дата добавления - 12.03.2019 в 11:32
sboy Дата: Вторник, 12.03.2019, 12:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2409
Репутация: 680 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Ссылки на внешние хранилища запрещены. Примера достаточно.
Исправляйте, ответ Вас уже ждет


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Ссылки на внешние хранилища запрещены. Примера достаточно.
Исправляйте, ответ Вас уже ждет

Автор - sboy
Дата добавления - 12.03.2019 в 12:22
_Boroda_ Дата: Вторник, 12.03.2019, 12:54 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14442
Репутация: 5779 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Отличие только в жирноте шрифта? Никаких других признаков нет?
Если по жирноте считать, то в диспетчер имен (ДИ) формулу
Код
=ПОЛУЧИТЬ.ЯЧЕЙКУ(20;СМЕЩ(ИНДЕКС(Sheet2!$B:$B;ПОИСКПОЗ(Sheet2!$A7;Sheet2!$A$1:$A7;));Ч(ИНДЕКС(СТРОКА(Sheet2!$A$1:ИНДЕКС(Sheet2!$A:$A;СЧЁТЕСЛИ(Sheet2!$A:$A;Sheet2!$A7)))-1;));))*ИНДЕКС(Sheet2!$C:$C;ПОИСКПОЗ(Sheet2!$A7;Sheet2!$A$1:$A7;)):ИНДЕКС(Sheet2!$C:$C;СЧЁТЕСЛИ(Sheet2!$A:$A;Sheet2!$A7)+СТРОКА()-СЧЁТЕСЛИ(Sheet2!$A$1:$A7;Sheet2!$A7))

А на лист формулу
Код
=СУММПРОИЗВ(Жир)

В файле макросов нет, но при его открытии Excel попросит об их разрешении. Соглашайтесь
Формулу в ДИ можно значительно проще написать, я ориентировался не на простоту, а на скорость работы
К сообщению приложен файл: -1.xlsm(15.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОтличие только в жирноте шрифта? Никаких других признаков нет?
Если по жирноте считать, то в диспетчер имен (ДИ) формулу
Код
=ПОЛУЧИТЬ.ЯЧЕЙКУ(20;СМЕЩ(ИНДЕКС(Sheet2!$B:$B;ПОИСКПОЗ(Sheet2!$A7;Sheet2!$A$1:$A7;));Ч(ИНДЕКС(СТРОКА(Sheet2!$A$1:ИНДЕКС(Sheet2!$A:$A;СЧЁТЕСЛИ(Sheet2!$A:$A;Sheet2!$A7)))-1;));))*ИНДЕКС(Sheet2!$C:$C;ПОИСКПОЗ(Sheet2!$A7;Sheet2!$A$1:$A7;)):ИНДЕКС(Sheet2!$C:$C;СЧЁТЕСЛИ(Sheet2!$A:$A;Sheet2!$A7)+СТРОКА()-СЧЁТЕСЛИ(Sheet2!$A$1:$A7;Sheet2!$A7))

А на лист формулу
Код
=СУММПРОИЗВ(Жир)

В файле макросов нет, но при его открытии Excel попросит об их разрешении. Соглашайтесь
Формулу в ДИ можно значительно проще написать, я ориентировался не на простоту, а на скорость работы

Автор - _Boroda_
Дата добавления - 12.03.2019 в 12:54
sboy Дата: Вторник, 12.03.2019, 13:05 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2409
Репутация: 680 ±
Замечаний: 0% ±

Excel 2010
У меня вариант с той же макрофункцией в ДИ и допстолбцом
К сообщению приложен файл: 9904423.xlsm(15.0 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеУ меня вариант с той же макрофункцией в ДИ и допстолбцом

Автор - sboy
Дата добавления - 12.03.2019 в 13:05
Kaiyr Дата: Вторник, 12.03.2019, 13:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Жирный и начинается с цифр от 1 до 124.


Активный участник Википедии, могу проконсультировать. Также по казахской генеалогии и программам.
 
Ответить
Сообщение_Boroda_, Жирный и начинается с цифр от 1 до 124.

Автор - Kaiyr
Дата добавления - 12.03.2019 в 13:23
krosav4ig Дата: Вторник, 12.03.2019, 14:37 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1984
Репутация: 840 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Kaiyr, откуда берутся циферки в строке
Код
Koriya    6 HINDI  621319
, а то под ней до следующей жирной в сумме 87671
у мну такие суммы вышли по вашей таблице[vba]
Код
CHHATTISGARH 249632
Koriya       94653
Bharatpur    46439
Baikunthpur  7511
[/vba] правильно?


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Вторник, 12.03.2019, 14:45
 
Ответить
СообщениеKaiyr, откуда берутся циферки в строке
Код
Koriya    6 HINDI  621319
, а то под ней до следующей жирной в сумме 87671
у мну такие суммы вышли по вашей таблице[vba]
Код
CHHATTISGARH 249632
Koriya       94653
Bharatpur    46439
Baikunthpur  7511
[/vba] правильно?

Автор - krosav4ig
Дата добавления - 12.03.2019 в 14:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!