Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выводить разницу между числом диапазона и срзнач диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выводить разницу между числом диапазона и срзнач диапазона (Формулы/Formulas)
Выводить разницу между числом диапазона и срзнач диапазона
Russt Дата: Среда, 13.03.2019, 09:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В столбце имеются диапазоны по 10 чисел каждый, разделенные пустой ячейкой. Необходимо напротив каждого числа выводить разницу между этим числом и средним значением диапазона.
К сообщению приложен файл: razn1303.xls(25.5 Kb)
 
Ответить
СообщениеВ столбце имеются диапазоны по 10 чисел каждый, разделенные пустой ячейкой. Необходимо напротив каждого числа выводить разницу между этим числом и средним значением диапазона.

Автор - Russt
Дата добавления - 13.03.2019 в 09:26
_Boroda_ Дата: Среда, 13.03.2019, 10:00 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Диапазоны всегда по 10 и через одну пустую ячейку? Или может быть через 2,3,... пустых? Ячейки именно пустые или с каким-то текстом?
Есть ли в диапазонах нули и отрицательные значения?
Начало именно со строки 3 или это только пример, а на самом деле может быть с любой строки, не меньшей 2?
В общем случае вот так можно
Код
=ЕСЛИ(B3="";"";СРЗНАЧ(ИНДЕКС(B:B;ПРОСМОТР(;-1/(B$1:B2="");СТРОКА(B$1:B2))):ИНДЕКС(B:B;ПОИСКПОЗ(0=0;B4:B989="";)+СТРОКА()))-B3)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: razn1303_1.xls(38.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДиапазоны всегда по 10 и через одну пустую ячейку? Или может быть через 2,3,... пустых? Ячейки именно пустые или с каким-то текстом?
Есть ли в диапазонах нули и отрицательные значения?
Начало именно со строки 3 или это только пример, а на самом деле может быть с любой строки, не меньшей 2?
В общем случае вот так можно
Код
=ЕСЛИ(B3="";"";СРЗНАЧ(ИНДЕКС(B:B;ПРОСМОТР(;-1/(B$1:B2="");СТРОКА(B$1:B2))):ИНДЕКС(B:B;ПОИСКПОЗ(0=0;B4:B989="";)+СТРОКА()))-B3)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 13.03.2019 в 10:00
sboy Дата: Среда, 13.03.2019, 10:05 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2417
Репутация: 682 ±
Замечаний: 0% ±

Excel 2010
через одну пустую ячейку?

пустые или с каким-то текстом?

вариант с доп. столбцами
Код
=ЕПУСТО(B2)+A1

Код
=СРЗНАЧЕСЛИ($A$2:$A$30;A2;$B$2:$B$30)

Код
=ЕСЛИ(ЕПУСТО(B2);"";C2-B2)
К сообщению приложен файл: 2107607.xls(29.0 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
через одну пустую ячейку?

пустые или с каким-то текстом?

вариант с доп. столбцами
Код
=ЕПУСТО(B2)+A1

Код
=СРЗНАЧЕСЛИ($A$2:$A$30;A2;$B$2:$B$30)

Код
=ЕСЛИ(ЕПУСТО(B2);"";C2-B2)

Автор - sboy
Дата добавления - 13.03.2019 в 10:05
Russt Дата: Среда, 13.03.2019, 10:36 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
иапазоны всегда по 10 и через одну пустую ячейку? Или может быть через 2,3,... пустых? Ячейки именно пустые или с каким-то текстом?
Есть ли в диапазонах нули и отрицательные значения?
Начало именно со строки 3 или это только пример, а на самом деле может быть с любой строки, не меньшей 2?


Диапазоны всегда по 10 через одну точно пустую ячейку.
Нулей и отрицательных значений нет.
Начало именно со строки 3.
 
Ответить
Сообщение
иапазоны всегда по 10 и через одну пустую ячейку? Или может быть через 2,3,... пустых? Ячейки именно пустые или с каким-то текстом?
Есть ли в диапазонах нули и отрицательные значения?
Начало именно со строки 3 или это только пример, а на самом деле может быть с любой строки, не меньшей 2?


Диапазоны всегда по 10 через одну точно пустую ячейку.
Нулей и отрицательных значений нет.
Начало именно со строки 3.

Автор - Russt
Дата добавления - 13.03.2019 в 10:36
Russt Дата: Среда, 13.03.2019, 10:47 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо! Быстро и самое что надо!
 
Ответить
СообщениеСпасибо! Быстро и самое что надо!

Автор - Russt
Дата добавления - 13.03.2019 в 10:47
_Boroda_ Дата: Среда, 13.03.2019, 10:58 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда проще
Код
=ЕСЛИ(B3="";"";СРЗНАЧ(ИНДЕКС(B:B;ОТБР((СТРОКА()+8)/11)*11-8):ИНДЕКС(B:B;ОТБР((СТРОКА()+8)/11)*11+2))-B3)
К сообщению приложен файл: razn1303_2.xls(42.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда проще
Код
=ЕСЛИ(B3="";"";СРЗНАЧ(ИНДЕКС(B:B;ОТБР((СТРОКА()+8)/11)*11-8):ИНДЕКС(B:B;ОТБР((СТРОКА()+8)/11)*11+2))-B3)

Автор - _Boroda_
Дата добавления - 13.03.2019 в 10:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выводить разницу между числом диапазона и срзнач диапазона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!