Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка зависимых диапазонов ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка зависимых диапазонов ячеек (Формулы/Formulas)
Вставка зависимых диапазонов ячеек
Liof78 Дата: Пятница, 15.03.2019, 10:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день!
Необходимо, чтобы при изменении ячейки В14 в диапазон D16:G18? вставлялся диапазон P55:S57, который соответствует ячейке B14. Возможно ли прописать такую формулу, или же в каждой ячейке прописывать зависимость?
К сообщению приложен файл: _v_2.1.xlsx(21.3 Kb)
 
Ответить
СообщениеДобрый день!
Необходимо, чтобы при изменении ячейки В14 в диапазон D16:G18? вставлялся диапазон P55:S57, который соответствует ячейке B14. Возможно ли прописать такую формулу, или же в каждой ячейке прописывать зависимость?

Автор - Liof78
Дата добавления - 15.03.2019 в 10:46
_Boroda_ Дата: Пятница, 15.03.2019, 11:58 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14424
Репутация: 5774 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;ПОИСКПОЗ(ПРОСМОТР(;-1/(B$12:B15<>"");B$11:B14);P$1:P$999;)+СТРОКА()+ПРОСМОТР(;-СТРОКА($12:15)/(B$12:B15<>"")));"")

Для всех ячеек и любого количества номеров
К сообщению приложен файл: _v_2.1_1.xlsx(21.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;ПОИСКПОЗ(ПРОСМОТР(;-1/(B$12:B15<>"");B$11:B14);P$1:P$999;)+СТРОКА()+ПРОСМОТР(;-СТРОКА($12:15)/(B$12:B15<>"")));"")

Для всех ячеек и любого количества номеров

Автор - _Boroda_
Дата добавления - 15.03.2019 в 11:58
Liof78 Дата: Пятница, 15.03.2019, 12:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо огромное за Ваше время. Решил пойти по меньшему сопротивлению, прописал исходники в строчку. Через ВПР работает. Формулу в копилку.
 
Ответить
СообщениеСпасибо огромное за Ваше время. Решил пойти по меньшему сопротивлению, прописал исходники в строчку. Через ВПР работает. Формулу в копилку.

Автор - Liof78
Дата добавления - 15.03.2019 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка зависимых диапазонов ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!