Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос только тех значений диапазона - что идут до ошибки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос только тех значений диапазона - что идут до ошибки (Формулы/Formulas)
Перенос только тех значений диапазона - что идут до ошибки
DimOzerov Дата: Воскресенье, 17.03.2019, 22:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер.
Помогите разобраться с непростой задачей.

В общем - есть таблица B6:B20.
Часть ее занята - некими текстовыми значениями, а другая часть ошибками или нулями.
И еще есть ячейка C2 - с текстом.

Как формулой перенести текстовые данные в диапазон H6:H20, которые встречаются до первого обозначения ошибки (или нуля), а потом еще добавить один раз значение из C2 ?

И если во всем диапазоне M6:M20 - одинаковые значения - то как вставить в диапазон S6:S20 - только самое первое значение, а затем добавить значение C2 ?
К сообщению приложен файл: 56886-.xls(45.5 Kb)
 
Ответить
СообщениеДобрый вечер.
Помогите разобраться с непростой задачей.

В общем - есть таблица B6:B20.
Часть ее занята - некими текстовыми значениями, а другая часть ошибками или нулями.
И еще есть ячейка C2 - с текстом.

Как формулой перенести текстовые данные в диапазон H6:H20, которые встречаются до первого обозначения ошибки (или нуля), а потом еще добавить один раз значение из C2 ?

И если во всем диапазоне M6:M20 - одинаковые значения - то как вставить в диапазон S6:S20 - только самое первое значение, а затем добавить значение C2 ?

Автор - DimOzerov
Дата добавления - 17.03.2019 в 22:19
bmv98rus Дата: Воскресенье, 17.03.2019, 22:52 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
Вариант сложный и массивный
Код
=IF(ROW(A1)>MATCH(1=1;ISNA($B$6:$B$20););"";IF(ISNA(B6);$C$2;B6))

Простой
Код
=IF(ISNA(B6);IF(ISNA(B5);"";$C$2);B6)


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеВариант сложный и массивный
Код
=IF(ROW(A1)>MATCH(1=1;ISNA($B$6:$B$20););"";IF(ISNA(B6);$C$2;B6))

Простой
Код
=IF(ISNA(B6);IF(ISNA(B5);"";$C$2);B6)

Автор - bmv98rus
Дата добавления - 17.03.2019 в 22:52
DimOzerov Дата: Воскресенье, 17.03.2019, 23:11 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
bmv98rus, не работает не тот ни другой
К сообщению приложен файл: 56886-2.xls(49.0 Kb)
 
Ответить
Сообщениеbmv98rus, не работает не тот ни другой

Автор - DimOzerov
Дата добавления - 17.03.2019 в 23:11
bmv98rus Дата: Воскресенье, 17.03.2019, 23:14 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
ну уж сделайте усилие, переведите на русский названия функций.


Замечательный медведь, процентов на 20.
 
Ответить
Сообщениену уж сделайте усилие, переведите на русский названия функций.

Автор - bmv98rus
Дата добавления - 17.03.2019 в 23:14
DimOzerov Дата: Воскресенье, 17.03.2019, 23:53 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
bmv98rus, вот та формула, которая более сложная - она работает.

А как обработать столбец M6:M20 ?
 
Ответить
Сообщениеbmv98rus, вот та формула, которая более сложная - она работает.

А как обработать столбец M6:M20 ?

Автор - DimOzerov
Дата добавления - 17.03.2019 в 23:53
gling Дата: Понедельник, 18.03.2019, 00:01 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
Еще страшный вариант.
Код
=ЕСЛИ(СЧЁТЕСЛИ($J$5:J5;ЕСЛИОШИБКА(ИНДЕКС(B$6:B$255;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(J$5:J5;B$6:B$255)=0)*(B$6:B$255<>"")*(B$6:B$255<>0);0);0));$C$2));"";ЕСЛИОШИБКА(ИНДЕКС(B$6:B$255;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(J$5:J5;B$6:B$255)=0)*(B$6:B$255<>"")*(B$6:B$255<>0);0);0));$C$2))
Собирает уникальные из столбца.


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 18.03.2019, 00:02
 
Ответить
СообщениеЕще страшный вариант.
Код
=ЕСЛИ(СЧЁТЕСЛИ($J$5:J5;ЕСЛИОШИБКА(ИНДЕКС(B$6:B$255;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(J$5:J5;B$6:B$255)=0)*(B$6:B$255<>"")*(B$6:B$255<>0);0);0));$C$2));"";ЕСЛИОШИБКА(ИНДЕКС(B$6:B$255;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(J$5:J5;B$6:B$255)=0)*(B$6:B$255<>"")*(B$6:B$255<>0);0);0));$C$2))
Собирает уникальные из столбца.

Автор - gling
Дата добавления - 18.03.2019 в 00:01
DimOzerov Дата: Понедельник, 18.03.2019, 00:21 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, не работает эта формула.

А как обработать столбец M6:M20 ?
 
Ответить
Сообщениеgling, не работает эта формула.

А как обработать столбец M6:M20 ?

Автор - DimOzerov
Дата добавления - 18.03.2019 в 00:21
gling Дата: Понедельник, 18.03.2019, 00:46 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
gling, не работает эта формула.
А у меня работает и обрабатывает данные похожие на столбец M6:M20. Возможно Вам не это нужно? Скопируйте данные из столбца М в столбец В. Результат получите в столбце J.
К сообщению приложен файл: 8446967.xls(49.5 Kb)


ЯД-41001506838083
 
Ответить
Сообщение
gling, не работает эта формула.
А у меня работает и обрабатывает данные похожие на столбец M6:M20. Возможно Вам не это нужно? Скопируйте данные из столбца М в столбец В. Результат получите в столбце J.

Автор - gling
Дата добавления - 18.03.2019 в 00:46
DimOzerov Дата: Понедельник, 18.03.2019, 01:31 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, да, действительно работает.

Теперь проблема решена.
Спасибо всем за советы.
 
Ответить
Сообщениеgling, да, действительно работает.

Теперь проблема решена.
Спасибо всем за советы.

Автор - DimOzerov
Дата добавления - 18.03.2019 в 01:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос только тех значений диапазона - что идут до ошибки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!