Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование строки из диапазона по трем условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование строки из диапазона по трем условиям (Макросы/Sub)
Копирование строки из диапазона по трем условиям
RagnarLodbrokovitch Дата: Вторник, 19.03.2019, 17:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Подскажите решение задачи с извлечением данных из таблицы - формулой.

Есть большая таблица T4:Y64 в ней находится много данных.
Рядом находится маленькая таблица B42:E56 - в которую надо перенести выборочные данные - из большой таблицы - по определенным условиям.

Условия всего три.
Первое условие находится в ячейке B33. Текст записанный в этой ячейке - ищется по столбцу W4:W64
Второе условие находится в ячейке B35. Текст записанный в этой ячейке - ищется по столбцу X4:X64
Третье условие записано в ячейке C40. Текст записанный в этой ячейке - ищется по столбцу Y4:Y64

Как должна выглядеть формула - копирующая данные из большой таблицы в малую - с условием нахождения в ней - текста из ячеек B33,B35,C40 ?

То есть - если формула находит, что все эти три текста - находятся в одной какой-то строке таблицы, то та часть строки -которая занимает столбцы T,U,V - переносится в маленькую табличку B42:E56.
В файле показал как заполняются еще две маленькие таблицы - для примера.
К сообщению приложен файл: 5768889.xls(53.0 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите решение задачи с извлечением данных из таблицы - формулой.

Есть большая таблица T4:Y64 в ней находится много данных.
Рядом находится маленькая таблица B42:E56 - в которую надо перенести выборочные данные - из большой таблицы - по определенным условиям.

Условия всего три.
Первое условие находится в ячейке B33. Текст записанный в этой ячейке - ищется по столбцу W4:W64
Второе условие находится в ячейке B35. Текст записанный в этой ячейке - ищется по столбцу X4:X64
Третье условие записано в ячейке C40. Текст записанный в этой ячейке - ищется по столбцу Y4:Y64

Как должна выглядеть формула - копирующая данные из большой таблицы в малую - с условием нахождения в ней - текста из ячеек B33,B35,C40 ?

То есть - если формула находит, что все эти три текста - находятся в одной какой-то строке таблицы, то та часть строки -которая занимает столбцы T,U,V - переносится в маленькую табличку B42:E56.
В файле показал как заполняются еще две маленькие таблицы - для примера.

Автор - RagnarLodbrokovitch
Дата добавления - 19.03.2019 в 17:10
sboy Дата: Вторник, 19.03.2019, 17:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Сделал для первой таблицы (для остальных по аналогии)
Код
=ЕСЛИОШИБКА(ИНДЕКС(T$4:T$56;АГРЕГАТ(15;6;(СТРОКА($T$4:$T$56)-3)/(($Y$4:$Y$56=$C$40)*($W$4:$W$56=$B$33)*($X$4:$X$56=$B$35));СТРОКА(A1)));"")

нумерация
Код
=ЕСЛИ(ЕТЕКСТ(D42);"";СЧЁТ($D$42:D42))
К сообщению приложен файл: 8120284.xls(55.5 Kb)


Яндекс: 410016850021169

Сообщение отредактировал sboy - Вторник, 19.03.2019, 17:52
 
Ответить
СообщениеДобрый день.
Сделал для первой таблицы (для остальных по аналогии)
Код
=ЕСЛИОШИБКА(ИНДЕКС(T$4:T$56;АГРЕГАТ(15;6;(СТРОКА($T$4:$T$56)-3)/(($Y$4:$Y$56=$C$40)*($W$4:$W$56=$B$33)*($X$4:$X$56=$B$35));СТРОКА(A1)));"")

нумерация
Код
=ЕСЛИ(ЕТЕКСТ(D42);"";СЧЁТ($D$42:D42))

Автор - sboy
Дата добавления - 19.03.2019 в 17:35
_Boroda_ Дата: Вторник, 19.03.2019, 17:35 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(T:T;НАИМЕНЬШИЙ(ЕСЛИ(($W$4:$W$64=$B$33)*($X$4:$X$64=$B$35)*($Y$4:$Y$64=$C$40);СТРОКА(T$4:T$64));СТРОКА(C1)));"")
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Нумерация
Код
=ЕСЛИ(C42="";"";B41+1)


Если формула, то почему вопрос в ветке VBA? Переношу
К сообщению приложен файл: 5768889_1.xls(66.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(T:T;НАИМЕНЬШИЙ(ЕСЛИ(($W$4:$W$64=$B$33)*($X$4:$X$64=$B$35)*($Y$4:$Y$64=$C$40);СТРОКА(T$4:T$64));СТРОКА(C1)));"")
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Нумерация
Код
=ЕСЛИ(C42="";"";B41+1)


Если формула, то почему вопрос в ветке VBA? Переношу

Автор - _Boroda_
Дата добавления - 19.03.2019 в 17:35
RagnarLodbrokovitch Дата: Вторник, 19.03.2019, 17:43 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, не работает
 
Ответить
Сообщениеsboy, не работает

Автор - RagnarLodbrokovitch
Дата добавления - 19.03.2019 в 17:43
RagnarLodbrokovitch Дата: Вторник, 19.03.2019, 17:43 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, все работает.
Спасибо.
 
Ответить
Сообщение_Boroda_, все работает.
Спасибо.

Автор - RagnarLodbrokovitch
Дата добавления - 19.03.2019 в 17:43
sboy Дата: Вторник, 19.03.2019, 17:53 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Цитата RagnarLodbrokovitch, 19.03.2019 в 17:43, в сообщении № 4 ()
не работает

ага, условия потерялись. Исправил, перевложил файл


Яндекс: 410016850021169
 
Ответить
Сообщение
Цитата RagnarLodbrokovitch, 19.03.2019 в 17:43, в сообщении № 4 ()
не работает

ага, условия потерялись. Исправил, перевложил файл

Автор - sboy
Дата добавления - 19.03.2019 в 17:53
RagnarLodbrokovitch Дата: Среда, 20.03.2019, 03:18 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, спасибо
 
Ответить
Сообщениеsboy, спасибо

Автор - RagnarLodbrokovitch
Дата добавления - 20.03.2019 в 03:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование строки из диапазона по трем условиям (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!