Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Из нескольких столбцов сделать один без пустых ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из нескольких столбцов сделать один без пустых ячеек (Формулы/Formulas)
Из нескольких столбцов сделать один без пустых ячеек
Ikusya Дата: Среда, 20.03.2019, 10:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро!
Подскажите, пожалуйста.

Первоначальной целью было формирование одного столбца из нескольких без пробелов и повторов, и в принципе эта цель была достигнута на листе 1 с помощью формулы:
Код
=SUBSTITUTE(SMALL(--LEFTB(TRIM($A$2:$F$173)&99999999;8);1+SUM(COUNTIF(A$2:F$173;"*"&I$1:I1&"*")));99999999;)


Но на листе 2 если произвести увеличение диапазона (с корректировкой диапазона и в формуле, разуеется), то формула насчитывает почти в два раза меньше значений, а если вдобавок к этому еще вводить данные не всегда в формате номер-фамилия, а оставить только номер, то вообще считается только несколько значений и далее происходит повтор одного и того же номера (для сравнения, на листе 1 и 2 количество заполненных ячеек одинаково)

Подскажите, пожалуйста, можно ли как-то формулу скорректировать, чтобы она охватывала более широкий диапазон и была возможность в качестве данных вводить только номер :)
К сообщению приложен файл: 7302905-1-.xlsx(38.7 Kb)
 
Ответить
СообщениеДоброе утро!
Подскажите, пожалуйста.

Первоначальной целью было формирование одного столбца из нескольких без пробелов и повторов, и в принципе эта цель была достигнута на листе 1 с помощью формулы:
Код
=SUBSTITUTE(SMALL(--LEFTB(TRIM($A$2:$F$173)&99999999;8);1+SUM(COUNTIF(A$2:F$173;"*"&I$1:I1&"*")));99999999;)


Но на листе 2 если произвести увеличение диапазона (с корректировкой диапазона и в формуле, разуеется), то формула насчитывает почти в два раза меньше значений, а если вдобавок к этому еще вводить данные не всегда в формате номер-фамилия, а оставить только номер, то вообще считается только несколько значений и далее происходит повтор одного и того же номера (для сравнения, на листе 1 и 2 количество заполненных ячеек одинаково)

Подскажите, пожалуйста, можно ли как-то формулу скорректировать, чтобы она охватывала более широкий диапазон и была возможность в качестве данных вводить только номер :)

Автор - Ikusya
Дата добавления - 20.03.2019 в 10:22
_Boroda_ Дата: Среда, 20.03.2019, 11:15 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИОШИБКА(--ЛЕВБ(A$4:O$22;ПОИСК(" ";A$4:O$22&" "));"");СТРОКА(S1));"")

Уникальные
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИОШИБКА(--ЛЕВБ(A$4:O$22;ПОИСК(" ";A$4:O$22&" "));"");1+СУММПРОИЗВ(СЧЁТЕСЛИ(A$4:O$22;T$2:T2&{"";"*"})));"")


Формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 7302905-1-1.xlsx(40.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИОШИБКА(--ЛЕВБ(A$4:O$22;ПОИСК(" ";A$4:O$22&" "));"");СТРОКА(S1));"")

Уникальные
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИОШИБКА(--ЛЕВБ(A$4:O$22;ПОИСК(" ";A$4:O$22&" "));"");1+СУММПРОИЗВ(СЧЁТЕСЛИ(A$4:O$22;T$2:T2&{"";"*"})));"")


Формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 20.03.2019 в 11:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из нескольких столбцов сделать один без пустых ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!