Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/счётесли как исключить подсчет числе в формате текста? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счётесли как исключить подсчет числе в формате текста? (Формулы/Formulas)
счётесли как исключить подсчет числе в формате текста?
MFor Дата: Четверг, 21.03.2019, 13:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.
Мне нужно узнать если ли в массиве числа 8 и 9. В одной из ячеек есть текстовое значение '08.

решил, что можно просто подсчитать количество ячеек с помощью
Код
=СЧЁТЕСЛИ(A3:E3;8)+СЧЁТЕСЛИ(A3:E3;9)
, но значение '08 также воспринимается как 8. Как исключить подсчет ячеек с числами записанными как текст?

P.S.
Почему СУММЕСЛИ считает '08 как 0, а СЧЁТЕСЛИ считает как 8?

Спасибо!
К сообщению приложен файл: 6572394.xlsx(9.0 Kb)


Сообщение отредактировал MFor - Четверг, 21.03.2019, 14:25
 
Ответить
СообщениеЗдравствуйте.
Мне нужно узнать если ли в массиве числа 8 и 9. В одной из ячеек есть текстовое значение '08.

решил, что можно просто подсчитать количество ячеек с помощью
Код
=СЧЁТЕСЛИ(A3:E3;8)+СЧЁТЕСЛИ(A3:E3;9)
, но значение '08 также воспринимается как 8. Как исключить подсчет ячеек с числами записанными как текст?

P.S.
Почему СУММЕСЛИ считает '08 как 0, а СЧЁТЕСЛИ считает как 8?

Спасибо!

Автор - MFor
Дата добавления - 21.03.2019 в 13:20
sboy Дата: Четверг, 21.03.2019, 13:31 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2455
Репутация: 690 ±
Замечаний: 0% ±

Excel 2010
Ответ удален администрацией


Яндекс: 410016850021169
 
Ответить
СообщениеОтвет удален администрацией

Автор - sboy
Дата добавления - 21.03.2019 в 13:31
_Boroda_ Дата: Четверг, 21.03.2019, 13:50 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
MFor, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеMFor, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 21.03.2019 в 13:50
MFor Дата: Четверг, 21.03.2019, 14:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
- Оформите формулу тегами


Так?
 
Ответить
Сообщение
- Оформите формулу тегами


Так?

Автор - MFor
Дата добавления - 21.03.2019 в 14:26
_Boroda_ Дата: Четверг, 21.03.2019, 15:08 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ага, так
Сразу скажу, что СУММЕСЛИ считает также - см. пример. Суммируются 8 и 08, а поскольку 08 - это текст, то он не считается - 8+08=8
С...ЕСЛИ иногда бывают слишком умными - сами пытаются преобразовать в числа свои аргументы. Причем только первый и второй, на третий аргумент в СУММЕСЛИ это почему-то не распространяется. Вот так заложено в принцип работы функции
Можнор использовать другие функции (как раз ответ выше был с функцией СУММПРОИЗВ, ниже пара вариантов, может они и были, я не смотрел, что там конкретно написано было)
Код
=СУММПРОИЗВ((A3:E3=8)+(A3:E3=9))

Код
=СУММПРОИЗВ(--(A3:E3={8:9}))

Если же очень хочется именно СЧЁТЕСЛИ, то такой вариант
Код
=СЧЁТЗ(3:3)*2-СУММПРОИЗВ(СЧЁТЕСЛИ(A3:E3;{"<>8";"<>9"}))
К сообщению приложен файл: 6572394_1.xlsx(9.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАга, так
Сразу скажу, что СУММЕСЛИ считает также - см. пример. Суммируются 8 и 08, а поскольку 08 - это текст, то он не считается - 8+08=8
С...ЕСЛИ иногда бывают слишком умными - сами пытаются преобразовать в числа свои аргументы. Причем только первый и второй, на третий аргумент в СУММЕСЛИ это почему-то не распространяется. Вот так заложено в принцип работы функции
Можнор использовать другие функции (как раз ответ выше был с функцией СУММПРОИЗВ, ниже пара вариантов, может они и были, я не смотрел, что там конкретно написано было)
Код
=СУММПРОИЗВ((A3:E3=8)+(A3:E3=9))

Код
=СУММПРОИЗВ(--(A3:E3={8:9}))

Если же очень хочется именно СЧЁТЕСЛИ, то такой вариант
Код
=СЧЁТЗ(3:3)*2-СУММПРОИЗВ(СЧЁТЕСЛИ(A3:E3;{"<>8";"<>9"}))

Автор - _Boroda_
Дата добавления - 21.03.2019 в 15:08
Nic70y Дата: Четверг, 21.03.2019, 20:17 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5220
Репутация: 1131 ±
Замечаний: 0% ±

Excel 2013
СУММЕСЛИ считает
так почему ей не пользуетесь?
Код
=СУММЕСЛИ(A3:E3;8)/8+СУММЕСЛИ(A3:E3;9)/9


ЯД(poison) 41001841029809
 
Ответить
Сообщение
СУММЕСЛИ считает
так почему ей не пользуетесь?
Код
=СУММЕСЛИ(A3:E3;8)/8+СУММЕСЛИ(A3:E3;9)/9

Автор - Nic70y
Дата добавления - 21.03.2019 в 20:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счётесли как исключить подсчет числе в формате текста? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!