Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значений я чейки в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений я чейки в столбце (Формулы/Formulas)
Поиск значений я чейки в столбце
Espada Дата: Четверг, 21.03.2019, 14:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня, подскажите пожалуйста, как решить такую проблемку: Есть столбец А(лист 2), нужно сравнить есть ли значения из столбца А(на листе 2), в столбце Е (на Листе 1)? проблема в том ,что в столбце Е(на Листе 1), может быть сразу несколько значений, т.е. как я понимаю поиск должен идти по подстроке, а не полному совпадению. пробовал =ПОИСКПОЗ(), но он отображал, только когда полное совпадение ячеек. пример файла приложил
К сообщению приложен файл: 9348116.xlsx(13.8 Kb)
 
Ответить
СообщениеДоброго дня, подскажите пожалуйста, как решить такую проблемку: Есть столбец А(лист 2), нужно сравнить есть ли значения из столбца А(на листе 2), в столбце Е (на Листе 1)? проблема в том ,что в столбце Е(на Листе 1), может быть сразу несколько значений, т.е. как я понимаю поиск должен идти по подстроке, а не полному совпадению. пробовал =ПОИСКПОЗ(), но он отображал, только когда полное совпадение ячеек. пример файла приложил

Автор - Espada
Дата добавления - 21.03.2019 в 14:19
Espada Дата: Четверг, 21.03.2019, 14:22 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

более понятный файл)
К сообщению приложен файл: 2872142.xlsx(11.5 Kb)
 
Ответить
Сообщениеболее понятный файл)

Автор - Espada
Дата добавления - 21.03.2019 в 14:22
_Boroda_ Дата: Четверг, 21.03.2019, 14:42 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СЧЁТ(ПОИСКПОЗ("*"&A2&",*";Лист1!E$2:E$99&",";))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Попроще
Код
=СЧЁТЕСЛИ(Лист1!E:E;"*"&A2&"*")

Или массивная
Код
=СЧЁТ(ПОИСК(A2;Лист1!E$2:E$99))

Код
=СЧЁТ(ИНДЕКС(ПОИСК(A2;Лист1!E$2:E$99);))
К сообщению приложен файл: 2872142_1.xlsx(12.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СЧЁТ(ПОИСКПОЗ("*"&A2&",*";Лист1!E$2:E$99&",";))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Попроще
Код
=СЧЁТЕСЛИ(Лист1!E:E;"*"&A2&"*")

Или массивная
Код
=СЧЁТ(ПОИСК(A2;Лист1!E$2:E$99))

Код
=СЧЁТ(ИНДЕКС(ПОИСК(A2;Лист1!E$2:E$99);))

Автор - _Boroda_
Дата добавления - 21.03.2019 в 14:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений я чейки в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!