Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка данных по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка данных по нескольким условиям (Формулы/Formulas)
Проверка данных по нескольким условиям
boshemokrie Дата: Воскресенье, 24.03.2019, 09:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Пытаюсь отредактировать файл с целью максимально ограничить возможные действия конечного пользователя и принудить корректно заполнить некоторые ячейки и все это категорически без использования макросов. Сам думал над этой задачей, ничего стоящего в голову не пришло. Может быть, кто-то сможет мне помочь?
Проблемы следующие:
В ячейке C1 сделал выпадающий список, «ВЫБЕРИТЕ НАЗВАНИЕ ТОЧКИ» тоже является одним из его пунктов, необходимо каким-либо образом вынудить конечного пользователя выбрать один из пунктов списка кроме «ВЫБЕРИТЕ НАЗВАНИЕ ТОЧКИ», проверку данных уже использовал для создания списка, как тут быть не представляю, к сожалению.
Также необходимо принудить конечного пользователя заполнить ячейку I1 и выполнить сравнение ячейки I1 с ячейкой I2, в случае если числовое значение ячейки I2 превышает значение в ячейке I1 тоже должна выводится ошибка. Как это сделать с привязкой к проверке данных с трудом представляю. Может быть, есть какие-то другие способы достичь данного эффекта?
Заранее спасибо за ответы!
К сообщению приложен файл: 9473557.xlsx(30.1 Kb)


Сообщение отредактировал boshemokrie - Воскресенье, 24.03.2019, 09:25
 
Ответить
СообщениеДобрый день!
Пытаюсь отредактировать файл с целью максимально ограничить возможные действия конечного пользователя и принудить корректно заполнить некоторые ячейки и все это категорически без использования макросов. Сам думал над этой задачей, ничего стоящего в голову не пришло. Может быть, кто-то сможет мне помочь?
Проблемы следующие:
В ячейке C1 сделал выпадающий список, «ВЫБЕРИТЕ НАЗВАНИЕ ТОЧКИ» тоже является одним из его пунктов, необходимо каким-либо образом вынудить конечного пользователя выбрать один из пунктов списка кроме «ВЫБЕРИТЕ НАЗВАНИЕ ТОЧКИ», проверку данных уже использовал для создания списка, как тут быть не представляю, к сожалению.
Также необходимо принудить конечного пользователя заполнить ячейку I1 и выполнить сравнение ячейки I1 с ячейкой I2, в случае если числовое значение ячейки I2 превышает значение в ячейке I1 тоже должна выводится ошибка. Как это сделать с привязкой к проверке данных с трудом представляю. Может быть, есть какие-то другие способы достичь данного эффекта?
Заранее спасибо за ответы!

Автор - boshemokrie
Дата добавления - 24.03.2019 в 09:20
Nic70y Дата: Воскресенье, 24.03.2019, 10:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5220
Репутация: 1131 ±
Замечаний: 0% ±

Excel 2013
Пытаюсь отредактировать файл с целью максимально ограничить возможные действия конечного пользователя
дальше не читал. используйте ЮзерФорму (прикольная штука)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Пытаюсь отредактировать файл с целью максимально ограничить возможные действия конечного пользователя
дальше не читал. используйте ЮзерФорму (прикольная штука)

Автор - Nic70y
Дата добавления - 24.03.2019 в 10:10
_Boroda_ Дата: Воскресенье, 24.03.2019, 15:56 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тоже проверка данных (серые ячейки)
Код
=$C$1<>Лист2!$A$1

Ограничение на бумагу пишем формулой в G8
Код
=ЕСЛИ(F8>100;"Слишком много бумаги";F8*D8)

Сравнение с бюджетом тоже формулой и подкраской в Условном форматировании
Код
=ЕСЛИ(СУММ(G3:G999)>I1;"Денег нет, но вы держитесь";СУММ(G3:G66))


И не пишите ВПР на целиковые столбца во втором аргументе, думает дольше. Вот так быстрее будет
Код
= ВПР(B3;Лист1!$A$1:$F$999;6;0)
К сообщению приложен файл: 9473557_1.xlsx(31.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТоже проверка данных (серые ячейки)
Код
=$C$1<>Лист2!$A$1

Ограничение на бумагу пишем формулой в G8
Код
=ЕСЛИ(F8>100;"Слишком много бумаги";F8*D8)

Сравнение с бюджетом тоже формулой и подкраской в Условном форматировании
Код
=ЕСЛИ(СУММ(G3:G999)>I1;"Денег нет, но вы держитесь";СУММ(G3:G66))


И не пишите ВПР на целиковые столбца во втором аргументе, думает дольше. Вот так быстрее будет
Код
= ВПР(B3;Лист1!$A$1:$F$999;6;0)

Автор - _Boroda_
Дата добавления - 24.03.2019 в 15:56
boshemokrie Дата: Среда, 03.04.2019, 11:46 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное!

Помогло!
 
Ответить
СообщениеСпасибо огромное!

Помогло!

Автор - boshemokrie
Дата добавления - 03.04.2019 в 11:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка данных по нескольким условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!