Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение данных (Формулы/Formulas)
Автоматическое заполнение данных
OYakshe Дата: Воскресенье, 24.03.2019, 18:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер, прошу помочь с автоматизацией работы. Скачиваю для обработки метеоданные за каждые сутки с июня по август. Попадаются дни, когда данные по температуре отсутствуют. Приходится каждый раз просматривать и вручную проставлять температуру. Какую формулу применить, чтобы в пустой ячейке проставлялась среднее арифметическое значение температуры за сутки между предыдущим и следующим днем?
К сообщению приложен файл: 5629692.xlsx(8.8 Kb)
 
Ответить
СообщениеДобрый вечер, прошу помочь с автоматизацией работы. Скачиваю для обработки метеоданные за каждые сутки с июня по август. Попадаются дни, когда данные по температуре отсутствуют. Приходится каждый раз просматривать и вручную проставлять температуру. Какую формулу применить, чтобы в пустой ячейке проставлялась среднее арифметическое значение температуры за сутки между предыдущим и следующим днем?

Автор - OYakshe
Дата добавления - 24.03.2019 в 18:41
Pelena Дата: Воскресенье, 24.03.2019, 19:29 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант формула массива
Код
=ЕСЛИ(B2<>0;B2;СУММ(E1;ИНДЕКС(B2:B$34;ПОИСКПОЗ(0=0;B2:B$34>0;0)))/2)
К сообщению приложен файл: 5855603.xlsx(11.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант формула массива
Код
=ЕСЛИ(B2<>0;B2;СУММ(E1;ИНДЕКС(B2:B$34;ПОИСКПОЗ(0=0;B2:B$34>0;0)))/2)

Автор - Pelena
Дата добавления - 24.03.2019 в 19:29
_Boroda_ Дата: Воскресенье, 24.03.2019, 19:59 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если несколько нулей подряд, то ведь нужно найти ненулевые значения выше и ниже и от них уже пропорционально количеству нулей считать, правильно?
Поэтому предлагаю так
Код
=ЕСЛИ(B2;B2;H3-(H3+1/ПРОСМОТР(;-1/B$1:B1))/(ПРОСМОТР(;-1/B$1:B1;$A$1:$A1)-$A3))

Обычная формула
Конечно первое и последнее значения таблицы не должны быть нулевыми

Кстати, OYakshe, а если температура реально равна 0, то как тогда?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли несколько нулей подряд, то ведь нужно найти ненулевые значения выше и ниже и от них уже пропорционально количеству нулей считать, правильно?
Поэтому предлагаю так
Код
=ЕСЛИ(B2;B2;H3-(H3+1/ПРОСМОТР(;-1/B$1:B1))/(ПРОСМОТР(;-1/B$1:B1;$A$1:$A1)-$A3))

Обычная формула
Конечно первое и последнее значения таблицы не должны быть нулевыми

Кстати, OYakshe, а если температура реально равна 0, то как тогда?

Автор - _Boroda_
Дата добавления - 24.03.2019 в 19:59
OYakshe Дата: Воскресенье, 24.03.2019, 23:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вопрос, конечно, сильно правильный. Если быть совсем точной, для своих расчетов беру суточные температуры с 15 июня по 5 августа. Для исследуемой зоны в этот период крайне мало вероятна нулевая температура. Меня только это спасает. Пока больше нет соображений на этот счет. Все работает, в очередной раз, СПАСИБО ОГРОМНОЕ!!!!!!!!!!!!!!!
 
Ответить
СообщениеВопрос, конечно, сильно правильный. Если быть совсем точной, для своих расчетов беру суточные температуры с 15 июня по 5 августа. Для исследуемой зоны в этот период крайне мало вероятна нулевая температура. Меня только это спасает. Пока больше нет соображений на этот счет. Все работает, в очередной раз, СПАСИБО ОГРОМНОЕ!!!!!!!!!!!!!!!

Автор - OYakshe
Дата добавления - 24.03.2019 в 23:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!