Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск названия ячейки, содержащей число - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск названия ячейки, содержащей число (Формулы/Formulas)
Поиск названия ячейки, содержащей число
baneska Дата: Пятница, 29.03.2019, 07:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, форумчане! Нуждаюсь в Вашей помощи.

В таблице имеется две строки: 1 - номер ячейки (A1:M1), 2 - значения (A2:M2). В ячейке O2 стоит формула для нахождения максимального значения из приведенных значений (A2:M2). Задача состоит в том, что нужно в O1 отобразить номер ячейки (A1:M1), которому соответствует максимальное значение.

Прошу Вашей помощи, без решения данного этапа не могу двинуться дальше.
К сообщению приложен файл: 3486934.xlsx(9.9 Kb)


Новичок
 
Ответить
СообщениеДобрый день, форумчане! Нуждаюсь в Вашей помощи.

В таблице имеется две строки: 1 - номер ячейки (A1:M1), 2 - значения (A2:M2). В ячейке O2 стоит формула для нахождения максимального значения из приведенных значений (A2:M2). Задача состоит в том, что нужно в O1 отобразить номер ячейки (A1:M1), которому соответствует максимальное значение.

Прошу Вашей помощи, без решения данного этапа не могу двинуться дальше.

Автор - baneska
Дата добавления - 29.03.2019 в 07:26
_Boroda_ Дата: Пятница, 29.03.2019, 07:46 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(1:1;ПОИСКПОЗ(O2;A2:M2;))

Код
=ПРОСМОТР(;-1/(O2=A2:M2);A1:M1)

Если Макс единственный, то
Код
=СУММЕСЛИ(A2:M2;O2;A1:M1)

Код
=СУММПРОИЗВ(A1:M1*(A2:M2=O2))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(1:1;ПОИСКПОЗ(O2;A2:M2;))

Код
=ПРОСМОТР(;-1/(O2=A2:M2);A1:M1)

Если Макс единственный, то
Код
=СУММЕСЛИ(A2:M2;O2;A1:M1)

Код
=СУММПРОИЗВ(A1:M1*(A2:M2=O2))

Автор - _Boroda_
Дата добавления - 29.03.2019 в 07:46
китин Дата: Пятница, 29.03.2019, 07:47 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5468
Репутация: 874 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Добрый! Тут все просто
Код
=ИНДЕКС($A$1:$M$1;ПОИСКПОЗ($O$2;$A$2:$M$2;0))

или сразу ищем МАКС
Код
=ИНДЕКС($A$1:$M$1;ПОИСКПОЗ(МАКС($A$2:$M$2);$A$2:$M$2;0))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДобрый! Тут все просто
Код
=ИНДЕКС($A$1:$M$1;ПОИСКПОЗ($O$2;$A$2:$M$2;0))

или сразу ищем МАКС
Код
=ИНДЕКС($A$1:$M$1;ПОИСКПОЗ(МАКС($A$2:$M$2);$A$2:$M$2;0))

Автор - китин
Дата добавления - 29.03.2019 в 07:47
baneska Дата: Пятница, 29.03.2019, 07:48 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Да, именно так. Спасибо, Вам, большое!


Новичок
 
Ответить
Сообщение_Boroda_, Да, именно так. Спасибо, Вам, большое!

Автор - baneska
Дата добавления - 29.03.2019 в 07:48
baneska Дата: Пятница, 29.03.2019, 07:49 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Знаю что просто, но своим ходом не додумалась. Спасибо большое за Вашу помощь!


Новичок

Сообщение отредактировал baneska - Пятница, 29.03.2019, 07:50
 
Ответить
Сообщениекитин, Знаю что просто, но своим ходом не додумалась. Спасибо большое за Вашу помощь!

Автор - baneska
Дата добавления - 29.03.2019 в 07:49
bmv98rus Дата: Пятница, 29.03.2019, 07:59 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2057
Репутация: 333 ±
Замечаний: 20% ±

Excel 2013/2016
и для изврата
Код
=HLOOKUP(O2;IF({1;2}=1;A2:M2;A1:M1);2;0)

Код
=HLOOKUP(O2;CHOOSE({1;2};A2:M2;A1:M1);2;0)


Замечательный медведь, процентов на 20.
 
Ответить
Сообщениеи для изврата
Код
=HLOOKUP(O2;IF({1;2}=1;A2:M2;A1:M1);2;0)

Код
=HLOOKUP(O2;CHOOSE({1;2};A2:M2;A1:M1);2;0)

Автор - bmv98rus
Дата добавления - 29.03.2019 в 07:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск названия ячейки, содержащей число (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!