Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/разнесение данных по листам/файлам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » разнесение данных по листам/файлам (Формулы/Formulas)
разнесение данных по листам/файлам
Denver77 Дата: Понедельник, 01.04.2019, 23:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Вечер добрый, господа знатоки.
Прошу помощи у вас и покорнейше прошу простить меня за излишнюю дотошность в некоторых моментах, но, к сожалению, пока сам не пойму как формула работает, не успокоюсь.
Генеральный план нападения прост: разнести данные из таблицы по листам (или файлам - это уж как посоветуете)
В приложенном файле из листа ОБЩАЯ надо вынести данные из столбцов с данными в одноименные листы (или отдельные файлы - как посоветуете). Для примера: из столбца СТЕНД1 ищется первое значение и выводится вместе с двумя соответствующими значениями из колонок КОНТРАГЕНТ и ОПИС.
Господа, прошу вас предложить решение с учетом описанных проблем:
количество строк таблицы к концу года может возрасти до 3000-5000;
количество столбцов (не факт конечно) может перевалить за 200;
данные появляются не сразу, а в течение нескольких месяцев и, соответственно, эти данные должны пополнять соответствующие листы/файлы;
Учитывая относительно большой объем данных, что в данном случае лучше использовать - сводную таблицу или формулы?
Нужно ли данные хранить как "ТАБЛИЦУ"? Я попытался использовать формулу структуры ИНДЕКС(НАИМЕНЬШИЙ(ЕСЛИ(СТРОКА для вытаскивания данных, но столкнулся с тем, что массив данных столбца таблицы он отображает корректно, а вот строки все равно гад считает по общей нумерации экселя (первая строка таблицы все равно как шестую отображает). Как с этим бороться так и не понял.
Убедительная просьба сделать пример, если стенд в отдельный файл сохранять.
Буду очень признателен за вашу помощь.
К сообщению приложен файл: __2.xlsx(13.8 Kb)
 
Ответить
СообщениеВечер добрый, господа знатоки.
Прошу помощи у вас и покорнейше прошу простить меня за излишнюю дотошность в некоторых моментах, но, к сожалению, пока сам не пойму как формула работает, не успокоюсь.
Генеральный план нападения прост: разнести данные из таблицы по листам (или файлам - это уж как посоветуете)
В приложенном файле из листа ОБЩАЯ надо вынести данные из столбцов с данными в одноименные листы (или отдельные файлы - как посоветуете). Для примера: из столбца СТЕНД1 ищется первое значение и выводится вместе с двумя соответствующими значениями из колонок КОНТРАГЕНТ и ОПИС.
Господа, прошу вас предложить решение с учетом описанных проблем:
количество строк таблицы к концу года может возрасти до 3000-5000;
количество столбцов (не факт конечно) может перевалить за 200;
данные появляются не сразу, а в течение нескольких месяцев и, соответственно, эти данные должны пополнять соответствующие листы/файлы;
Учитывая относительно большой объем данных, что в данном случае лучше использовать - сводную таблицу или формулы?
Нужно ли данные хранить как "ТАБЛИЦУ"? Я попытался использовать формулу структуры ИНДЕКС(НАИМЕНЬШИЙ(ЕСЛИ(СТРОКА для вытаскивания данных, но столкнулся с тем, что массив данных столбца таблицы он отображает корректно, а вот строки все равно гад считает по общей нумерации экселя (первая строка таблицы все равно как шестую отображает). Как с этим бороться так и не понял.
Убедительная просьба сделать пример, если стенд в отдельный файл сохранять.
Буду очень признателен за вашу помощь.

Автор - Denver77
Дата добавления - 01.04.2019 в 23:15
sboy Дата: Вторник, 02.04.2019, 09:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2444
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял
[vba]
Код
=ИНДЕКС(Таблица1;АГРЕГАТ(15;6;(СТРОКА(Таблица1[Контрагент])-СТРОКА(Таблица1[#Заголовки]))/ЕЧИСЛО(Таблица1[[стенд1]:[стенд1]]);СТРОКА(A1));ПОИСКПОЗ(A$5;Таблица1[#Заголовки];))
[/vba]
upd.
вот так для любого листа
[vba]
Код
=ИНДЕКС(Таблица1;АГРЕГАТ(15;6;(СТРОКА(Таблица1[Контрагент])-СТРОКА(Таблица1[#Заголовки]))/ЕЧИСЛО(ИНДЕКС(Таблица1;;ПОИСКПОЗ($C$5;Таблица1[#Заголовки];)));СТРОКА(A1));ПОИСКПОЗ(A$5;Таблица1[#Заголовки];))
[/vba]
К сообщению приложен файл: _2-1-.xlsx(18.6 Kb)


Яндекс: 410016850021169

Сообщение отредактировал sboy - Вторник, 02.04.2019, 09:21
 
Ответить
СообщениеДобрый день.
Если правильно понял
[vba]
Код
=ИНДЕКС(Таблица1;АГРЕГАТ(15;6;(СТРОКА(Таблица1[Контрагент])-СТРОКА(Таблица1[#Заголовки]))/ЕЧИСЛО(Таблица1[[стенд1]:[стенд1]]);СТРОКА(A1));ПОИСКПОЗ(A$5;Таблица1[#Заголовки];))
[/vba]
upd.
вот так для любого листа
[vba]
Код
=ИНДЕКС(Таблица1;АГРЕГАТ(15;6;(СТРОКА(Таблица1[Контрагент])-СТРОКА(Таблица1[#Заголовки]))/ЕЧИСЛО(ИНДЕКС(Таблица1;;ПОИСКПОЗ($C$5;Таблица1[#Заголовки];)));СТРОКА(A1));ПОИСКПОЗ(A$5;Таблица1[#Заголовки];))
[/vba]

Автор - sboy
Дата добавления - 02.04.2019 в 09:16
Denver77 Дата: Вторник, 02.04.2019, 18:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Спасибо огромное.
Буду разбираться с формулой )))
Как только с ней разберусь, сразу еще раз поблагодарю.
 
Ответить
СообщениеСпасибо огромное.
Буду разбираться с формулой )))
Как только с ней разберусь, сразу еще раз поблагодарю.

Автор - Denver77
Дата добавления - 02.04.2019 в 18:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » разнесение данных по листам/файлам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!