Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборочный перенос данных из одного листа в другой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочный перенос данных из одного листа в другой (Формулы/Formulas)
Выборочный перенос данных из одного листа в другой
GSeReGa Дата: Вторник, 02.04.2019, 10:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Суть проблемы такова. Можно ли сделать так, что бы внесенные данные из листа ГОД переносились в лист НЕДЕЛЯ (именно текущей недели, с понедельника по воскресенье) и далее в ДЕНЬ (текущий день). Данные вносятся в лист ГОД, но их потом нужно фильтровать и копировать в лист НЕДЕЛЯ и также в лист ДЕНЬ. Можно ли это как то автоматизировать?
К сообщению приложен файл: 5727860.xls(38.0 Kb)
 
Ответить
СообщениеДобрый день. Суть проблемы такова. Можно ли сделать так, что бы внесенные данные из листа ГОД переносились в лист НЕДЕЛЯ (именно текущей недели, с понедельника по воскресенье) и далее в ДЕНЬ (текущий день). Данные вносятся в лист ГОД, но их потом нужно фильтровать и копировать в лист НЕДЕЛЯ и также в лист ДЕНЬ. Можно ли это как то автоматизировать?

Автор - GSeReGa
Дата добавления - 02.04.2019 в 10:16
Pelena Дата: Вторник, 02.04.2019, 11:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Нарисуйте вручную, какой результат Вы хотите видеть на листе Неделя и День


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Нарисуйте вручную, какой результат Вы хотите видеть на листе Неделя и День

Автор - Pelena
Дата добавления - 02.04.2019 в 11:05
GSeReGa Дата: Вторник, 02.04.2019, 13:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, описал результат в файле.
К сообщению приложен файл: 1570460.xls(41.5 Kb)
 
Ответить
СообщениеPelena, описал результат в файле.

Автор - GSeReGa
Дата добавления - 02.04.2019 в 13:35
китин Дата: Вторник, 02.04.2019, 14:03 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5444
Репутация: 870 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как то так наверное
Код
=ЕСЛИОШИБКА(ИНДЕКС(ГОД!$A$2:$A$27;НАИМЕНЬШИЙ(ЕСЛИ((ГОД!$E$2:$E$27<=НЕДЕЛЯ!$H$3)*(ГОД!$E$2:$E$27>=НЕДЕЛЯ!$H$2);СТРОКА(ГОД!$A$2:$A$27)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
в зеленых ячейках выбираем дату
К сообщению приложен файл: GSeReGa22.xlsx(24.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак то так наверное
Код
=ЕСЛИОШИБКА(ИНДЕКС(ГОД!$A$2:$A$27;НАИМЕНЬШИЙ(ЕСЛИ((ГОД!$E$2:$E$27<=НЕДЕЛЯ!$H$3)*(ГОД!$E$2:$E$27>=НЕДЕЛЯ!$H$2);СТРОКА(ГОД!$A$2:$A$27)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
в зеленых ячейках выбираем дату

Автор - китин
Дата добавления - 02.04.2019 в 14:03
GSeReGa Дата: Среда, 03.04.2019, 13:17 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, по листу НЕДЕЛЯ получилось шикарно! Но вот по листу ДЕНЬ немного не ТО.
При вводе даты 02.04.2019 должны копироваться группы которые находятся на маршруте на сегодняшний день.
Т.е. если выставить фильтр "Дата возвращения" ПОСЛЕ 02.04.2019, то как раз и выходит, что на сегодняшний день в походе 4 группы
 
Ответить
Сообщениекитин, по листу НЕДЕЛЯ получилось шикарно! Но вот по листу ДЕНЬ немного не ТО.
При вводе даты 02.04.2019 должны копироваться группы которые находятся на маршруте на сегодняшний день.
Т.е. если выставить фильтр "Дата возвращения" ПОСЛЕ 02.04.2019, то как раз и выходит, что на сегодняшний день в походе 4 группы

Автор - GSeReGa
Дата добавления - 03.04.2019 в 13:17
GSeReGa Дата: Среда, 03.04.2019, 13:18 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прикрепил файл
К сообщению приложен файл: 1858863.xlsx(24.2 Kb)
 
Ответить
СообщениеПрикрепил файл

Автор - GSeReGa
Дата добавления - 03.04.2019 в 13:18
китин Дата: Среда, 03.04.2019, 13:27 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5444
Репутация: 870 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
поменять диапазон
Код
=ЕСЛИОШИБКА(ИНДЕКС(ГОД!$A$2:$A$27;НАИМЕНЬШИЙ(ЕСЛИ((ГОД!$F$2:$F$27>=ДЕНЬ!$H$2);СТРОКА(ГОД!$A$2:$A$27)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 242.xlsx(25.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениепоменять диапазон
Код
=ЕСЛИОШИБКА(ИНДЕКС(ГОД!$A$2:$A$27;НАИМЕНЬШИЙ(ЕСЛИ((ГОД!$F$2:$F$27>=ДЕНЬ!$H$2);СТРОКА(ГОД!$A$2:$A$27)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 03.04.2019 в 13:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочный перенос данных из одного листа в другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!