Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределить числа по столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределить числа по столбцам (Формулы/Formulas)
Распределить числа по столбцам
olshaid Дата: Вторник, 02.04.2019, 15:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день, уважаемые знатоки Excel
До сего момента использовала в программе только простенькие формулы и функции, мне для подготовки отчетов было достаточно, но вот столкнулась с необходимостью представить данные определенным образом - и для меня это оказалось непосильной задачей. Надеюсь кто-нибудь подскажет, как с ней справиться. Уже имеющиеся темы дисциплинированно просмотрела, но подходящего не нашла, если оно есть, но я пропустила, очень прошу - киньте ссылку.
Не уверена, что название темы сформулировала верно, если подскажите как поправить - непременно поправлю.
Задача следующая: числа, находящиеся в столбце В, необходимо распределить по столбцам таким образом, чтобы число совпадало с номером столбца. ( Число один отражалось в столбце с заголовком 1, число 2 в столбце с заголовком 2 и т.д.) На сегодняшний день максимальное число 5, но желательно чтобы можно было то же самое делать не только с числами от 1 до 5, но и с любыми другими целыми числами.
Исходные данные представила в файле 1. ТО, что должно получаться на выходе - в файле 2. В примере взяла 15 строк, но предполагается, что строк будет пара сотен.
Заранее благодарю всех, кто откликнется.
К сообщению приложен файл: 4472377.xlsx(9.1 Kb) · 6439038.xlsx(9.3 Kb)
 
Ответить
СообщениеДобрый день, уважаемые знатоки Excel
До сего момента использовала в программе только простенькие формулы и функции, мне для подготовки отчетов было достаточно, но вот столкнулась с необходимостью представить данные определенным образом - и для меня это оказалось непосильной задачей. Надеюсь кто-нибудь подскажет, как с ней справиться. Уже имеющиеся темы дисциплинированно просмотрела, но подходящего не нашла, если оно есть, но я пропустила, очень прошу - киньте ссылку.
Не уверена, что название темы сформулировала верно, если подскажите как поправить - непременно поправлю.
Задача следующая: числа, находящиеся в столбце В, необходимо распределить по столбцам таким образом, чтобы число совпадало с номером столбца. ( Число один отражалось в столбце с заголовком 1, число 2 в столбце с заголовком 2 и т.д.) На сегодняшний день максимальное число 5, но желательно чтобы можно было то же самое делать не только с числами от 1 до 5, но и с любыми другими целыми числами.
Исходные данные представила в файле 1. ТО, что должно получаться на выходе - в файле 2. В примере взяла 15 строк, но предполагается, что строк будет пара сотен.
Заранее благодарю всех, кто откликнется.

Автор - olshaid
Дата добавления - 02.04.2019 в 15:26
_Boroda_ Дата: Вторник, 02.04.2019, 15:45 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Перенеc начальную таблицу ниже итоговой
Код
=--(B$1=$B24)

Можно формат ячеек поставить
0;;

Предваряя вопрос про --
http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9
К сообщению приложен файл: 6439038_1.xlsx(12.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПеренеc начальную таблицу ниже итоговой
Код
=--(B$1=$B24)

Можно формат ячеек поставить
0;;

Предваряя вопрос про --
http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9

Автор - _Boroda_
Дата добавления - 02.04.2019 в 15:45
jakim Дата: Вторник, 02.04.2019, 15:49 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 895
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=ЕСЛИ($B2=ЧИСЛСТОЛБ($G:G);1;"")
К сообщению приложен файл: 4630253.xlsx(10.4 Kb)
 
Ответить
Сообщение
Формула

Код
=ЕСЛИ($B2=ЧИСЛСТОЛБ($G:G);1;"")

Автор - jakim
Дата добавления - 02.04.2019 в 15:49
olshaid Дата: Вторник, 02.04.2019, 16:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
ох, спасибо большущее, сейчас буду разбираться с обоими вариантами, надеюсь хватит мозгов понять.
 
Ответить
Сообщениеох, спасибо большущее, сейчас буду разбираться с обоими вариантами, надеюсь хватит мозгов понять.

Автор - olshaid
Дата добавления - 02.04.2019 в 16:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределить числа по столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!