Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/посчитать сумму через каждые 52 ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать сумму через каждые 52 ячейки (Формулы/Formulas)
посчитать сумму через каждые 52 ячейки
annmadman Дата: Вторник, 02.04.2019, 20:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, не могу приложить файл, так как уж очень большой. Суть вот в чём: есть таблица с 68993 строками, нужно произвести сумму каждых 52 ячеек X2:X53, X54:X105. Но есть моменты, где нужно суммировать каждые 53 ячейки (их мало), можно ли этот процесс как-то автоматизировать с помощью формулы?
 
Ответить
СообщениеЗдравствуйте, не могу приложить файл, так как уж очень большой. Суть вот в чём: есть таблица с 68993 строками, нужно произвести сумму каждых 52 ячеек X2:X53, X54:X105. Но есть моменты, где нужно суммировать каждые 53 ячейки (их мало), можно ли этот процесс как-то автоматизировать с помощью формулы?

Автор - annmadman
Дата добавления - 02.04.2019 в 20:48
Pelena Дата: Вторник, 02.04.2019, 21:01 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
А весь файл и не нужен. Приложите небольшой пример с сохранением структуры


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА весь файл и не нужен. Приложите небольшой пример с сохранением структуры

Автор - Pelena
Дата добавления - 02.04.2019 в 21:01
gling Дата: Вторник, 02.04.2019, 21:05 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
не могу приложить файл,

А в 200 строк и только со столбцом который нужно суммировать, тоже большой? И куда выводить каждую сумму, ведь должно получится 1326 результатов?


ЯД-41001506838083
 
Ответить
Сообщение
не могу приложить файл,

А в 200 строк и только со столбцом который нужно суммировать, тоже большой? И куда выводить каждую сумму, ведь должно получится 1326 результатов?

Автор - gling
Дата добавления - 02.04.2019 в 21:05
annmadman Дата: Вторник, 02.04.2019, 21:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
gling, Я знаю, результатов будет очень много, их делаю на отдельном листе.
К сообщению приложен файл: 11.xlsx(68.3 Kb)


Сообщение отредактировал annmadman - Вторник, 02.04.2019, 21:32
 
Ответить
Сообщениеgling, Я знаю, результатов будет очень много, их делаю на отдельном листе.

Автор - annmadman
Дата добавления - 02.04.2019 в 21:12
annmadman Дата: Вторник, 02.04.2019, 21:19 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, вот небольшая часть файла, результаты считаю на втором листе. там формула суммы только еще в степени и со знаком минус
К сообщению приложен файл: 9508829.xlsx(68.3 Kb)


Сообщение отредактировал annmadman - Вторник, 02.04.2019, 21:32
 
Ответить
СообщениеPelena, вот небольшая часть файла, результаты считаю на втором листе. там формула суммы только еще в степени и со знаком минус

Автор - annmadman
Дата добавления - 02.04.2019 в 21:19
_Boroda_ Дата: Вторник, 02.04.2019, 21:25 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Самое простое - использовать сводную таблицу. В Вашем файле почему-то у исходной таблицы шапки нет, поэтому добавил ее с произвольными названиями

Еще вариант
Выделяете целиком столбец А, копируете, переходите на новый лист, вставляете в ячейку А1, идете на вкладку Данные, жмете "Удалить дубликаты"
В ячейке В2 пишете формулу
Код
=СУММЕСЛИ(Лист1!A:A;A2;Лист1!X:X)
протягиваете ее вниз

Оба варианта в файле
К сообщению приложен файл: 11_1.xlsx(87.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСамое простое - использовать сводную таблицу. В Вашем файле почему-то у исходной таблицы шапки нет, поэтому добавил ее с произвольными названиями

Еще вариант
Выделяете целиком столбец А, копируете, переходите на новый лист, вставляете в ячейку А1, идете на вкладку Данные, жмете "Удалить дубликаты"
В ячейке В2 пишете формулу
Код
=СУММЕСЛИ(Лист1!A:A;A2;Лист1!X:X)
протягиваете ее вниз

Оба варианта в файле

Автор - _Boroda_
Дата добавления - 02.04.2019 в 21:25
gling Дата: Вторник, 02.04.2019, 21:49 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
нужно произвести сумму каждых 52 ячеек X2:X53
Цитата
там формула суммы только еще в степени
Если строго по тексту, то можно такой формулой
Код
=ЕСЛИОШИБКА((-СУММ(ИНДЕКС(Лист1!X:X;СТРОКА()*52-52+2):ИНДЕКС(Лист1!X:X;СТРОКА()*52+1)))^(-1);"")
В вариант сводной от Александра _Boroda_, добавил вычисляемое поле "Нов".
К сообщению приложен файл: 0040362.xlsx(88.4 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 02.04.2019, 21:53
 
Ответить
Сообщение
нужно произвести сумму каждых 52 ячеек X2:X53
Цитата
там формула суммы только еще в степени
Если строго по тексту, то можно такой формулой
Код
=ЕСЛИОШИБКА((-СУММ(ИНДЕКС(Лист1!X:X;СТРОКА()*52-52+2):ИНДЕКС(Лист1!X:X;СТРОКА()*52+1)))^(-1);"")
В вариант сводной от Александра _Boroda_, добавил вычисляемое поле "Нов".

Автор - gling
Дата добавления - 02.04.2019 в 21:49
annmadman Дата: Вторник, 02.04.2019, 22:12 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
gling, Извините, не могу в Вашей формуле разобраться, она правильно считает, когда на втором листе нет шапки, но, когда она есть, значения выходят не те.
 
Ответить
Сообщениеgling, Извините, не могу в Вашей формуле разобраться, она правильно считает, когда на втором листе нет шапки, но, когда она есть, значения выходят не те.

Автор - annmadman
Дата добавления - 02.04.2019 в 22:12
gling Дата: Вторник, 02.04.2019, 22:30 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
От этого СТРОКА()*52-52+2 и от этого СТРОКА()*52+1 зависит начало и конец диапазона, вставьте это со знаком = в строку рядом с формулой и увидите какие строки берутся в расчет. Если не разберетесь выложите файл с шапкой. Ведь зависит в какую строку вы вставили эту формулу. Если формула в первой строке то диапазон 1*52-52+2=2 до 1*52+1=53, если формула во второй строке то соответственно от 2*52-52+2=54 до 2*52+1=105.
Если формулу вставили во вторую строку то СТРОКА() замените на (СТРОКА()-1), получится так (СТРОКА()-1)*52-52+2 и (СТРОКА()-1)*52+1. Но на мой взгляд Сводной таблицей лучше.


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 02.04.2019, 22:38
 
Ответить
СообщениеОт этого СТРОКА()*52-52+2 и от этого СТРОКА()*52+1 зависит начало и конец диапазона, вставьте это со знаком = в строку рядом с формулой и увидите какие строки берутся в расчет. Если не разберетесь выложите файл с шапкой. Ведь зависит в какую строку вы вставили эту формулу. Если формула в первой строке то диапазон 1*52-52+2=2 до 1*52+1=53, если формула во второй строке то соответственно от 2*52-52+2=54 до 2*52+1=105.
Если формулу вставили во вторую строку то СТРОКА() замените на (СТРОКА()-1), получится так (СТРОКА()-1)*52-52+2 и (СТРОКА()-1)*52+1. Но на мой взгляд Сводной таблицей лучше.

Автор - gling
Дата добавления - 02.04.2019 в 22:30
annmadman Дата: Вторник, 02.04.2019, 23:19 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
gling, Спасибо! Вы очень помогли!
Только один момент остался, дальше в таблице есть годы, в которых 53 недели, следовательно нужно складывать 53 ячейки, потом снова 52 и так несколько раз, получится с этой формулой как-то исправить ситуацию?
 
Ответить
Сообщениеgling, Спасибо! Вы очень помогли!
Только один момент остался, дальше в таблице есть годы, в которых 53 недели, следовательно нужно складывать 53 ячейки, потом снова 52 и так несколько раз, получится с этой формулой как-то исправить ситуацию?

Автор - annmadman
Дата добавления - 02.04.2019 в 23:19
_Boroda_ Дата: Вторник, 02.04.2019, 23:40 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А что, СУММЕСЛИ не подошло? Или обязательно нужно с минусом и степенью? Ну хорошо
Код
=-СУММЕСЛИ(Лист1!A:A;A2;Лист1!X:X)^(-1)

Код
=ЕСЛИОШИБКА(-СУММЕСЛИ(Лист1!A:A;A2;Лист1!X:X)^(-1);"")


А, понял, еще и годы. Тогда чуть изменим
Выделяете целиком столбцы А:В, копируете, переходите на новый лист, вставляете в ячейку А1, идете на вкладку Данные, жмете "Удалить дубликаты"
В ячейке С2 пишете формулу

С ней не нужно думать 52 или 53, она сама все посчитает
Код
=ЕСЛИОШИБКА(-СУММЕСЛИМН(Лист1!X:X;Лист1!A:A;A2;Лист1!B:B;B2)^(-1);"")


А сводную gling уже наверняка сделал как нужно (не смотрел)
К сообщению приложен файл: 11_2.xlsx(87.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА что, СУММЕСЛИ не подошло? Или обязательно нужно с минусом и степенью? Ну хорошо
Код
=-СУММЕСЛИ(Лист1!A:A;A2;Лист1!X:X)^(-1)

Код
=ЕСЛИОШИБКА(-СУММЕСЛИ(Лист1!A:A;A2;Лист1!X:X)^(-1);"")


А, понял, еще и годы. Тогда чуть изменим
Выделяете целиком столбцы А:В, копируете, переходите на новый лист, вставляете в ячейку А1, идете на вкладку Данные, жмете "Удалить дубликаты"
В ячейке С2 пишете формулу

С ней не нужно думать 52 или 53, она сама все посчитает
Код
=ЕСЛИОШИБКА(-СУММЕСЛИМН(Лист1!X:X;Лист1!A:A;A2;Лист1!B:B;B2)^(-1);"")


А сводную gling уже наверняка сделал как нужно (не смотрел)

Автор - _Boroda_
Дата добавления - 02.04.2019 в 23:40
annmadman Дата: Среда, 03.04.2019, 23:22 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо! :) :) :) :) Все получилось
 
Ответить
Сообщение_Boroda_, Спасибо! :) :) :) :) Все получилось

Автор - annmadman
Дата добавления - 03.04.2019 в 23:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать сумму через каждые 52 ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!