Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/График учета рабочего времени (подсчет ночных часов) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График учета рабочего времени (подсчет ночных часов) (Формулы/Formulas)
График учета рабочего времени (подсчет ночных часов)
igor-potseluev Дата: Пятница, 05.04.2019, 15:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Впервые зарегистрировался на этом замечательном сайте hands Очень много находил здесь полезных решений :ok: , а в этот раз никак не получается((( Необходимо посчитать кол-во ночных часов по заданным параметрам, а вот формулу не могу подобрать. Есть ячейки в которых прописаны ночные часы (сверху указана буква "н"), но где 4 часа (там 2 приходятся на дневную смену, а 2 на ночную) , так же где 12 часов ( четыре часа приходятся на дневную, а 8 на ночную). Не пойму к чему привязать формулу, то ли к строке где указаны значения (н,в,д) или к форматам ячеек, где указаны часы (8,4,12). Файл прикладываю. Модератор не ссудите строго :prof: , как новичка сайта и форума)
К сообщению приложен файл: __.xls(76.5 Kb)


С уважением и благодарностью!
 
Ответить
СообщениеДобрый день! Впервые зарегистрировался на этом замечательном сайте hands Очень много находил здесь полезных решений :ok: , а в этот раз никак не получается((( Необходимо посчитать кол-во ночных часов по заданным параметрам, а вот формулу не могу подобрать. Есть ячейки в которых прописаны ночные часы (сверху указана буква "н"), но где 4 часа (там 2 приходятся на дневную смену, а 2 на ночную) , так же где 12 часов ( четыре часа приходятся на дневную, а 8 на ночную). Не пойму к чему привязать формулу, то ли к строке где указаны значения (н,в,д) или к форматам ячеек, где указаны часы (8,4,12). Файл прикладываю. Модератор не ссудите строго :prof: , как новичка сайта и форума)

Автор - igor-potseluev
Дата добавления - 05.04.2019 в 15:40
_Boroda_ Дата: Пятница, 05.04.2019, 15:48 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20;"[=12]8;[=4]2;0"))

Нерабочпраздн нужен список дат

* Не совсем понятно почему в 8 не вычитается 2 часа. Насколько я знаю, ночные - с 22 до 6
Если вычитаем, то так можно
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20-2;"[=10]8;0"))
К сообщению приложен файл: 423234324_1.xls(73.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20;"[=12]8;[=4]2;0"))

Нерабочпраздн нужен список дат

* Не совсем понятно почему в 8 не вычитается 2 часа. Насколько я знаю, ночные - с 22 до 6
Если вычитаем, то так можно
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20-2;"[=10]8;0"))

Автор - _Boroda_
Дата добавления - 05.04.2019 в 15:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График учета рабочего времени (подсчет ночных часов) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!