Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/График учета рабочего времени (подсчет ночных часов) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График учета рабочего времени (подсчет ночных часов) (Формулы/Formulas)
График учета рабочего времени (подсчет ночных часов)
igor-potseluev Дата: Пятница, 05.04.2019, 15:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Впервые зарегистрировался на этом замечательном сайте hands Очень много находил здесь полезных решений :ok: , а в этот раз никак не получается((( Необходимо посчитать кол-во ночных часов по заданным параметрам, а вот формулу не могу подобрать. Есть ячейки в которых прописаны ночные часы (сверху указана буква "н"), но где 4 часа (там 2 приходятся на дневную смену, а 2 на ночную) , так же где 12 часов ( четыре часа приходятся на дневную, а 8 на ночную). Не пойму к чему привязать формулу, то ли к строке где указаны значения (н,в,д) или к форматам ячеек, где указаны часы (8,4,12). Файл прикладываю. Модератор не ссудите строго :prof: , как новичка сайта и форума)
К сообщению приложен файл: -15-.xls(71.0 Kb)


С уважением и благодарностью!
 
Ответить
СообщениеДобрый день! Впервые зарегистрировался на этом замечательном сайте hands Очень много находил здесь полезных решений :ok: , а в этот раз никак не получается((( Необходимо посчитать кол-во ночных часов по заданным параметрам, а вот формулу не могу подобрать. Есть ячейки в которых прописаны ночные часы (сверху указана буква "н"), но где 4 часа (там 2 приходятся на дневную смену, а 2 на ночную) , так же где 12 часов ( четыре часа приходятся на дневную, а 8 на ночную). Не пойму к чему привязать формулу, то ли к строке где указаны значения (н,в,д) или к форматам ячеек, где указаны часы (8,4,12). Файл прикладываю. Модератор не ссудите строго :prof: , как новичка сайта и форума)

Автор - igor-potseluev
Дата добавления - 05.04.2019 в 15:40
_Boroda_ Дата: Пятница, 05.04.2019, 15:48 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20;"[=12]8;[=4]2;0"))

Нерабочпраздн нужен список дат

* Не совсем понятно почему в 8 не вычитается 2 часа. Насколько я знаю, ночные - с 22 до 6
Если вычитаем, то так можно
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20-2;"[=10]8;0"))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20;"[=12]8;[=4]2;0"))

Нерабочпраздн нужен список дат

* Не совсем понятно почему в 8 не вычитается 2 часа. Насколько я знаю, ночные - с 22 до 6
Если вычитаем, то так можно
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20-2;"[=10]8;0"))

Автор - _Boroda_
Дата добавления - 05.04.2019 в 15:48
igor-potseluev Дата: Понедельник, 27.05.2019, 16:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемый Boroda! Спасибо за ответ, но вычисления почему-то не сходятся((
Вы все правильно говорите hands , просто у нас разработали такой "кривой" график!!!
4Н- означает, что человек работал с 20:00 до 24:00 (2 часа ночных);
12Н- означает, что человек работал с 24:00 до 08:00 (6 часов ночных)+ этот же день с 20:00 до 24:00 (2 ночных часа) (итого 8 ночных часов);
8Н- означает, что человек работал с 24:00 до 08:00 (6 часов ночных);
Как-то так, надеюсь ,что понятно объяснил.

С праздничными совсем туго, т.к. предпраздничный день короче на 1 час.


С уважением и благодарностью!
 
Ответить
СообщениеУважаемый Boroda! Спасибо за ответ, но вычисления почему-то не сходятся((
Вы все правильно говорите hands , просто у нас разработали такой "кривой" график!!!
4Н- означает, что человек работал с 20:00 до 24:00 (2 часа ночных);
12Н- означает, что человек работал с 24:00 до 08:00 (6 часов ночных)+ этот же день с 20:00 до 24:00 (2 ночных часа) (итого 8 ночных часов);
8Н- означает, что человек работал с 24:00 до 08:00 (6 часов ночных);
Как-то так, надеюсь ,что понятно объяснил.

С праздничными совсем туго, т.к. предпраздничный день короче на 1 час.

Автор - igor-potseluev
Дата добавления - 27.05.2019 в 16:30
_Boroda_ Дата: Понедельник, 27.05.2019, 16:37 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Что конкретно не сходится, как должно быть и почему. Прямо в файле покажите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧто конкретно не сходится, как должно быть и почему. Прямо в файле покажите

Автор - _Boroda_
Дата добавления - 27.05.2019 в 16:37
igor-potseluev Дата: Вторник, 28.05.2019, 10:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, По факту у "Иванова" 56 ночных часов, а по вашей формуле получается 64. Файл прикладываю
К сообщению приложен файл: 8239829-2-.xls(71.5 Kb)


С уважением и благодарностью!
 
Ответить
Сообщение_Boroda_, По факту у "Иванова" 56 ночных часов, а по вашей формуле получается 64. Файл прикладываю

Автор - igor-potseluev
Дата добавления - 28.05.2019 в 10:29
_Boroda_ Дата: Вторник, 28.05.2019, 10:36 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20-2;"[=10]8;0"))

Или еще вариант
Код
=СУММПРОИЗВ((C19:AG19="Н")*((C20:AG20-2)-2*(C20:AG20=12)))
К сообщению приложен файл: 8239829_1-1-.xls(71.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((C19:AG19="Н")*ТЕКСТ(C20:AG20-2;"[=10]8;0"))

Или еще вариант
Код
=СУММПРОИЗВ((C19:AG19="Н")*((C20:AG20-2)-2*(C20:AG20=12)))

Автор - _Boroda_
Дата добавления - 28.05.2019 в 10:36
igor-potseluev Дата: Четверг, 30.05.2019, 15:34 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Это просто ВОЛШЕБСТВО hands Спасибо, вот сейчас разобрался в формуле. specool


С уважением и благодарностью!
 
Ответить
Сообщение_Boroda_, Это просто ВОЛШЕБСТВО hands Спасибо, вот сейчас разобрался в формуле. specool

Автор - igor-potseluev
Дата добавления - 30.05.2019 в 15:34
igor-potseluev Дата: Пятница, 07.06.2019, 15:46 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Подскажите, пожалуйста! Как атоматизировать праздничные дни в табеле учетного времени. Меняеться месяц, меняется норма и…… хотелось бы, чтобы и менялись автоматически праздничные дни, при этом , конечно, и сразу же считалась норма рабочего времени (она еще зависит и от отпуска работника)! Благодарю заранее!


С уважением и благодарностью!
 
Ответить
Сообщение_Boroda_, Подскажите, пожалуйста! Как атоматизировать праздничные дни в табеле учетного времени. Меняеться месяц, меняется норма и…… хотелось бы, чтобы и менялись автоматически праздничные дни, при этом , конечно, и сразу же считалась норма рабочего времени (она еще зависит и от отпуска работника)! Благодарю заранее!

Автор - igor-potseluev
Дата добавления - 07.06.2019 в 15:46
_Boroda_ Дата: Пятница, 07.06.2019, 15:53 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Мне все это самому придумать? Особенно расчет нормы рв и график отпусков? :D
Приложите файл со всей этой красотой, опишите хотелки подробно


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМне все это самому придумать? Особенно расчет нормы рв и график отпусков? :D
Приложите файл со всей этой красотой, опишите хотелки подробно

Автор - _Boroda_
Дата добавления - 07.06.2019 в 15:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График учета рабочего времени (подсчет ночных часов) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!