Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Составление таблицы истинности по списку соединений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление таблицы истинности по списку соединений (Формулы/Formulas)
Составление таблицы истинности по списку соединений
ВасилисаЛукьянчикова Дата: Воскресенье, 07.04.2019, 04:49 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Помогите решить задачу при помощи формул.

Есть таблица вершин вершин графа.
Как на ее основе - при помощи формул составить таблицу истинности (то есть таблицу соединений) - как показано в моем файле ?
(В таблице истинности - если есть соединение между вершинами - то ставится 1, если нет - то ничего не ставится)

По сути все соединения какие есть - представлены, а вот как их перенести в таблицу истинности - ума не приложу.
К сообщению приложен файл: 6458547.xls(32.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите решить задачу при помощи формул.

Есть таблица вершин вершин графа.
Как на ее основе - при помощи формул составить таблицу истинности (то есть таблицу соединений) - как показано в моем файле ?
(В таблице истинности - если есть соединение между вершинами - то ставится 1, если нет - то ничего не ставится)

По сути все соединения какие есть - представлены, а вот как их перенести в таблицу истинности - ума не приложу.

Автор - ВасилисаЛукьянчикова
Дата добавления - 07.04.2019 в 04:49
Pelena Дата: Воскресенье, 07.04.2019, 07:39 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14097
Репутация: 3081 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно так
Код
=СУММПРОИЗВ(($A$3:$A$15=$H4)*($B$3:$B$15=I$3)+($A$3:$A$15=I$3)*($B$3:$B$15=$H4))

Немного не совпало с Вашим результатом
К сообщению приложен файл: 3512333.xls(43.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно так
Код
=СУММПРОИЗВ(($A$3:$A$15=$H4)*($B$3:$B$15=I$3)+($A$3:$A$15=I$3)*($B$3:$B$15=$H4))

Немного не совпало с Вашим результатом

Автор - Pelena
Дата добавления - 07.04.2019 в 07:39
krosav4ig Дата: Воскресенье, 07.04.2019, 08:23 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2007,2010,2013
до кучи, массивная формула
Код
=--ИЛИ(ВЫБОР({1;2};$H4&I$3;I$3&$H4)=$A$3:$A$15&$B$3:$B$15)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениедо кучи, массивная формула
Код
=--ИЛИ(ВЫБОР({1;2};$H4&I$3;I$3&$H4)=$A$3:$A$15&$B$3:$B$15)

Автор - krosav4ig
Дата добавления - 07.04.2019 в 08:23
AlexM Дата: Воскресенье, 07.04.2019, 16:07 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Андрей, некорректно работает формула если 1 и 14
формула ставит 4 единицы
1-14, 14-1, 11-4 и 4-11
Идея интересная. формулу можно поправить так
Код
=--ИЛИ(ВЫБОР({1;2};$H4&"|"&I$3;I$3&"|"&$H4)=$A$3:$A$15&"|"&$B$3:$B$15)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 07.04.2019, 16:12
 
Ответить
СообщениеАндрей, некорректно работает формула если 1 и 14
формула ставит 4 единицы
1-14, 14-1, 11-4 и 4-11
Идея интересная. формулу можно поправить так
Код
=--ИЛИ(ВЫБОР({1;2};$H4&"|"&I$3;I$3&"|"&$H4)=$A$3:$A$15&"|"&$B$3:$B$15)

Автор - AlexM
Дата добавления - 07.04.2019 в 16:07
Светлый Дата: Воскресенье, 07.04.2019, 16:28 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1112
Репутация: 283 ±
Замечаний: 0% ±

Excel 2010
Ещё массивный вариант:
Код
=СЧЁТ(ПОИСК("!"&$B$3:$B$15&"!"&$A$3:$A$15&"!";"!"&I$3&"!"&$H4&"!"&I$3&"!"))
Сразу покажет, если соединение повторяется.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕщё массивный вариант:
Код
=СЧЁТ(ПОИСК("!"&$B$3:$B$15&"!"&$A$3:$A$15&"!";"!"&I$3&"!"&$H4&"!"&I$3&"!"))
Сразу покажет, если соединение повторяется.

Автор - Светлый
Дата добавления - 07.04.2019 в 16:28
ВасилисаЛукьянчикова Дата: Воскресенье, 07.04.2019, 22:48 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, krosav4ig, AlexM, Pelena, все формулы работают.
Спасибо за ответы.
 
Ответить
СообщениеСветлый, krosav4ig, AlexM, Pelena, все формулы работают.
Спасибо за ответы.

Автор - ВасилисаЛукьянчикова
Дата добавления - 07.04.2019 в 22:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление таблицы истинности по списку соединений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!