Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование ячеек до и после наступления события - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек до и после наступления события (Формулы/Formulas)
Суммирование ячеек до и после наступления события
МихаилЪ Дата: Понедельник, 08.04.2019, 22:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток! Так и не смог составить корректно работающую формулу, по этому прошу помощи у Вас. Существует некая таблица с численными данными получаемыми раз в месяц на протяжении года. Так же существуют некое событие "Р" происходящее в течении года в любом месяце. Задача состоит в том, что необходимо произвести суммирование ячеек до события "Р" (т.е. пока в данной таблице не будет введено "Р"), а после наступления события "Р" суммирование должно начинается с нуля. За ранее благодарен.
К сообщению приложен файл: 6823939.xls(24.5 Kb)


С уважением, Михаил.
 
Ответить
СообщениеДоброго времени суток! Так и не смог составить корректно работающую формулу, по этому прошу помощи у Вас. Существует некая таблица с численными данными получаемыми раз в месяц на протяжении года. Так же существуют некое событие "Р" происходящее в течении года в любом месяце. Задача состоит в том, что необходимо произвести суммирование ячеек до события "Р" (т.е. пока в данной таблице не будет введено "Р"), а после наступления события "Р" суммирование должно начинается с нуля. За ранее благодарен.

Автор - МихаилЪ
Дата добавления - 08.04.2019 в 22:02
_Boroda_ Дата: Понедельник, 08.04.2019, 22:40 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(A2:ИНДЕКС(2:2;ПОИСКПОЗ("Р";A2:X2;)))

Код
=СУММ(A2:X2)-Y2
К сообщению приложен файл: 6823939_1.xls(28.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(A2:ИНДЕКС(2:2;ПОИСКПОЗ("Р";A2:X2;)))

Код
=СУММ(A2:X2)-Y2

Автор - _Boroda_
Дата добавления - 08.04.2019 в 22:40
МихаилЪ Дата: Понедельник, 08.04.2019, 22:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Большое спасибо, но нужна формула именно для одной ячейки + если нет события "Р", чтобы все равно суммировался весь диапазон


С уважением, Михаил.

Сообщение отредактировал МихаилЪ - Понедельник, 08.04.2019, 22:46
 
Ответить
Сообщение_Boroda_, Большое спасибо, но нужна формула именно для одной ячейки + если нет события "Р", чтобы все равно суммировался весь диапазон

Автор - МихаилЪ
Дата добавления - 08.04.2019 в 22:44
Светлый Дата: Понедельник, 08.04.2019, 22:45 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1112
Репутация: 283 ±
Замечаний: 0% ±

Excel 2010
Ещё вариант:
Код
=СУММ(СМЕЩ(A2;;;;ПОИСКПОЗ("Р";A2:X2)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕщё вариант:
Код
=СУММ(СМЕЩ(A2;;;;ПОИСКПОЗ("Р";A2:X2)))

Автор - Светлый
Дата добавления - 08.04.2019 в 22:45
_Boroda_ Дата: Понедельник, 08.04.2019, 22:47 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Цитата МихаилЪ, 08.04.2019 в 22:44, в сообщении № 3 ()
нужна формула именно для одной ячейки
Тогда я не понял условие. Что нужно получить-то? И где?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Цитата МихаилЪ, 08.04.2019 в 22:44, в сообщении № 3 ()
нужна формула именно для одной ячейки
Тогда я не понял условие. Что нужно получить-то? И где?

Автор - _Boroda_
Дата добавления - 08.04.2019 в 22:47
МихаилЪ Дата: Понедельник, 08.04.2019, 22:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, Моя благодарность, но в предложенных формулах, если отсутствует событие, суммирование не происходит (ошибка #Н/Д).


С уважением, Михаил.
 
Ответить
СообщениеСветлый, Моя благодарность, но в предложенных формулах, если отсутствует событие, суммирование не происходит (ошибка #Н/Д).

Автор - МихаилЪ
Дата добавления - 08.04.2019 в 22:49
Светлый Дата: Понедельник, 08.04.2019, 22:53 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1112
Репутация: 283 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(A2:X2)-ЕСЛИОШИБКА(СУММ(СМЕЩ(A2;;;;ПОИСКПОЗ("Р";A2:X2)));)
*Или для 2003:
Код
=СУММ(A2:X2)-ЕСЛИ(ЕОШ(ПОИСКПОЗ("Р";A2:X2));;СУММ(СМЕЩ(A2;;;;ПОИСКПОЗ("Р";A2:X2))))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 08.04.2019, 22:59
 
Ответить
Сообщение
Код
=СУММ(A2:X2)-ЕСЛИОШИБКА(СУММ(СМЕЩ(A2;;;;ПОИСКПОЗ("Р";A2:X2)));)
*Или для 2003:
Код
=СУММ(A2:X2)-ЕСЛИ(ЕОШ(ПОИСКПОЗ("Р";A2:X2));;СУММ(СМЕЩ(A2;;;;ПОИСКПОЗ("Р";A2:X2))))

Автор - Светлый
Дата добавления - 08.04.2019 в 22:53
_Boroda_ Дата: Понедельник, 08.04.2019, 22:54 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=СУММ(A2:ИНДЕКС(2:2;ЕСЛИОШИБКА(ПОИСКПОЗ("Р";A2:X2;);24)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=СУММ(A2:ИНДЕКС(2:2;ЕСЛИОШИБКА(ПОИСКПОЗ("Р";A2:X2;);24)))

Автор - _Boroda_
Дата добавления - 08.04.2019 в 22:54
МихаилЪ Дата: Понедельник, 08.04.2019, 22:55 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, То что нужно! hands Огромнейшее спасибо.


С уважением, Михаил.
 
Ответить
СообщениеСветлый, То что нужно! hands Огромнейшее спасибо.

Автор - МихаилЪ
Дата добавления - 08.04.2019 в 22:55
_Boroda_ Дата: Понедельник, 08.04.2019, 22:58 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда так
Код
=СУММ(X2:ИНДЕКС(2:2;ЕСЛИОШИБКА(ПОИСКПОЗ("Р";A2:X2;);1)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда так
Код
=СУММ(X2:ИНДЕКС(2:2;ЕСЛИОШИБКА(ПОИСКПОЗ("Р";A2:X2;);1)))

Автор - _Boroda_
Дата добавления - 08.04.2019 в 22:58
bmv98rus Дата: Понедельник, 08.04.2019, 23:00 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 2278
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
По следам _Boroda_,
Код
=SUM(2:2)-IFERROR(SUM(A2:INDEX(2:2;MATCH("Р";2:2;)));)


Код
=SUM(X2:INDEX(2:2;IFERROR(MATCH("Р";2:2;);1)))


[p.s.]2:2 - должно хоть что-то отличаться :-)


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 08.04.2019, 23:02
 
Ответить
СообщениеПо следам _Boroda_,
Код
=SUM(2:2)-IFERROR(SUM(A2:INDEX(2:2;MATCH("Р";2:2;)));)


Код
=SUM(X2:INDEX(2:2;IFERROR(MATCH("Р";2:2;);1)))


[p.s.]2:2 - должно хоть что-то отличаться :-)

Автор - bmv98rus
Дата добавления - 08.04.2019 в 23:00
МихаилЪ Дата: Понедельник, 08.04.2019, 23:02 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Большое спасибо Вам за оперативную помощь, все как надо yes


С уважением, Михаил.
 
Ответить
Сообщение_Boroda_, Большое спасибо Вам за оперативную помощь, все как надо yes

Автор - МихаилЪ
Дата добавления - 08.04.2019 в 23:02
_Boroda_ Дата: Понедельник, 08.04.2019, 23:09 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
2:2 - должно хоть что-то отличаться

Ну не в ущерб же скорости работы? Не, я понимаю, для одной формулы что A2:X2, что 2:2 - не так уж намного разница в скорости. Также, как и волатильность СМЕЩ. Но кто ж знает, сколько там таких будет?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
2:2 - должно хоть что-то отличаться

Ну не в ущерб же скорости работы? Не, я понимаю, для одной формулы что A2:X2, что 2:2 - не так уж намного разница в скорости. Также, как и волатильность СМЕЩ. Но кто ж знает, сколько там таких будет?

Автор - _Boroda_
Дата добавления - 08.04.2019 в 23:09
bmv98rus Дата: Понедельник, 08.04.2019, 23:36 | Сообщение № 14
Группа: Проверенные
Ранг: Старожил
Сообщений: 2278
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
Ну не в ущерб же скорости работы?
Саш, я тут проверял и кажется что Match научился работать с диапазоном данных . Проверял на 200к строках 200k MATCH, естесвенно с поиском того что нет в списке по всему столбцу и по этим 200к. Разница почти незаметна.
69,97656 против 69,84375 и при поиске последнего 69,65625 против 69,27344


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 08.04.2019, 23:43
 
Ответить
Сообщение
Ну не в ущерб же скорости работы?
Саш, я тут проверял и кажется что Match научился работать с диапазоном данных . Проверял на 200к строках 200k MATCH, естесвенно с поиском того что нет в списке по всему столбцу и по этим 200к. Разница почти незаметна.
69,97656 против 69,84375 и при поиске последнего 69,65625 против 69,27344

Автор - bmv98rus
Дата добавления - 08.04.2019 в 23:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек до и после наступления события (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!