Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Кол-во коробок и штук - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кол-во коробок и штук (Формулы/Formulas)
Кол-во коробок и штук
bmv98rus Дата: Понедельник, 15.04.2019, 21:04 | Сообщение № 21
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
тебя уже много раз предупреждал, позорься теперь с замечанием
Ни кто не увидит плачущего медведя. Пыхающего еще куда не шло, но не плачущего.
Если честно, то даже не думал что на 15 посте еще не устранено, ну не углядел.
Ты что, считаешь, что ты чем-то лучше Светлого, который удалил свой ответ?
Не думал что мы тут соревнуемся на лучший и худший, думал помогаем другим делимся между собой.
Тем более, что при некоторых площадях ответ у тебя неверный
например? Про несоответствия в таблице я указывал.


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
тебя уже много раз предупреждал, позорься теперь с замечанием
Ни кто не увидит плачущего медведя. Пыхающего еще куда не шло, но не плачущего.
Если честно, то даже не думал что на 15 посте еще не устранено, ну не углядел.
Ты что, считаешь, что ты чем-то лучше Светлого, который удалил свой ответ?
Не думал что мы тут соревнуемся на лучший и худший, думал помогаем другим делимся между собой.
Тем более, что при некоторых площадях ответ у тебя неверный
например? Про несоответствия в таблице я указывал.

Автор - bmv98rus
Дата добавления - 15.04.2019 в 21:04
_Boroda_ Дата: Понедельник, 15.04.2019, 21:21 | Сообщение № 22
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот с таким расчетом штук в одном метре все правильно и одинаково - без разницы, как считать - по штукам, или по площади, или по размерам. Правда штуки дробными получаются :(
Код
=ЕСЛИОШИБКА(ОТБР(ОКРУГЛВВЕРХ(G2*C2;0)/B2)&" кор. и "&ОКРУГЛВВЕРХ(G2*C2;0)-ОТБР(ОКРУГЛВВЕРХ(G2*C2;0)/B2)*B2&" шт.";"")

Код
=ЕСЛИОШИБКА(ОТБР(ОКРУГЛВВЕРХ(G2/D2;0)/B2)&" кор. и "&ОКРУГЛВВЕРХ(G2/D2;0)-ОТБР(ОКРУГЛВВЕРХ(G2/D2;0)/B2)*B2&" шт.";"")


Например - смотри красные в файле
Для старых значений такие же косяки были для площадей из G4 и G5
[offtop]
Не думал что мы тут соревнуемся на лучший и худший
Не в соревнованиях дело, а в том, как ты ставишь себя, причем уже не в первый раз, мы с тобой об этом раньше говорили - никто ответов не дает в темах с неисправленными замечаниями, один ты не замечаешь. Потому я про "лучше" и написал[/offtop]
К сообщению приложен файл: 0814516_1.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот с таким расчетом штук в одном метре все правильно и одинаково - без разницы, как считать - по штукам, или по площади, или по размерам. Правда штуки дробными получаются :(
Код
=ЕСЛИОШИБКА(ОТБР(ОКРУГЛВВЕРХ(G2*C2;0)/B2)&" кор. и "&ОКРУГЛВВЕРХ(G2*C2;0)-ОТБР(ОКРУГЛВВЕРХ(G2*C2;0)/B2)*B2&" шт.";"")

Код
=ЕСЛИОШИБКА(ОТБР(ОКРУГЛВВЕРХ(G2/D2;0)/B2)&" кор. и "&ОКРУГЛВВЕРХ(G2/D2;0)-ОТБР(ОКРУГЛВВЕРХ(G2/D2;0)/B2)*B2&" шт.";"")


Например - смотри красные в файле
Для старых значений такие же косяки были для площадей из G4 и G5
[offtop]
Не думал что мы тут соревнуемся на лучший и худший
Не в соревнованиях дело, а в том, как ты ставишь себя, причем уже не в первый раз, мы с тобой об этом раньше говорили - никто ответов не дает в темах с неисправленными замечаниями, один ты не замечаешь. Потому я про "лучше" и написал[/offtop]

Автор - _Boroda_
Дата добавления - 15.04.2019 в 21:21
Sobol Дата: Понедельник, 15.04.2019, 21:25 | Сообщение № 23
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем спасибо!
 
Ответить
СообщениеВсем спасибо!

Автор - Sobol
Дата добавления - 15.04.2019 в 21:25
Светлый Дата: Понедельник, 15.04.2019, 21:31 | Сообщение № 24
Группа: Проверенные
Ранг: Старожил
Сообщений: 1003
Репутация: 258 ±
Замечаний: 0% ±

Excel 2010
А вот и я проснулся:
Код
=ЕСЛИ(G2;ОТБР(G2/F2%/E2%/B2)&" кор. "&ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1)&" шт.";"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА вот и я проснулся:
Код
=ЕСЛИ(G2;ОТБР(G2/F2%/E2%/B2)&" кор. "&ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1)&" шт.";"")

Автор - Светлый
Дата добавления - 15.04.2019 в 21:31
_Boroda_ Дата: Понедельник, 15.04.2019, 21:53 | Сообщение № 25
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сергей, поздравляю с 1000!

метраж 8,5 и 35


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСергей, поздравляю с 1000!

метраж 8,5 и 35

Автор - _Boroda_
Дата добавления - 15.04.2019 в 21:53
bmv98rus Дата: Понедельник, 15.04.2019, 22:07 | Сообщение № 26
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
[offtop]Я правильно понимаю что единственный кто виноват это всегда медведь? Что разве замечания устранены? Медведю - замечание, Светлому -поздравления, Бороде - борода .Прекрасно!![/offtop]


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение[offtop]Я правильно понимаю что единственный кто виноват это всегда медведь? Что разве замечания устранены? Медведю - замечание, Светлому -поздравления, Бороде - борода .Прекрасно!![/offtop]

Автор - bmv98rus
Дата добавления - 15.04.2019 в 22:07
_Boroda_ Дата: Понедельник, 15.04.2019, 22:51 | Сообщение № 27
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Замечание не то, чтобы устранено, но попытка от ТС была. Немного лучше, но все равно нехорошо. Но уже смысла нет - один ответ был получен, дальше, как практика показывает, ни к чему не приводит настойчивость.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЗамечание не то, чтобы устранено, но попытка от ТС была. Немного лучше, но все равно нехорошо. Но уже смысла нет - один ответ был получен, дальше, как практика показывает, ни к чему не приводит настойчивость.

Автор - _Boroda_
Дата добавления - 15.04.2019 в 22:51
Светлый Дата: Вторник, 16.04.2019, 06:09 | Сообщение № 28
Группа: Проверенные
Ранг: Старожил
Сообщений: 1003
Репутация: 258 ±
Замечаний: 0% ±

Excel 2010
метраж 8,5 и 35
Пришлось немного усложнить:
Код
=ЕСЛИ(G2;ОТБР(G2/F2%/E2%/B2)+(ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1)=B2)&" кор. "&ОСТАТ(ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1);B2)&" шт.";"")
**Можно и по другому, но может всплыть ошибка округления:
Код
=ЕСЛИ(G2;ОТБР((G2/F2%/E2%+1)/B2)&" кор. "&ОСТАТ(ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1);B2)&" шт.";"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 16.04.2019, 14:13
 
Ответить
Сообщение
метраж 8,5 и 35
Пришлось немного усложнить:
Код
=ЕСЛИ(G2;ОТБР(G2/F2%/E2%/B2)+(ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1)=B2)&" кор. "&ОСТАТ(ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1);B2)&" шт.";"")
**Можно и по другому, но может всплыть ошибка округления:
Код
=ЕСЛИ(G2;ОТБР((G2/F2%/E2%+1)/B2)&" кор. "&ОСТАТ(ОКРВВЕРХ(ОСТАТ(G2/F2%/E2%;B2);1);B2)&" шт.";"")

Автор - Светлый
Дата добавления - 16.04.2019 в 06:09
krosav4ig Дата: Вторник, 16.04.2019, 13:09 | Сообщение № 29
Группа: Друзья
Ранг: Старожил
Сообщений: 2031
Репутация: 847 ±
Замечаний: 0% ±

Excel 2007,2010,2013
до кучи. кривовато, но работает
Код
=СУММ(10^-{0;3}*ОТБР(ОКРУГЛ(ОСТАТ(ОКРВВЕРХ(G2;D2)/D2/B2;9^9^{1;0})*B2^{0;1};5)))
и числовой формат
Код
0\ кор., ??0\ шт.
К сообщению приложен файл: 1628248.xlsx(10.8 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениедо кучи. кривовато, но работает
Код
=СУММ(10^-{0;3}*ОТБР(ОКРУГЛ(ОСТАТ(ОКРВВЕРХ(G2;D2)/D2/B2;9^9^{1;0})*B2^{0;1};5)))
и числовой формат
Код
0\ кор., ??0\ шт.

Автор - krosav4ig
Дата добавления - 16.04.2019 в 13:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кол-во коробок и штук (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!