Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/рассчитать среднее значение в двумерном массиве с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » рассчитать среднее значение в двумерном массиве с условием (Формулы/Formulas)
рассчитать среднее значение в двумерном массиве с условием
akocherovskiy Дата: Понедельник, 29.04.2019, 17:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Нужно рассчитать среднее значение в двумерном массиве с условием без учёта пустых ячеек. Массив плавающий по строкам, по столбцам постоянный.
Во вложенном файле упрощённый пример с используемой мною формулой и проблемой, с которой столкнулся. Спасибо.
К сообщению приложен файл: 2115810.xlsx(9.8 Kb)
 
Ответить
СообщениеНужно рассчитать среднее значение в двумерном массиве с условием без учёта пустых ячеек. Массив плавающий по строкам, по столбцам постоянный.
Во вложенном файле упрощённый пример с используемой мною формулой и проблемой, с которой столкнулся. Спасибо.

Автор - akocherovskiy
Дата добавления - 29.04.2019 в 17:42
Светлый Дата: Понедельник, 29.04.2019, 19:19 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1207
Репутация: 310 ±
Замечаний: 0% ±

Excel 2010
И Вам, здравствуйте!
Массивная формула:
Код
=СУММ(Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1)))/СУММ(Ч(0<Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1))))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ Вам, здравствуйте!
Массивная формула:
Код
=СУММ(Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1)))/СУММ(Ч(0<Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1))))

Автор - Светлый
Дата добавления - 29.04.2019 в 19:19
bmv98rus Дата: Понедельник, 29.04.2019, 20:11 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Массивная
Код
=AVERAGE(IF((B1:F1=E14)*(A2:A8>=D14)*(A2:A8<D14+3)*(B2:F8<>"");B2:F8))
К сообщению приложен файл: Copy_of_895.xlsx(9.8 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеМассивная
Код
=AVERAGE(IF((B1:F1=E14)*(A2:A8>=D14)*(A2:A8<D14+3)*(B2:F8<>"");B2:F8))

Автор - bmv98rus
Дата добавления - 29.04.2019 в 20:11
akocherovskiy Дата: Понедельник, 29.04.2019, 21:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 29.04.2019 в 19:19, в сообщении № 2 ()
И Вам, здравствуйте!
Массивная формула:

=СУММ(Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1)))/СУММ(Ч(0<Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1))))


Спасибо! Работает)

Массивная

=СРЗНАЧ(ЕСЛИ((B1:F1=E14)*(A2:A8>=D14)*(A2:A8<D14+3)*(B2:F8<>"");B2:F8))
К сообщению приложен файл: Copy_of_895.xlsx(9.8 Kb)


Охренеть) Это просто шедевр) Буду осваивать массивы) В строке формул, где мне подобный расчет нужно было вывести за неделю у меня собиралось по 20 строк текста) Спасибо!
 
Ответить
Сообщение
Цитата Светлый, 29.04.2019 в 19:19, в сообщении № 2 ()
И Вам, здравствуйте!
Массивная формула:

=СУММ(Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1)))/СУММ(Ч(0<Ч(СМЕЩ(A1:A3;СТРОКА(ДВССЫЛ(ПОИСКПОЗ(D14;A2:A19;)&":"&ПОИСКПОЗ(D14;A2:A19;)+2));СТОЛБЕЦ(A:C)*2-1))))


Спасибо! Работает)

Массивная

=СРЗНАЧ(ЕСЛИ((B1:F1=E14)*(A2:A8>=D14)*(A2:A8<D14+3)*(B2:F8<>"");B2:F8))
К сообщению приложен файл: Copy_of_895.xlsx(9.8 Kb)


Охренеть) Это просто шедевр) Буду осваивать массивы) В строке формул, где мне подобный расчет нужно было вывести за неделю у меня собиралось по 20 строк текста) Спасибо!

Автор - akocherovskiy
Дата добавления - 29.04.2019 в 21:41
bmv98rus Дата: Понедельник, 29.04.2019, 23:18 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
[offtop]
Цитата akocherovskiy, 29.04.2019 в 21:41, в сообщении № 4 ()
В строке формул, где мне подобный расчет нужно было вывести за неделю у меня собиралось по 20 строк текста)

зато показывая их другим, Вы могли гордится, мол во как я умею. А что теперь будете делать с такой простой формулой? :-)[/offtop]


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение[offtop]
Цитата akocherovskiy, 29.04.2019 в 21:41, в сообщении № 4 ()
В строке формул, где мне подобный расчет нужно было вывести за неделю у меня собиралось по 20 строк текста)

зато показывая их другим, Вы могли гордится, мол во как я умею. А что теперь будете делать с такой простой формулой? :-)[/offtop]

Автор - bmv98rus
Дата добавления - 29.04.2019 в 23:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » рассчитать среднее значение в двумерном массиве с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!