Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование повторяющихся значений из двух столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование повторяющихся значений из двух столбцов (Формулы/Formulas)
Суммирование повторяющихся значений из двух столбцов
Dimantion Дата: Понедельник, 06.05.2019, 17:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Что то всю голову уже сломал, на мой взгляд простое решение должно быть, а решить не могу.
Для примера прикладываю таблицу. С левой стороны сводная таблица, а с правой таблица, откуда тянутся данные.
Если станция операции равняется станции назначения (из правой таблички желтым выделил), то кол-во таких совпадений должно просумироваться в левую табл, если станции не совпадают, то заносится в соответствующую ячейку (красным пометил). Ну и также для станции Круглое поле. Буду очень благодарен за решение.
К сообщению приложен файл: 7323461.xlsx(14.5 Kb)


Сообщение отредактировал Dimantion - Понедельник, 06.05.2019, 17:29
 
Ответить
СообщениеЧто то всю голову уже сломал, на мой взгляд простое решение должно быть, а решить не могу.
Для примера прикладываю таблицу. С левой стороны сводная таблица, а с правой таблица, откуда тянутся данные.
Если станция операции равняется станции назначения (из правой таблички желтым выделил), то кол-во таких совпадений должно просумироваться в левую табл, если станции не совпадают, то заносится в соответствующую ячейку (красным пометил). Ну и также для станции Круглое поле. Буду очень благодарен за решение.

Автор - Dimantion
Дата добавления - 06.05.2019 в 17:19
sboy Дата: Понедельник, 06.05.2019, 17:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=СУММПРОИЗВ(($L$4:$L$29=$N$4:$N$29)*($A4=$L$4:$L$29))

Код
=СУММПРОИЗВ(($N$4:$N$29<>$L$4:$L$29)*($N$4:$N$29=$A4)*($M$4:$M$29>0))

Код
=СУММПРОИЗВ(($N$4:$N$29<>$L$4:$L$29)*($N$4:$N$29=$A4)*($M$4:$M$29=0))
К сообщению приложен файл: 3548557.xlsx(15.2 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Код
=СУММПРОИЗВ(($L$4:$L$29=$N$4:$N$29)*($A4=$L$4:$L$29))

Код
=СУММПРОИЗВ(($N$4:$N$29<>$L$4:$L$29)*($N$4:$N$29=$A4)*($M$4:$M$29>0))

Код
=СУММПРОИЗВ(($N$4:$N$29<>$L$4:$L$29)*($N$4:$N$29=$A4)*($M$4:$M$29=0))

Автор - sboy
Дата добавления - 06.05.2019 в 17:49
Dimantion Дата: Вторник, 07.05.2019, 08:15 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Излишнее цитирование удалено

Спасибо большое, вы мой бог! :-)
 
Ответить
СообщениеИзлишнее цитирование удалено

Спасибо большое, вы мой бог! :-)

Автор - Dimantion
Дата добавления - 07.05.2019 в 08:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование повторяющихся значений из двух столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!