Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать время обработки заяки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать время обработки заяки (Формулы/Formulas)
Посчитать время обработки заяки
magst Дата: Среда, 08.05.2019, 10:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Ломаю голову уже не первый день, и чем дальше, тем хуже.
Задача: менеджеру поступает заявка, необходимо посчитать количество времени, ушедшее на ее отработку.
Проблема в следующем-как посчитать количество времени, ушедшее на ее решение при рабочем дне 10:00-20:00. Соответственно время за рамками этого промежутка учитываться не должно.
Заранее спасибо...
К сообщению приложен файл: 4191913.xlsx(12.6 Kb)


Сообщение отредактировал magst - Среда, 08.05.2019, 10:09
 
Ответить
СообщениеДоброго времени суток!
Ломаю голову уже не первый день, и чем дальше, тем хуже.
Задача: менеджеру поступает заявка, необходимо посчитать количество времени, ушедшее на ее отработку.
Проблема в следующем-как посчитать количество времени, ушедшее на ее решение при рабочем дне 10:00-20:00. Соответственно время за рамками этого промежутка учитываться не должно.
Заранее спасибо...

Автор - magst
Дата добавления - 08.05.2019 в 10:06
sboy Дата: Среда, 08.05.2019, 10:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2498
Репутация: 699 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял
Код
=ЕСЛИ(ДЕНЬ(B2)>ДЕНЬ(A2);"20:"-A2+B2-"10:";МИН(--ТЕКСТ(B2;"чч:мм");"20:00")-МАКС(--ТЕКСТ(A2;"чч:мм");"10:00"))
К сообщению приложен файл: 3063245.xlsx(13.5 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Если правильно понял
Код
=ЕСЛИ(ДЕНЬ(B2)>ДЕНЬ(A2);"20:"-A2+B2-"10:";МИН(--ТЕКСТ(B2;"чч:мм");"20:00")-МАКС(--ТЕКСТ(A2;"чч:мм");"10:00"))

Автор - sboy
Дата добавления - 08.05.2019 в 10:34
magst Дата: Среда, 08.05.2019, 10:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Если правильно понял

В большинстве случаев все сошлось как надо.
Огромное спасибо за проявленный интерес и помощь.
Не сочтите за наглость, т.к. формулу не понял, просчитал в ручную и значения не совпали.
Если есть такая возможность, пожалуйста, гляньте еще раз файл во вложении.
Заранее спасибо.
К сообщению приложен файл: _3063245.xlsx(13.7 Kb)
 
Ответить
Сообщение
Если правильно понял

В большинстве случаев все сошлось как надо.
Огромное спасибо за проявленный интерес и помощь.
Не сочтите за наглость, т.к. формулу не понял, просчитал в ручную и значения не совпали.
Если есть такая возможность, пожалуйста, гляньте еще раз файл во вложении.
Заранее спасибо.

Автор - magst
Дата добавления - 08.05.2019 в 10:44
WildGodlike Дата: Среда, 08.05.2019, 10:45 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 4 ±
Замечаний: 0% ±

Excel 2016
sboy, Добрый день! Стало интересно
02.05.2019 22:01 03.05.2019 12:17 14:16:00 0:16
Звонок поступил уже после окончания рабочего дня 2 числа в 22:01, начало рабочего дня 3 числа в 10:00, время ответа в 12:17, почему у вас 0:16, а не 2:16 или 2:17?

UPD
пока писал ТС уже написал сообщение выше.


Сообщение отредактировал WildGodlike - Среда, 08.05.2019, 10:46
 
Ответить
Сообщениеsboy, Добрый день! Стало интересно
02.05.2019 22:01 03.05.2019 12:17 14:16:00 0:16
Звонок поступил уже после окончания рабочего дня 2 числа в 22:01, начало рабочего дня 3 числа в 10:00, время ответа в 12:17, почему у вас 0:16, а не 2:16 или 2:17?

UPD
пока писал ТС уже написал сообщение выше.

Автор - WildGodlike
Дата добавления - 08.05.2019 в 10:45
sboy Дата: Среда, 08.05.2019, 10:58 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2498
Репутация: 699 ±
Замечаний: 0% ±

Excel 2010
Да, не учел входящие после 20:00
Код
=ЕСЛИ(ДЕНЬ(B2)>ДЕНЬ(A2);"20:"-МИН(--ТЕКСТ(A2;"чч:мм");"20:")+МАКС(--ТЕКСТ(B2;"чч:мм");"10:")-"10:";МИН(--ТЕКСТ(B2;"чч:мм");"20:")-МИН(МАКС(--ТЕКСТ(A2;"чч:мм");"10:");"20:"))
К сообщению приложен файл: 0645121.xlsx(13.7 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДа, не учел входящие после 20:00
Код
=ЕСЛИ(ДЕНЬ(B2)>ДЕНЬ(A2);"20:"-МИН(--ТЕКСТ(A2;"чч:мм");"20:")+МАКС(--ТЕКСТ(B2;"чч:мм");"10:")-"10:";МИН(--ТЕКСТ(B2;"чч:мм");"20:")-МИН(МАКС(--ТЕКСТ(A2;"чч:мм");"10:");"20:"))

Автор - sboy
Дата добавления - 08.05.2019 в 10:58
magst Дата: Среда, 08.05.2019, 11:24 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, Огромное Вам спасибо.
+ в репутацию!
 
Ответить
Сообщениеsboy, Огромное Вам спасибо.
+ в репутацию!

Автор - magst
Дата добавления - 08.05.2019 в 11:24
Kostya_Ye Дата: Среда, 08.05.2019, 11:39 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 3 ±
Замечаний: 0% ±

Excel 2016
мой вариант, который учитывает если длительность заявки более двух дней
Код
="10:00"*(DAY(B2)-DAY(A2)+1)-MIN(MAX(MOD(A2;1)-"10:00";0);"10:00")-MAX("20:00"-MOD(B2;1);0)
 
Ответить
Сообщениемой вариант, который учитывает если длительность заявки более двух дней
Код
="10:00"*(DAY(B2)-DAY(A2)+1)-MIN(MAX(MOD(A2;1)-"10:00";0);"10:00")-MAX("20:00"-MOD(B2;1);0)

Автор - Kostya_Ye
Дата добавления - 08.05.2019 в 11:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать время обработки заяки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!