Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление строк, которые не содержат значения из списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление строк, которые не содержат значения из списка (Формулы/Formulas)
Удаление строк, которые не содержат значения из списка
vovan0307 Дата: Четверг, 09.05.2019, 19:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, такая проблема:

есть документ с 5 листами с разными значениями, но на каждом листе есть столбец product_id, нужно удалить все строки в которых нет значения product_id из первого листа.

В файле желтым выделены те значения, которые нужны, если в строке значения из этого списка нет, её нужно удалить.

Заранее спасибо за помощь.
К сообщению приложен файл: ttt4.xls(93.5 Kb)
 
Ответить
СообщениеДобрый день, такая проблема:

есть документ с 5 листами с разными значениями, но на каждом листе есть столбец product_id, нужно удалить все строки в которых нет значения product_id из первого листа.

В файле желтым выделены те значения, которые нужны, если в строке значения из этого списка нет, её нужно удалить.

Заранее спасибо за помощь.

Автор - vovan0307
Дата добавления - 09.05.2019 в 19:42
Pelena Дата: Пятница, 10.05.2019, 09:10 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14014
Репутация: 3067 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
В доп. столбец формулу
Код
=СЧЁТЕСЛИ(Products!$A$2:$A$93;A2)

Потом фильтром выбрать строки по критерию 0, выделить строки -- удалить
[p.s.]Оставила только два листа из-за превышения размера файла[/p.s.]
К сообщению приложен файл: 1700674.xls(69.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
В доп. столбец формулу
Код
=СЧЁТЕСЛИ(Products!$A$2:$A$93;A2)

Потом фильтром выбрать строки по критерию 0, выделить строки -- удалить
[p.s.]Оставила только два листа из-за превышения размера файла[/p.s.]

Автор - Pelena
Дата добавления - 10.05.2019 в 09:10
vovan0307 Дата: Пятница, 10.05.2019, 16:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное Вам спасибо - всё работает, Вы сэкономили мне огромное количество времени и сил.
 
Ответить
СообщениеОгромное Вам спасибо - всё работает, Вы сэкономили мне огромное количество времени и сил.

Автор - vovan0307
Дата добавления - 10.05.2019 в 16:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление строк, которые не содержат значения из списка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!