Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение данных при изменении структуры таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение данных при изменении структуры таблицы (Формулы/Formulas)
Заполнение данных при изменении структуры таблицы
basicfire Дата: Пятница, 10.05.2019, 16:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Как заполнить таблицу методом протаскивания в моём случаи б19 из листа б17 по названиям каждой строки/столбца (смотреть файл) шаг две строки в б17?
К сообщению приложен файл: 9504658.xlsx(10.5 Kb)
 
Ответить
СообщениеКак заполнить таблицу методом протаскивания в моём случаи б19 из листа б17 по названиям каждой строки/столбца (смотреть файл) шаг две строки в б17?

Автор - basicfire
Дата добавления - 10.05.2019 в 16:27
Pelena Дата: Пятница, 10.05.2019, 17:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14329
Репутация: 3132 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Покажите вручную, как должны расположиться данные в итоге


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПокажите вручную, как должны расположиться данные в итоге

Автор - Pelena
Дата добавления - 10.05.2019 в 17:05
basicfire Дата: Суббота, 11.05.2019, 09:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, данные внёс в лист б19, но хотелось бы протягивать т.к. таблицы большие. Было бы еще лучше если в таблице б17 вводит данные, а в б19 автоматом прописывались значения с привязкой к номеру детали.
К сообщению приложен файл: 6594980.xlsx(11.1 Kb)


Сообщение отредактировал basicfire - Суббота, 11.05.2019, 09:44
 
Ответить
СообщениеPelena, данные внёс в лист б19, но хотелось бы протягивать т.к. таблицы большие. Было бы еще лучше если в таблице б17 вводит данные, а в б19 автоматом прописывались значения с привязкой к номеру детали.

Автор - basicfire
Дата добавления - 11.05.2019 в 09:44
Pelena Дата: Суббота, 11.05.2019, 10:05 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14329
Репутация: 3132 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Посмотрите такой вариант.
Формула массива вводится сразу в диапазон C1:F4 (объединение ячеек я удалила, мешает. На первом листе тоже)
Код
=ТРАНСП(б17!A2:D5)

Для копирования выделяете сразу диапазон из четырёх строк (например A17:F20) и протягиваете вниз
К сообщению приложен файл: 3580821.xlsx(12.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПосмотрите такой вариант.
Формула массива вводится сразу в диапазон C1:F4 (объединение ячеек я удалила, мешает. На первом листе тоже)
Код
=ТРАНСП(б17!A2:D5)

Для копирования выделяете сразу диапазон из четырёх строк (например A17:F20) и протягиваете вниз

Автор - Pelena
Дата добавления - 11.05.2019 в 10:05
basicfire Дата: Суббота, 11.05.2019, 11:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, формат ячеек нельзя менять, он такой: в б17 ячейка в две строки и один столбец, а в б19 ячейка в одну строку и два столбца.
 
Ответить
СообщениеPelena, формат ячеек нельзя менять, он такой: в б17 ячейка в две строки и один столбец, а в б19 ячейка в одну строку и два столбца.

Автор - basicfire
Дата добавления - 11.05.2019 в 11:30
Pelena Дата: Суббота, 11.05.2019, 19:02 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14329
Репутация: 3132 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Попробуйте так
Код
=ИНДЕКС(б17!$A$3:$D$102;СТОЛБЕЦ(A1)+ОТБР((СТРОКА(A1)-1)/4)*8;ОСТАТ(СТРОКА(A4);4)+1)
К сообщению приложен файл: 6594980-1-.xlsx(12.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте так
Код
=ИНДЕКС(б17!$A$3:$D$102;СТОЛБЕЦ(A1)+ОТБР((СТРОКА(A1)-1)/4)*8;ОСТАТ(СТРОКА(A4);4)+1)

Автор - Pelena
Дата добавления - 11.05.2019 в 19:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение данных при изменении структуры таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!