Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена автоматически числа на значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена автоматически числа на значение (Формулы/Formulas)
Замена автоматически числа на значение
Jonkle Дата: Понедельник, 13.05.2019, 09:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день друзья! Я в экселе новичок и мне нужна помощь вот в каком плане. У меня есть две таблицы одна табель на людей, другая таблица учеты проживания и питания. Какую мне формулу применить ко второй таблице, что бы когда я ставлю в табеле число 11(часы), в табеле учета проживания и питания автоматом ставился "+", на против той же ФИО и дате. Заранее спасибо за помощь!
К сообщению приложен файл: 8733941.xlsx(8.4 Kb)


Сообщение отредактировал Jonkle - Понедельник, 13.05.2019, 09:46
 
Ответить
СообщениеДобрый день друзья! Я в экселе новичок и мне нужна помощь вот в каком плане. У меня есть две таблицы одна табель на людей, другая таблица учеты проживания и питания. Какую мне формулу применить ко второй таблице, что бы когда я ставлю в табеле число 11(часы), в табеле учета проживания и питания автоматом ставился "+", на против той же ФИО и дате. Заранее спасибо за помощь!

Автор - Jonkle
Дата добавления - 13.05.2019 в 09:27
китин Дата: Понедельник, 13.05.2019, 09:55 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5537
Репутация: 883 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Добрый!!! так надо?
Код
=ЕСЛИ(ЕЧИСЛО(ИНДЕКС($B$3:$C$5;ПОИСКПОЗ($I3;$A$3:$A$5;0);ПОИСКПОЗ(J$2;$B$2:$C$2;0)));"+";"")
К сообщению приложен файл: Jonkle.xlsx(8.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДобрый!!! так надо?
Код
=ЕСЛИ(ЕЧИСЛО(ИНДЕКС($B$3:$C$5;ПОИСКПОЗ($I3;$A$3:$A$5;0);ПОИСКПОЗ(J$2;$B$2:$C$2;0)));"+";"")

Автор - китин
Дата добавления - 13.05.2019 в 09:55
Jonkle Дата: Понедельник, 13.05.2019, 10:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, да круто, а эта формула будет работать если я в отдельные файлы размещу?)
 
Ответить
Сообщениекитин, да круто, а эта формула будет работать если я в отдельные файлы размещу?)

Автор - Jonkle
Дата добавления - 13.05.2019 в 10:01
Jonkle Дата: Понедельник, 13.05.2019, 10:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, на разных листах почему то не работает формула, что можно откорректировать, подскажите пожалуйста!
К сообщению приложен файл: 4498691.xlsx(9.0 Kb)
 
Ответить
Сообщениекитин, на разных листах почему то не работает формула, что можно откорректировать, подскажите пожалуйста!

Автор - Jonkle
Дата добавления - 13.05.2019 в 10:42
Pelena Дата: Понедельник, 13.05.2019, 10:47 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14022
Репутация: 3069 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(ЕЧИСЛО(ИНДЕКС(Лист1!$B$3:$C$5;ПОИСКПОЗ($A3;Лист1!$A$3:$A$5;0);ПОИСКПОЗ(B$2;Лист1!$B$2:$AF$2;0)));"+";"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ИНДЕКС(Лист1!$B$3:$C$5;ПОИСКПОЗ($A3;Лист1!$A$3:$A$5;0);ПОИСКПОЗ(B$2;Лист1!$B$2:$AF$2;0)));"+";"")

Автор - Pelena
Дата добавления - 13.05.2019 в 10:47
_Boroda_ Дата: Понедельник, 13.05.2019, 11:01 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15023
Репутация: 5930 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ТЕКСТ(СУММПРОИЗВ(($A3=Лист1!$A$3:$A$9)*(B$2=Лист1!$B$2:$C$2)*Лист1!$B$3:$C$9);"+;;")

Код
=ТЕКСТ(-ЕЧИСЛО(ИНДЕКС(Лист1!$B$3:$C$5;ПОИСКПОЗ($K3;Лист1!$A$3:$A$5;);ПОИСКПОЗ(L$2;Лист1!$B$2:$AF$2;)));";+")

Если у Вас одинаковые таблицы на листах (как в примере), то достаточно просто
Код
=ЕСЛИ(Лист1!B3;"+";"")
К сообщению приложен файл: 4498691_1.xlsx(9.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ТЕКСТ(СУММПРОИЗВ(($A3=Лист1!$A$3:$A$9)*(B$2=Лист1!$B$2:$C$2)*Лист1!$B$3:$C$9);"+;;")

Код
=ТЕКСТ(-ЕЧИСЛО(ИНДЕКС(Лист1!$B$3:$C$5;ПОИСКПОЗ($K3;Лист1!$A$3:$A$5;);ПОИСКПОЗ(L$2;Лист1!$B$2:$AF$2;)));";+")

Если у Вас одинаковые таблицы на листах (как в примере), то достаточно просто
Код
=ЕСЛИ(Лист1!B3;"+";"")

Автор - _Boroda_
Дата добавления - 13.05.2019 в 11:01
Jonkle Дата: Понедельник, 13.05.2019, 11:05 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Спасибо большое!) + к карме поставил всем
 
Ответить
Сообщение_Boroda_, Спасибо большое!) + к карме поставил всем

Автор - Jonkle
Дата добавления - 13.05.2019 в 11:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена автоматически числа на значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!