Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод уникальных значений по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод уникальных значений по условию (Формулы/Formulas)
Вывод уникальных значений по условию
Arkanzas Дата: Четверг, 16.05.2019, 16:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Вновь вынужден к Вам обратиться за помощью.
Есть таблица где в стобце "А" указан номер условной поставки и в столбце "В" указан продукт. Нужно вывести уникальные значения по каждой поставке отдельно. Как вывести уникальные значения я нашел, но не здесь, вариант который указан на нашем форуме у меня не работает (не выяснял почему, может у меня руки не от туда растут, но на самом деле, совершенно не осознаю, как работает эта формула).
В общем на мой взгляд все предельно просто, вставить куда надо функцию- ЕСЛИ() и готово, но у меня не получилось по простому.
Будьте добры, скажите, это вообще возможно?
К сообщению приложен файл: 4264925.xlsx(10.3 Kb)
 
Ответить
СообщениеДобрый день!
Вновь вынужден к Вам обратиться за помощью.
Есть таблица где в стобце "А" указан номер условной поставки и в столбце "В" указан продукт. Нужно вывести уникальные значения по каждой поставке отдельно. Как вывести уникальные значения я нашел, но не здесь, вариант который указан на нашем форуме у меня не работает (не выяснял почему, может у меня руки не от туда растут, но на самом деле, совершенно не осознаю, как работает эта формула).
В общем на мой взгляд все предельно просто, вставить куда надо функцию- ЕСЛИ() и готово, но у меня не получилось по простому.
Будьте добры, скажите, это вообще возможно?

Автор - Arkanzas
Дата добавления - 16.05.2019 в 16:24
_Boroda_ Дата: Четверг, 16.05.2019, 17:20 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15023
Репутация: 5930 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В общем на мой взгляд все предельно просто
Согласен. Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ(A$2:A$25=A2;B$2:B$25);ЕСЛИ(A$2:A$25=A2;B$2:B$25);)=СТРОКА($1:$24)*(A$2:A$25=A2);СТРОКА($2:$25));СЧЁТЕСЛИ(A$2:A2;A2)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 4264925_1.xlsx(10.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
В общем на мой взгляд все предельно просто
Согласен. Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ(A$2:A$25=A2;B$2:B$25);ЕСЛИ(A$2:A$25=A2;B$2:B$25);)=СТРОКА($1:$24)*(A$2:A$25=A2);СТРОКА($2:$25));СЧЁТЕСЛИ(A$2:A2;A2)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 16.05.2019 в 17:20
Светлый Дата: Четверг, 16.05.2019, 17:49 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1079
Репутация: 275 ±
Замечаний: 0% ±

Excel 2010
И мой вариант. Тоже массивная:
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(B$1:B$19;ЕСЛИ(A$1:A$19=A2;B$1:B$19););)=СТРОКА($1:$19);СТРОКА($1:$19));СТРОКА(C3)-ПОИСКПОЗ(A2;A:A;)));"")
*И подсмотрев у _Boroda_:
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(B$1:B$19;ЕСЛИ(A$1:A$19=A2;B$1:B$19););)=СТРОКА($1:$19);СТРОКА($1:$19));СЧЁТЕСЛИ(A$2:A2;A2)));"")
**Можно рыхлое решение получить:
Код
=ЕСЛИ(СЧЁТЕСЛИМН(A$2:A2;A2;B$2:B2;B2)=1;B2;"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 17.05.2019, 11:38
 
Ответить
СообщениеИ мой вариант. Тоже массивная:
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(B$1:B$19;ЕСЛИ(A$1:A$19=A2;B$1:B$19););)=СТРОКА($1:$19);СТРОКА($1:$19));СТРОКА(C3)-ПОИСКПОЗ(A2;A:A;)));"")
*И подсмотрев у _Boroda_:
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(B$1:B$19;ЕСЛИ(A$1:A$19=A2;B$1:B$19););)=СТРОКА($1:$19);СТРОКА($1:$19));СЧЁТЕСЛИ(A$2:A2;A2)));"")
**Можно рыхлое решение получить:
Код
=ЕСЛИ(СЧЁТЕСЛИМН(A$2:A2;A2;B$2:B2;B2)=1;B2;"")

Автор - Светлый
Дата добавления - 16.05.2019 в 17:49
Arkanzas Дата: Пятница, 17.05.2019, 12:21 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо! То, что нужно!
P.S. Я очень сильно люблю Exel и постоянно ставлю перед собой новые, сложные (для меня) задачи для превращения рабочей рутины в увлекательный рабочий процесс. НО! Такие формулы для меня КОСМОС.
P.P.S. Кто бы меня научил сочинять такое)
 
Ответить
Сообщение_Boroda_, Спасибо! То, что нужно!
P.S. Я очень сильно люблю Exel и постоянно ставлю перед собой новые, сложные (для меня) задачи для превращения рабочей рутины в увлекательный рабочий процесс. НО! Такие формулы для меня КОСМОС.
P.P.S. Кто бы меня научил сочинять такое)

Автор - Arkanzas
Дата добавления - 17.05.2019 в 12:21
_Boroda_ Дата: Пятница, 17.05.2019, 12:39 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15023
Репутация: 5930 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А Светлого почто спасибом обошли? Он тоже старался
Решайте задачки на форуме, анализируйте чужие решения и научитесь потихонечку


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА Светлого почто спасибом обошли? Он тоже старался
Решайте задачки на форуме, анализируйте чужие решения и научитесь потихонечку

Автор - _Boroda_
Дата добавления - 17.05.2019 в 12:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод уникальных значений по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!