Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значения строки на другом листе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения строки на другом листе (Формулы/Formulas)
поиск значения строки на другом листе
maslenkin Дата: Понедельник, 27.05.2019, 11:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не получается доработать формулу в столбцах J что бы при вводе данных в значения I6 - I17 в столбце ОЧКИ появлялся результат поиска этого введенного значения I из таблицы листа ОСН_М1 (значение соответствует номеру строки).
Спасибо.
К сообщению приложен файл: 2566181.xlsx(25.1 Kb)
 
Ответить
СообщениеНе получается доработать формулу в столбцах J что бы при вводе данных в значения I6 - I17 в столбце ОЧКИ появлялся результат поиска этого введенного значения I из таблицы листа ОСН_М1 (значение соответствует номеру строки).
Спасибо.

Автор - maslenkin
Дата добавления - 27.05.2019 в 11:00
sboy Дата: Понедельник, 27.05.2019, 11:12 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
И Вам здравствуйте.
там числа "как текст"
Код
=ЕСЛИ(I6;ЕСЛИОШИБКА(ПОИСКПОЗ(I6&"";ОСН_М1!$A$1:$A$100;);"");ЕСЛИ(I6="";"";))
К сообщению приложен файл: 5775610.xlsx(25.7 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеИ Вам здравствуйте.
там числа "как текст"
Код
=ЕСЛИ(I6;ЕСЛИОШИБКА(ПОИСКПОЗ(I6&"";ОСН_М1!$A$1:$A$100;);"");ЕСЛИ(I6="";"";))

Автор - sboy
Дата добавления - 27.05.2019 в 11:12
китин Дата: Понедельник, 27.05.2019, 11:15 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам здравствуйте!!!
так?
Код
=ЕСЛИОШИБКА(ПРОСМОТР($L6;ОСН_М1!$A$1:$A$100;СТРОКА($1:$100));"")

или
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(I6;ОСН_М1!$A$1:$A$100;1);"")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеИ вам здравствуйте!!!
так?
Код
=ЕСЛИОШИБКА(ПРОСМОТР($L6;ОСН_М1!$A$1:$A$100;СТРОКА($1:$100));"")

или
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(I6;ОСН_М1!$A$1:$A$100;1);"")

Автор - китин
Дата добавления - 27.05.2019 в 11:15
Che79 Дата: Понедельник, 27.05.2019, 11:26 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1373
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013, 365
еще вариант
Код
=ЕСЛИ(I6;ПОИСКПОЗ(I6;--(ОСН_М1!$A$1:$A$100););)
формула массива (ввод Ctrl+Shift+Enter) + ФЯ 0;;
К сообщению приложен файл: 2566181_1.xlsx(24.8 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениееще вариант
Код
=ЕСЛИ(I6;ПОИСКПОЗ(I6;--(ОСН_М1!$A$1:$A$100););)
формула массива (ввод Ctrl+Shift+Enter) + ФЯ 0;;

Автор - Che79
Дата добавления - 27.05.2019 в 11:26
maslenkin Дата: Понедельник, 27.05.2019, 11:31 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, спасибо за помощь, тут вот в чем проблема, в таблице осн_1 есть "разрыв" в матрице значений, например нет 12, 14, 16 (это так дэби... минспортом составлены, это для подтигивания... я в шоке от них, как будто ни кто не выполнит эти значения), значит мне надо брать по худшему, то есть если я ввожу 14, то результат должен быть как у 13, т.е 63 очка.
 
Ответить
Сообщениеsboy, спасибо за помощь, тут вот в чем проблема, в таблице осн_1 есть "разрыв" в матрице значений, например нет 12, 14, 16 (это так дэби... минспортом составлены, это для подтигивания... я в шоке от них, как будто ни кто не выполнит эти значения), значит мне надо брать по худшему, то есть если я ввожу 14, то результат должен быть как у 13, т.е 63 очка.

Автор - maslenkin
Дата добавления - 27.05.2019 в 11:31
_Boroda_ Дата: Понедельник, 27.05.2019, 11:39 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда вот
Код
=ЕСЛИ(I6="";"";МАКС((I6>=--(ОСН_М1!A$1:A$100))*(ОСН_М1!A$1:A$100<>"")*СТРОКА(ОСН_М1!A$1:A$100)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Это один из вариантов, далеко не самый лучший


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда вот
Код
=ЕСЛИ(I6="";"";МАКС((I6>=--(ОСН_М1!A$1:A$100))*(ОСН_М1!A$1:A$100<>"")*СТРОКА(ОСН_М1!A$1:A$100)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Это один из вариантов, далеко не самый лучший

Автор - _Boroda_
Дата добавления - 27.05.2019 в 11:39
maslenkin Дата: Понедельник, 27.05.2019, 13:11 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, формула работает, изменил почти всю свою таблицу. Дошел до ввода значений 7,8 8,2 - это например бег и формула перестала работать.
Код
=ЕСЛИ(И(I6=0);0;ЕСЛИОШИБКА(ПОИСКПОЗ(I6;ОСН_М1!$A$1:$A$100;-1);""))
- оставить вот эту прежнюю?
К сообщению приложен файл: _2.xlsx(24.4 Kb)


Сообщение отредактировал maslenkin - Понедельник, 27.05.2019, 13:12
 
Ответить
Сообщение_Boroda_, формула работает, изменил почти всю свою таблицу. Дошел до ввода значений 7,8 8,2 - это например бег и формула перестала работать.
Код
=ЕСЛИ(И(I6=0);0;ЕСЛИОШИБКА(ПОИСКПОЗ(I6;ОСН_М1!$A$1:$A$100;-1);""))
- оставить вот эту прежнюю?

Автор - maslenkin
Дата добавления - 27.05.2019 в 13:11
_Boroda_ Дата: Понедельник, 27.05.2019, 13:35 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Там наоборот значения, поэтому > замените на <
Код
=ЕСЛИ(I6="";"";МАКС((I6<=--(ОСН_М1!A$1:A$100))*(ОСН_М1!A$1:A$100<>"")*СТРОКА(ОСН_М1!A$1:A$100)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТам наоборот значения, поэтому > замените на <
Код
=ЕСЛИ(I6="";"";МАКС((I6<=--(ОСН_М1!A$1:A$100))*(ОСН_М1!A$1:A$100<>"")*СТРОКА(ОСН_М1!A$1:A$100)))

Автор - _Boroda_
Дата добавления - 27.05.2019 в 13:35
maslenkin Дата: Понедельник, 27.05.2019, 14:15 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
без конвертации значений времени в осн_м1, например 12:15.00 (12мин 15сек 00сотая) или 09:11.00 уже не получиться осуществлять поиск в массиве? пока привожу эти значения времени к виду 12,15 или 9,11 через Заменить : на , и .00 на пустоту и так осуществляю подстановку в матрицу осн_м1


Сообщение отредактировал maslenkin - Понедельник, 27.05.2019, 14:19
 
Ответить
Сообщениебез конвертации значений времени в осн_м1, например 12:15.00 (12мин 15сек 00сотая) или 09:11.00 уже не получиться осуществлять поиск в массиве? пока привожу эти значения времени к виду 12,15 или 9,11 через Заменить : на , и .00 на пустоту и так осуществляю подстановку в матрицу осн_м1

Автор - maslenkin
Дата добавления - 27.05.2019 в 14:15
_Boroda_ Дата: Понедельник, 27.05.2019, 14:44 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Получится


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПолучится

Автор - _Boroda_
Дата добавления - 27.05.2019 в 14:44
maslenkin Дата: Понедельник, 27.05.2019, 14:59 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Получится

какой формат ячейки выставлять?
К сообщению приложен файл: _3.xlsx(26.2 Kb)
 
Ответить
Сообщение
Получится

какой формат ячейки выставлять?

Автор - maslenkin
Дата добавления - 27.05.2019 в 14:59
_Boroda_ Дата: Понедельник, 27.05.2019, 15:10 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас Excel русский? Тогда почему сотые отделяются точкой, а не запятой, как всегда?
К сообщению приложен файл: _3-5-1.xlsx(26.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас Excel русский? Тогда почему сотые отделяются точкой, а не запятой, как всегда?

Автор - _Boroda_
Дата добавления - 27.05.2019 в 15:10
maslenkin Дата: Понедельник, 27.05.2019, 15:58 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Тогда почему сотые отделяются точкой, а не запятой, как всегда?

исправлюсь :) спасибо, не заметил этой особенности в таблицах, которые мне скинули для работы.
 
Ответить
Сообщение
Тогда почему сотые отделяются точкой, а не запятой, как всегда?

исправлюсь :) спасибо, не заметил этой особенности в таблицах, которые мне скинули для работы.

Автор - maslenkin
Дата добавления - 27.05.2019 в 15:58
_Boroda_ Дата: Понедельник, 27.05.2019, 16:34 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот так можно
Код
=ЕСЛИ(I7="";"";МАКС((--ПОДСТАВИТЬ(I7;".";",")<=--ПОДСТАВИТЬ(ОСН_М1!A$1:A$100;".";","))*(ОСН_М1!A$1:A$100<>"")*СТРОКА(ОСН_М1!A$1:A$100)))
К сообщению приложен файл: _3-5-2.xlsx(26.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот так можно
Код
=ЕСЛИ(I7="";"";МАКС((--ПОДСТАВИТЬ(I7;".";",")<=--ПОДСТАВИТЬ(ОСН_М1!A$1:A$100;".";","))*(ОСН_М1!A$1:A$100<>"")*СТРОКА(ОСН_М1!A$1:A$100)))

Автор - _Boroda_
Дата добавления - 27.05.2019 в 16:34
maslenkin Дата: Вторник, 30.07.2019, 14:19 | Сообщение № 15
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
здравствуйте, опять мне усложнили жизнь :)
как формуле сделать поиск на другом листе, при переменчивом условии на предыдущем?
К сообщению приложен файл: _1.xlsm(93.1 Kb)
 
Ответить
Сообщениездравствуйте, опять мне усложнили жизнь :)
как формуле сделать поиск на другом листе, при переменчивом условии на предыдущем?

Автор - maslenkin
Дата добавления - 30.07.2019 в 14:19
_Boroda_ Дата: Вторник, 30.07.2019, 16:52 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(I6="";"";МАКС((I6>=--ТЕКСТ(ОСН_М1!A$1:B$98;"0;;99"))*СТРОКА(ОСН_М1!$1:$98)*ЕСЛИ(D6>24;{0;1};{1;0})))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: _1-6-1.xlsm(84.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(I6="";"";МАКС((I6>=--ТЕКСТ(ОСН_М1!A$1:B$98;"0;;99"))*СТРОКА(ОСН_М1!$1:$98)*ЕСЛИ(D6>24;{0;1};{1;0})))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 30.07.2019 в 16:52
maslenkin Дата: Вторник, 30.07.2019, 18:56 | Сообщение № 17
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так нужно?

да, но не корректно считает при вводе значений 38 и 30, должно быть 100


Сообщение отредактировал maslenkin - Вторник, 30.07.2019, 19:11
 
Ответить
Сообщение
Так нужно?

да, но не корректно считает при вводе значений 38 и 30, должно быть 100

Автор - maslenkin
Дата добавления - 30.07.2019 в 18:56
maslenkin Дата: Вторник, 30.07.2019, 19:01 | Сообщение № 18
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
р/с вроде ваша работает, только не пойму, почему при вводе крайних значений 38 и 30 не выдает результат равный 100
 
Ответить
Сообщениер/с вроде ваша работает, только не пойму, почему при вводе крайних значений 38 и 30 не выдает результат равный 100

Автор - maslenkin
Дата добавления - 30.07.2019 в 19:01
maslenkin Дата: Вторник, 30.07.2019, 19:19 | Сообщение № 19
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
з/ы понял , исправил на B$100
я правильно понял, что эта формула работает со значением в столбце D до 24 и после? как мне ограничить именно 18-24 и 24-29 ??? хотя мне в принципе не важно это для подобной формулы на другом листе - там будет 30-34 и 35-39, где "разделителем" является значение 34.


Сообщение отредактировал maslenkin - Вторник, 30.07.2019, 19:33
 
Ответить
Сообщениез/ы понял , исправил на B$100
я правильно понял, что эта формула работает со значением в столбце D до 24 и после? как мне ограничить именно 18-24 и 24-29 ??? хотя мне в принципе не важно это для подобной формулы на другом листе - там будет 30-34 и 35-39, где "разделителем" является значение 34.

Автор - maslenkin
Дата добавления - 30.07.2019 в 19:19
maslenkin Дата: Четверг, 01.08.2019, 00:17 | Сообщение № 20
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так нужно?

собираю все в рабочий вид, оказалось, формула не работает, если в таблице есть отрицательные данные, и возникли сложности с "копированием" формулы на таблицы со значением времени :(
К сообщению приложен файл: 0767980.xlsm(90.4 Kb)
 
Ответить
Сообщение
Так нужно?

собираю все в рабочий вид, оказалось, формула не работает, если в таблице есть отрицательные данные, и возникли сложности с "копированием" формулы на таблицы со значением времени :(

Автор - maslenkin
Дата добавления - 01.08.2019 в 00:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения строки на другом листе (Формулы/Formulas)
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!