Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтягивание значений из различных таблиц по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание значений из различных таблиц по условию (Формулы/Formulas)
Подтягивание значений из различных таблиц по условию
igrtsk Дата: Понедельник, 27.05.2019, 16:27 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010
Бодрый день!

Прошу помощи в следующем вопросе: необходимо подтянуть значения ячеек из двух различных таблиц при совпадении условий.
Если значение ячейки В2=1 и, значение ячейки В4="HASL", то при вводе в ячейку B6 значения от 0 до 0,3 включительно, в ячейку В7 должно подтянуться значение из таблицы №2, соответствующее значению на пересечении строки "До 0,3 включ." и столбца класс точности 1, то есть значение "X". При вводе в ячейку B6 значения свыше 0,3 до 1,0 включительно, значение ячейки B7 должно принять значение "0,05/-0,18" и т.д.

Если в ячейке B4 выбрано любое значение кроме (отличное от) "HASL", то значения в ячейку B7 подтягиваются из таблицы №1 по выборке аналогичной описанной выше
К сообщению приложен файл: 8800021.xlsx(12.8 Kb)


Инструктор по применению лосей в кавалерийских частях РККА
 
Ответить
СообщениеБодрый день!

Прошу помощи в следующем вопросе: необходимо подтянуть значения ячеек из двух различных таблиц при совпадении условий.
Если значение ячейки В2=1 и, значение ячейки В4="HASL", то при вводе в ячейку B6 значения от 0 до 0,3 включительно, в ячейку В7 должно подтянуться значение из таблицы №2, соответствующее значению на пересечении строки "До 0,3 включ." и столбца класс точности 1, то есть значение "X". При вводе в ячейку B6 значения свыше 0,3 до 1,0 включительно, значение ячейки B7 должно принять значение "0,05/-0,18" и т.д.

Если в ячейке B4 выбрано любое значение кроме (отличное от) "HASL", то значения в ячейку B7 подтягиваются из таблицы №1 по выборке аналогичной описанной выше

Автор - igrtsk
Дата добавления - 27.05.2019 в 16:27
_Boroda_ Дата: Понедельник, 27.05.2019, 16:43 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(ЕСЛИ(B4="HASL";E11:K13;E4:K6);ПОИСКПОЗ(B6;{0:0,31:1,1});B2)

Код
=ИНДЕКС(ЕСЛИ(B4="HASL";E11:K13;E4:K6);1+(B6>0,3)+(B6>1);B2)
К сообщению приложен файл: 8800021_1.xlsx(12.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(ЕСЛИ(B4="HASL";E11:K13;E4:K6);ПОИСКПОЗ(B6;{0:0,31:1,1});B2)

Код
=ИНДЕКС(ЕСЛИ(B4="HASL";E11:K13;E4:K6);1+(B6>0,3)+(B6>1);B2)

Автор - _Boroda_
Дата добавления - 27.05.2019 в 16:43
igrtsk Дата: Вторник, 28.05.2019, 08:08 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010
Первая формула (через ПОИСКПОЗ) работает с ошибкой: например, при значении ячейки B6=0,3001 B4=HASL в ячейку B7 подтягивается неправильное значение.
Вторая формула работает великолепно во всем диапазоне значений.
Спасибо маэстро!


Инструктор по применению лосей в кавалерийских частях РККА
 
Ответить
СообщениеПервая формула (через ПОИСКПОЗ) работает с ошибкой: например, при значении ячейки B6=0,3001 B4=HASL в ячейку B7 подтягивается неправильное значение.
Вторая формула работает великолепно во всем диапазоне значений.
Спасибо маэстро!

Автор - igrtsk
Дата добавления - 28.05.2019 в 08:08
_Boroda_ Дата: Вторник, 28.05.2019, 09:06 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
B6=0,3001

Дык в примере и в описании разве есть про то, что там нецелые значения? Просто замените в формуле 0,31 на 0,3000000001
Но лучше да, используйте вторую


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
B6=0,3001

Дык в примере и в описании разве есть про то, что там нецелые значения? Просто замените в формуле 0,31 на 0,3000000001
Но лучше да, используйте вторую

Автор - _Boroda_
Дата добавления - 28.05.2019 в 09:06
igrtsk Дата: Вторник, 28.05.2019, 09:19 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 209
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010
Я сообразил о 0,3001, но второе решение мне больше нравится :)


Инструктор по применению лосей в кавалерийских частях РККА
 
Ответить
СообщениеЯ сообразил о 0,3001, но второе решение мне больше нравится :)

Автор - igrtsk
Дата добавления - 28.05.2019 в 09:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание значений из различных таблиц по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!