Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Данные из столбца в строку по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные из столбца в строку по условию (Формулы/Formulas)
Данные из столбца в строку по условию
gromozeka130 Дата: Вторник, 28.05.2019, 10:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет!
Помогите пожалуйста, новичек в екселе.
Есть массив данных, который необходимо облагородить, одна из задач состоит в том что:
1. Если данные в ячейках D3, D4, D5 равны, то данные в ячейках O3, O4, O5 необходимо перевернуть из столбца в строку с началом в O3.

Думаю в сторону ЕСЛИ, но готовых решений такого рода не нашел, памагите :)
К сообщению приложен файл: 2849849.xlsx(9.6 Kb)


Сообщение отредактировал gromozeka130 - Вторник, 28.05.2019, 10:58
 
Ответить
СообщениеВсем привет!
Помогите пожалуйста, новичек в екселе.
Есть массив данных, который необходимо облагородить, одна из задач состоит в том что:
1. Если данные в ячейках D3, D4, D5 равны, то данные в ячейках O3, O4, O5 необходимо перевернуть из столбца в строку с началом в O3.

Думаю в сторону ЕСЛИ, но готовых решений такого рода не нашел, памагите :)

Автор - gromozeka130
Дата добавления - 28.05.2019 в 10:25
_Boroda_ Дата: Вторник, 28.05.2019, 10:28 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, "переворот" - это не совсем ясно, нужно что-то типа "Данные из столбца в строку по условию"
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, "переворот" - это не совсем ясно, нужно что-то типа "Данные из столбца в строку по условию"
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - _Boroda_
Дата добавления - 28.05.2019 в 10:28
gromozeka130 Дата: Вторник, 28.05.2019, 10:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Исправил.
 
Ответить
СообщениеИсправил.

Автор - gromozeka130
Дата добавления - 28.05.2019 в 10:59
китин Дата: Вторник, 28.05.2019, 11:09 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а одинаковый серийный номер может выпадать на разные даты?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа одинаковый серийный номер может выпадать на разные даты?

Автор - китин
Дата добавления - 28.05.2019 в 11:09
gromozeka130 Дата: Вторник, 28.05.2019, 11:27 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Да, может.
Но данные нужно переворачивать в рамках одного серийника и одной даты.
По сути, в примере первые 3 и последние 4 строки - это один ремонт в которых содержатся запасные части, я хочу их схлопнуть в отдельную строку для каждого ремонта с набором запасных частей записанных в строку.
 
Ответить
СообщениеДа, может.
Но данные нужно переворачивать в рамках одного серийника и одной даты.
По сути, в примере первые 3 и последние 4 строки - это один ремонт в которых содержатся запасные части, я хочу их схлопнуть в отдельную строку для каждого ремонта с набором запасных частей записанных в строку.

Автор - gromozeka130
Дата добавления - 28.05.2019 в 11:27
_Boroda_ Дата: Вторник, 28.05.2019, 11:36 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Первые 3 столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;ПОИСКПОЗ(;СЧЁТЕСЛИМН($G$1:$G1;$A$1:$A$20;$H$1:$H1;$B$1:$B$20;$I$1:$I1;$C$1:$C$20);));"")

Остальные
Код
=ЕСЛИОШИБКА(ИНДЕКС($D:$D;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$20&$B$2:$B$20&$C$2:$C$20=$G2&$H2&$I2;СТРОКА($2:$20));СТОЛБЕЦ(A2)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Нули скрыты форматом ячеек
К сообщению приложен файл: 2849849_1.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Первые 3 столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;ПОИСКПОЗ(;СЧЁТЕСЛИМН($G$1:$G1;$A$1:$A$20;$H$1:$H1;$B$1:$B$20;$I$1:$I1;$C$1:$C$20);));"")

Остальные
Код
=ЕСЛИОШИБКА(ИНДЕКС($D:$D;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$20&$B$2:$B$20&$C$2:$C$20=$G2&$H2&$I2;СТРОКА($2:$20));СТОЛБЕЦ(A2)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Нули скрыты форматом ячеек

Автор - _Boroda_
Дата добавления - 28.05.2019 в 11:36
китин Дата: Вторник, 28.05.2019, 11:40 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так. почти как у _Boroda_,
первые 3 столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$11;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$2:$A$11&$B$2:$B$11;$A$2:$A$11&$B$2:$B$11;0)=СТРОКА($A$2:$A$11)-1;СТРОКА($A$2:$A$11)-1);СТРОКА(A1)));"")

остальные
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$11;НАИМЕНЬШИЙ(ЕСЛИ($G2&$H2=$A$2:$A$11&$B$2:$B$11;СТРОКА($A$2:$A$11)-1);СТОЛБЕЦ(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: gromozeka130.xlsx(11.6 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так. почти как у _Boroda_,
первые 3 столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$11;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$2:$A$11&$B$2:$B$11;$A$2:$A$11&$B$2:$B$11;0)=СТРОКА($A$2:$A$11)-1;СТРОКА($A$2:$A$11)-1);СТРОКА(A1)));"")

остальные
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$11;НАИМЕНЬШИЙ(ЕСЛИ($G2&$H2=$A$2:$A$11&$B$2:$B$11;СТРОКА($A$2:$A$11)-1);СТОЛБЕЦ(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 28.05.2019 в 11:40
gromozeka130 Дата: Среда, 29.05.2019, 10:26 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Boroda, Igor спасибо большое.
Игорь, а как эти же формулы записать без привязки к координатам, не ограничивая 2-11 строками, а чтоб массив любой длины ей подсовывать и она его кушала спокойно?
 
Ответить
СообщениеBoroda, Igor спасибо большое.
Игорь, а как эти же формулы записать без привязки к координатам, не ограничивая 2-11 строками, а чтоб массив любой длины ей подсовывать и она его кушала спокойно?

Автор - gromozeka130
Дата добавления - 29.05.2019 в 10:26
китин Дата: Среда, 29.05.2019, 10:40 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
gromozeka130, Да замените все
Код
$11
на
Код
$1000
только без фанатизма. формулы тяжелые на больших объемах висеть будут


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеgromozeka130, Да замените все
Код
$11
на
Код
$1000
только без фанатизма. формулы тяжелые на больших объемах висеть будут

Автор - китин
Дата добавления - 29.05.2019 в 10:40
gromozeka130 Дата: Среда, 29.05.2019, 16:48 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Благодарю, все получилось
 
Ответить
СообщениеБлагодарю, все получилось

Автор - gromozeka130
Дата добавления - 29.05.2019 в 16:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные из столбца в строку по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!