Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пропуск ячеек с ошибкой (ДЕЛО) при расчете суммы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пропуск ячеек с ошибкой (ДЕЛО) при расчете суммы (Формулы/Formulas)
Пропуск ячеек с ошибкой (ДЕЛО) при расчете суммы
Gesper Дата: Четверг, 30.05.2019, 09:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Подскажите формулу

Есть некая формула, которая считает сумму
Код
=СУММ($AR$9:$AR$758)


Что в нее добавить, чтобы она пропускала из расчета ячейки, где данные не занесены, ячейки с ошибкой - #ДЕЛ/0

Прилагаю файл для примера
Вкладка 1, строка 22, суммирует данные из вкладки №2
Если во вкладке №2 не проставят значение в колонке AL, то произойдет ошибка, деление на 0. Следовательно во вкладке №1 будет ошибка и сумма уже не будет считаться.
Нужно чтобы во вкладке №1, в строке 22 считалась сумма, но ошибки в виде ДЕЛО пропускались.
К сообщению приложен файл: 1960650.xls(88.0 Kb)


Сообщение отредактировал Gesper - Четверг, 30.05.2019, 13:00
 
Ответить
СообщениеДобрый день!

Подскажите формулу

Есть некая формула, которая считает сумму
Код
=СУММ($AR$9:$AR$758)


Что в нее добавить, чтобы она пропускала из расчета ячейки, где данные не занесены, ячейки с ошибкой - #ДЕЛ/0

Прилагаю файл для примера
Вкладка 1, строка 22, суммирует данные из вкладки №2
Если во вкладке №2 не проставят значение в колонке AL, то произойдет ошибка, деление на 0. Следовательно во вкладке №1 будет ошибка и сумма уже не будет считаться.
Нужно чтобы во вкладке №1, в строке 22 считалась сумма, но ошибки в виде ДЕЛО пропускались.

Автор - Gesper
Дата добавления - 30.05.2019 в 09:44
китин Дата: Четверг, 30.05.2019, 10:02 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Gesper, оформите пост согласно п 3 Правил форума .пояснялка здесь
и очень было бы неплохо приложить файл пример


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеGesper, оформите пост согласно п 3 Правил форума .пояснялка здесь
и очень было бы неплохо приложить файл пример

Автор - китин
Дата добавления - 30.05.2019 в 10:02
Gesper Дата: Четверг, 30.05.2019, 12:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приложил файл и описал ситуацию более подробно
 
Ответить
СообщениеПриложил файл и описал ситуацию более подробно

Автор - Gesper
Дата добавления - 30.05.2019 в 12:00
Nic70y Дата: Четверг, 30.05.2019, 12:06 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
ответ готов, отвечать низя, т.к. формула в Вашем посте №1 не засунута в тЭги.


ЯД(poison) 41001841029809
 
Ответить
Сообщениеответ готов, отвечать низя, т.к. формула в Вашем посте №1 не засунута в тЭги.

Автор - Nic70y
Дата добавления - 30.05.2019 в 12:06
_Boroda_ Дата: Четверг, 30.05.2019, 12:06 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 30.05.2019 в 12:06
Gesper Дата: Четверг, 30.05.2019, 12:54 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Сделал
 
Ответить
Сообщение
Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Сделал

Автор - Gesper
Дата добавления - 30.05.2019 в 12:54
Che79 Дата: Четверг, 30.05.2019, 12:57 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1374
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
Сделал
в тЭги нужно сувать не ошибку, а саму формулу из Вашего сообщения, начиная со знака = и далее


Делай нормально и будет нормально!
 
Ответить
Сообщение
Сделал
в тЭги нужно сувать не ошибку, а саму формулу из Вашего сообщения, начиная со знака = и далее

Автор - Che79
Дата добавления - 30.05.2019 в 12:57
Gesper Дата: Четверг, 30.05.2019, 13:01 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
в тЭги нужно сувать не ошибку, а саму формулу из Вашего сообщения, начиная со знака = и далее

Готово
 
Ответить
Сообщение
в тЭги нужно сувать не ошибку, а саму формулу из Вашего сообщения, начиная со знака = и далее

Готово

Автор - Gesper
Дата добавления - 30.05.2019 в 13:01
Nic70y Дата: Четверг, 30.05.2019, 13:07 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММЕСЛИ('2'!$BD$3:$BD$12;">-9E+307")


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИ('2'!$BD$3:$BD$12;">-9E+307")

Автор - Nic70y
Дата добавления - 30.05.2019 в 13:07
Che79 Дата: Четверг, 30.05.2019, 13:09 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1374
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
[offtop]Теперь в сообщении 8 явное нарушение п. 5j Правил форума :D


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop]Теперь в сообщении 8 явное нарушение п. 5j Правил форума :D

Автор - Che79
Дата добавления - 30.05.2019 в 13:09
Nic70y Дата: Четверг, 30.05.2019, 13:11 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
явное нарушение п. 5j
[offtop]не, нету,
не процитирована цитата "сделал"
[/offtop] :)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
явное нарушение п. 5j
[offtop]не, нету,
не процитирована цитата "сделал"
[/offtop] :)

Автор - Nic70y
Дата добавления - 30.05.2019 в 13:11
Che79 Дата: Четверг, 30.05.2019, 13:13 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1374
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
не, нету
ну, тогда , еще вариант
Код
=АГРЕГАТ(9;6;'2'!$BD$3:$BD$12)
для версий Excel выше 2010


Делай нормально и будет нормально!
 
Ответить
Сообщение
не, нету
ну, тогда , еще вариант
Код
=АГРЕГАТ(9;6;'2'!$BD$3:$BD$12)
для версий Excel выше 2010

Автор - Che79
Дата добавления - 30.05.2019 в 13:13
Gesper Дата: Четверг, 30.05.2019, 13:20 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое!
 
Ответить
СообщениеСпасибо большое!

Автор - Gesper
Дата добавления - 30.05.2019 в 13:20
Pelena Дата: Четверг, 30.05.2019, 13:23 | Сообщение № 14
Группа: Админы
Ранг: Местный житель
Сообщений: 14579
Репутация: 3192 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
А на мой взгляд, правильнее доработать формулы на листе 2, чтобы ошибок не возникало.
Например, для BA
Код
=ЕСЛИ(AL3;AY3/AL3;0)

Или использовать ЕСЛИОШИБКА()


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА на мой взгляд, правильнее доработать формулы на листе 2, чтобы ошибок не возникало.
Например, для BA
Код
=ЕСЛИ(AL3;AY3/AL3;0)

Или использовать ЕСЛИОШИБКА()

Автор - Pelena
Дата добавления - 30.05.2019 в 13:23
_Boroda_ Дата: Четверг, 30.05.2019, 13:28 | Сообщение № 15
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Проще всего в листе 2 формулу переписать (файл _1)
Код
=ЕСЛИОШИБКА((ЦЕЛОЕ(AK5)*60+ОСТАТ(AK5;1)*100)*0,4*(BB3/60)+(ЦЕЛОЕ(AK5)*60+ОСТАТ(AK5;1)*100)*0,4*(BA3/60);)


Или на листе 1 (файл _2)
Код
=СУММ(ЕСЛИОШИБКА('2'!$BD$3:$BD$12;))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

* Текст ответа был заготовлен больше часа назад, пожтому могут быть повторы с решениями выше
К сообщению приложен файл: 1960650_1.xls(95.5 Kb) · 1960650_2.xls(95.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПроще всего в листе 2 формулу переписать (файл _1)
Код
=ЕСЛИОШИБКА((ЦЕЛОЕ(AK5)*60+ОСТАТ(AK5;1)*100)*0,4*(BB3/60)+(ЦЕЛОЕ(AK5)*60+ОСТАТ(AK5;1)*100)*0,4*(BA3/60);)


Или на листе 1 (файл _2)
Код
=СУММ(ЕСЛИОШИБКА('2'!$BD$3:$BD$12;))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

* Текст ответа был заготовлен больше часа назад, пожтому могут быть повторы с решениями выше

Автор - _Boroda_
Дата добавления - 30.05.2019 в 13:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пропуск ячеек с ошибкой (ДЕЛО) при расчете суммы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!