Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение сумм и текста из разных ячеек в одну по номеру - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение сумм и текста из разных ячеек в одну по номеру (Формулы/Formulas)
Сложение сумм и текста из разных ячеек в одну по номеру
Woltaren Дата: Вторник, 04.06.2019, 23:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Подскажите пожалуйста, как можно на втором листе вложенного файла, в одной ячейке, посчитать все суммы с первого листа, относящиеся к одному числу, например к 10 (т.е. куда входят:
10 = 200 + 10,1 = 500 + 10,2 = 700 + 10,3 = 100 + 10,4 = 60 + 10,5 = 21 => итого на 2 листе 10 = 1581
Можно ли выполнять это сложение два раза на втором листе, сначала используя на первом листе сумму и нумерацию столбца № 1, а затем используя сумму и нумерацию столбца № 2?
И как можно получить схожий результат для ячеек с текстом, собрав данные в одной ячейке, на втором листе с первого листа? (Показано на двух листах на примере № 100). Если можно, тоже с помощью нумерации столбца № 1 с данными, и нумерацией столбца № 2 с данными.
К сообщению приложен файл: _04.06.2019.xlsx(12.7 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите пожалуйста, как можно на втором листе вложенного файла, в одной ячейке, посчитать все суммы с первого листа, относящиеся к одному числу, например к 10 (т.е. куда входят:
10 = 200 + 10,1 = 500 + 10,2 = 700 + 10,3 = 100 + 10,4 = 60 + 10,5 = 21 => итого на 2 листе 10 = 1581
Можно ли выполнять это сложение два раза на втором листе, сначала используя на первом листе сумму и нумерацию столбца № 1, а затем используя сумму и нумерацию столбца № 2?
И как можно получить схожий результат для ячеек с текстом, собрав данные в одной ячейке, на втором листе с первого листа? (Показано на двух листах на примере № 100). Если можно, тоже с помощью нумерации столбца № 1 с данными, и нумерацией столбца № 2 с данными.

Автор - Woltaren
Дата добавления - 04.06.2019 в 23:30
Che79 Дата: Вторник, 04.06.2019, 23:55 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1377
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Мало что понял, но, может, угадал?
Код
=СУММПРОИЗВ((Лист1!$B$2:$B$25=C2)*(Лист1!$A$2:$A$25+Лист1!$C$2:$C$25))

И внимательно перечитайте п. 4 Правил форума...
К сообщению приложен файл: _04.06.2019_1.xlsx(12.8 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Мало что понял, но, может, угадал?
Код
=СУММПРОИЗВ((Лист1!$B$2:$B$25=C2)*(Лист1!$A$2:$A$25+Лист1!$C$2:$C$25))

И внимательно перечитайте п. 4 Правил форума...

Автор - Che79
Дата добавления - 04.06.2019 в 23:55
_Boroda_ Дата: Среда, 05.06.2019, 00:12 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
тоже не совсем понял. По столбцу 1
Код
=СУММПРОИЗВ((ОТБР(Лист1!A$2:A$25)=A2)*(Лист1!A$2:A$25+Лист1!C$2:C$25))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениетоже не совсем понял. По столбцу 1
Код
=СУММПРОИЗВ((ОТБР(Лист1!A$2:A$25)=A2)*(Лист1!A$2:A$25+Лист1!C$2:C$25))

Автор - _Boroda_
Дата добавления - 05.06.2019 в 00:12
bmv98rus Дата: Среда, 05.06.2019, 08:00 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2725
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
тоже имею затруднение с пониманием, но предлагаю использовать примерно так
Код
=SUMIF(B:B;10;A:A)+SUMIF(B:B;10;C:C)
а для столбца
Код
=SUMIFS(C:C;A:A;">="&10;A:A;"<"&10+1)
или
Код
=SUMIFS(C:C;A:A;">="&TRUNC(A2);A:A;"<"&TRUNC(A2)+1)

конечно дополнив второй суммой


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 05.06.2019, 08:00
 
Ответить
Сообщениетоже имею затруднение с пониманием, но предлагаю использовать примерно так
Код
=SUMIF(B:B;10;A:A)+SUMIF(B:B;10;C:C)
а для столбца
Код
=SUMIFS(C:C;A:A;">="&10;A:A;"<"&10+1)
или
Код
=SUMIFS(C:C;A:A;">="&TRUNC(A2);A:A;"<"&TRUNC(A2)+1)

конечно дополнив второй суммой

Автор - bmv98rus
Дата добавления - 05.06.2019 в 08:00
Woltaren Дата: Четверг, 06.06.2019, 22:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, Извините за невнятность!
Конкретизирую вопрос и соблюдаю п. 4 правил:
Как посчитать на втором листе, в столбце (B), суммы из первого листа, только из столбце (С), чтобы результат объединял в себя все значения столбца (А), которые относятся, например, только к № 10 (т.е 10; 10,1; 10,2; и т.д.), только к № 12, только к № 13 и т.д.
Можно ли это делать с массивом и без массива?
К сообщению приложен файл: _06.06.xlsx(11.7 Kb)
 
Ответить
СообщениеChe79, Извините за невнятность!
Конкретизирую вопрос и соблюдаю п. 4 правил:
Как посчитать на втором листе, в столбце (B), суммы из первого листа, только из столбце (С), чтобы результат объединял в себя все значения столбца (А), которые относятся, например, только к № 10 (т.е 10; 10,1; 10,2; и т.д.), только к № 12, только к № 13 и т.д.
Можно ли это делать с массивом и без массива?

Автор - Woltaren
Дата добавления - 06.06.2019 в 22:41
Woltaren Дата: Четверг, 06.06.2019, 22:42 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Извините за невнятность!
Конкретизирую вопрос и соблюдаю п. 4 правил:
Как посчитать на втором листе, в столбце (B), суммы из первого листа, только из столбце (С), чтобы результат объединял в себя все значения столбца (А), которые относятся, например, только к № 10 (т.е 10; 10,1; 10,2; и т.д.), только к № 12, только к № 13 и т.д.
Можно ли это делать с массивом и без массива?
К сообщению приложен файл: 3301831.xlsx(11.7 Kb)
 
Ответить
Сообщение_Boroda_, Извините за невнятность!
Конкретизирую вопрос и соблюдаю п. 4 правил:
Как посчитать на втором листе, в столбце (B), суммы из первого листа, только из столбце (С), чтобы результат объединял в себя все значения столбца (А), которые относятся, например, только к № 10 (т.е 10; 10,1; 10,2; и т.д.), только к № 12, только к № 13 и т.д.
Можно ли это делать с массивом и без массива?

Автор - Woltaren
Дата добавления - 06.06.2019 в 22:42
Woltaren Дата: Четверг, 06.06.2019, 22:42 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, Извините за невнятность!
Конкретизирую вопрос и соблюдаю п. 4 правил:
Как посчитать на втором листе, в столбце (B), суммы из первого листа, только из столбце (С), чтобы результат объединял в себя все значения столбца (А), которые относятся, например, только к № 10 (т.е 10; 10,1; 10,2; и т.д.), только к № 12, только к № 13 и т.д.
Можно ли это делать с массивом и без массива?
К сообщению приложен файл: 0403073.xlsx(11.7 Kb)
 
Ответить
Сообщениеbmv98rus, Извините за невнятность!
Конкретизирую вопрос и соблюдаю п. 4 правил:
Как посчитать на втором листе, в столбце (B), суммы из первого листа, только из столбце (С), чтобы результат объединял в себя все значения столбца (А), которые относятся, например, только к № 10 (т.е 10; 10,1; 10,2; и т.д.), только к № 12, только к № 13 и т.д.
Можно ли это делать с массивом и без массива?

Автор - Woltaren
Дата добавления - 06.06.2019 в 22:42
Che79 Дата: Четверг, 06.06.2019, 23:48 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1377
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
По файлу из сообщения №5 так нужно? С массивом
Код
=СУММ((ОТБР(Лист1!$A$2:$A$25)=A2)*Лист1!$C$2:$C$25)
ввод Crtl+Shift+Enter Без массива
Код
=СУММПРОИЗВ((ОТБР(Лист1!$A$2:$A$25)=A2)*Лист1!$C$2:$C$25)


UPD
Еще так, например, можно
Код
=СУММ(ЕСЛИ(ЦЕЛОЕ(Лист1!$A$2:$A$25)=A2;Лист1!$C$2:$C$25))
формула массива (ввод Crtl+Shift+Enter)
К сообщению приложен файл: _06.06-1.xlsx(12.9 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 07.06.2019, 00:00
 
Ответить
СообщениеПо файлу из сообщения №5 так нужно? С массивом
Код
=СУММ((ОТБР(Лист1!$A$2:$A$25)=A2)*Лист1!$C$2:$C$25)
ввод Crtl+Shift+Enter Без массива
Код
=СУММПРОИЗВ((ОТБР(Лист1!$A$2:$A$25)=A2)*Лист1!$C$2:$C$25)


UPD
Еще так, например, можно
Код
=СУММ(ЕСЛИ(ЦЕЛОЕ(Лист1!$A$2:$A$25)=A2;Лист1!$C$2:$C$25))
формула массива (ввод Crtl+Shift+Enter)

Автор - Che79
Дата добавления - 06.06.2019 в 23:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение сумм и текста из разных ячеек в одну по номеру (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!