Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подскажите с формулой для вывода нескольких чисел в строку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подскажите с формулой для вывода нескольких чисел в строку (Формулы/Formulas)
Подскажите с формулой для вывода нескольких чисел в строку
deadfly Дата: Среда, 05.06.2019, 21:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Подскажите, пожалуйста, может есть у кого идеи? Долго мучаюсь уже, не могу придумать ничего..
Ситуация следующая:
Первый столбец - число месяца
Второй столбец - Фамилия
Подскажите, пожалуйста с формулой

Как сделать, что бы справа, рядом с фамилией выписывались числа, когда он был?
Пробовал через поискзпоз, получается только первый день выбрать, через счет тоже фигня выходит.
Помогите, пожалуйста, любой способ будет хорош!
Заранее, спасибо!
К сообщению приложен файл: _Microsoft_Exce.xlsx(8.1 Kb)
 
Ответить
СообщениеДоброго времени суток!
Подскажите, пожалуйста, может есть у кого идеи? Долго мучаюсь уже, не могу придумать ничего..
Ситуация следующая:
Первый столбец - число месяца
Второй столбец - Фамилия
Подскажите, пожалуйста с формулой

Как сделать, что бы справа, рядом с фамилией выписывались числа, когда он был?
Пробовал через поискзпоз, получается только первый день выбрать, через счет тоже фигня выходит.
Помогите, пожалуйста, любой способ будет хорош!
Заранее, спасибо!

Автор - deadfly
Дата добавления - 05.06.2019 в 21:57
Pelena Дата: Среда, 05.06.2019, 22:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14472
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;$D$4:$D$11/($E$4:$E$11=$I4);СТОЛБЕЦ(A1));"")
К сообщению приложен файл: 8900851.xlsx(9.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;$D$4:$D$11/($E$4:$E$11=$I4);СТОЛБЕЦ(A1));"")

Автор - Pelena
Дата добавления - 05.06.2019 в 22:05
Che79 Дата: Среда, 05.06.2019, 23:38 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1373
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013, 365
Здравствуйте. Несколько другой вариант (с)
Формирование списка уников в столбце I
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$4:$E$1000;ПОИСКПОЗ(;СЧЁТЕСЛИ(I$3:I3;$E$4:$E$1000);));)
Массив чисел месяца начиная с J4
Код
=НАИМЕНЬШИЙ(ЕСЛИ($E$4:$E$1000=$I4;$D$4:$D$1000);СТОЛБЕЦ(A$1))
Обе формулы - формулы массива (ввод Ctrl+Shift+Enter)
Нули и ошибки скрыты при помощи условного форматирования
К сообщению приложен файл: 987789_1.xlsx(10.0 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Четверг, 06.06.2019, 13:24
 
Ответить
СообщениеЗдравствуйте. Несколько другой вариант (с)
Формирование списка уников в столбце I
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$4:$E$1000;ПОИСКПОЗ(;СЧЁТЕСЛИ(I$3:I3;$E$4:$E$1000);));)
Массив чисел месяца начиная с J4
Код
=НАИМЕНЬШИЙ(ЕСЛИ($E$4:$E$1000=$I4;$D$4:$D$1000);СТОЛБЕЦ(A$1))
Обе формулы - формулы массива (ввод Ctrl+Shift+Enter)
Нули и ошибки скрыты при помощи условного форматирования

Автор - Che79
Дата добавления - 05.06.2019 в 23:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подскажите с формулой для вывода нескольких чисел в строку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!