Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значений по ряду условий по горизонтали и вертикали - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значений по ряду условий по горизонтали и вертикали (Формулы/Formulas)
поиск значений по ряду условий по горизонтали и вертикали
Наталья83 Дата: Четверг, 06.06.2019, 13:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Помогите пожалуйста написать формулу, для поиска значения соответствующего ряду условий по вертикали и горизонтали

В файле н закладке "итоговая по сериям" сводная табличка, в которую данные подтягиваются из закладки "средняя стоим рем"

Вопрос в следующем, в ячейке В3 сводной таблички пытаюсь написать формулу, что при условии выборки "все" ищется значение соответствующее трем условиям по столбам (A;B;и С) закладки "средняя стоим рем", а при условии выбора конкретного филиала он искал бы еще и по необходимому столбцу, соответствующему выбранному филиала, т.е. по строке 2:2 закладки "средняя стоим рем".

Заранее спасибо!
К сообщению приложен файл: 7469533.xlsx(42.7 Kb)
 
Ответить
СообщениеДобрый день!
Помогите пожалуйста написать формулу, для поиска значения соответствующего ряду условий по вертикали и горизонтали

В файле н закладке "итоговая по сериям" сводная табличка, в которую данные подтягиваются из закладки "средняя стоим рем"

Вопрос в следующем, в ячейке В3 сводной таблички пытаюсь написать формулу, что при условии выборки "все" ищется значение соответствующее трем условиям по столбам (A;B;и С) закладки "средняя стоим рем", а при условии выбора конкретного филиала он искал бы еще и по необходимому столбцу, соответствующему выбранному филиала, т.е. по строке 2:2 закладки "средняя стоим рем".

Заранее спасибо!

Автор - Наталья83
Дата добавления - 06.06.2019 в 13:00
Светлый Дата: Четверг, 06.06.2019, 13:32 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1207
Репутация: 310 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Попробуйте такую массивную (Ctrl+Shift+Enter) формулу:
Код
=СУММ(ЕСЛИ((ЕСЛИ($B$3="ВСЕ";'средняя стоим рем'!$D$2:$M$2;$B$3)='средняя стоим рем'!$D$2:$M$2)*($B$4='средняя стоим рем'!$A$4:$A$307)*(B$6='средняя стоим рем'!$C$4:$C$307)*($A7='средняя стоим рем'!$B$4:$B$307);'средняя стоим рем'!$D$4:$M$307))
*Или без столбца D "Филиал":
Код
=СУММ(ЕСЛИ((ЕСЛИ($B$3="ВСЕ";'средняя стоим рем'!$E$2:$M$2;$B$3)='средняя стоим рем'!$E$2:$M$2)*($B$4='средняя стоим рем'!$A$4:$A$307)*(B$6='средняя стоим рем'!$C$4:$C$307)*($A7='средняя стоим рем'!$B$4:$B$307);'средняя стоим рем'!$E$4:$M$307))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 06.06.2019, 13:54
 
Ответить
СообщениеДобрый день!
Попробуйте такую массивную (Ctrl+Shift+Enter) формулу:
Код
=СУММ(ЕСЛИ((ЕСЛИ($B$3="ВСЕ";'средняя стоим рем'!$D$2:$M$2;$B$3)='средняя стоим рем'!$D$2:$M$2)*($B$4='средняя стоим рем'!$A$4:$A$307)*(B$6='средняя стоим рем'!$C$4:$C$307)*($A7='средняя стоим рем'!$B$4:$B$307);'средняя стоим рем'!$D$4:$M$307))
*Или без столбца D "Филиал":
Код
=СУММ(ЕСЛИ((ЕСЛИ($B$3="ВСЕ";'средняя стоим рем'!$E$2:$M$2;$B$3)='средняя стоим рем'!$E$2:$M$2)*($B$4='средняя стоим рем'!$A$4:$A$307)*(B$6='средняя стоим рем'!$C$4:$C$307)*($A7='средняя стоим рем'!$B$4:$B$307);'средняя стоим рем'!$E$4:$M$307))

Автор - Светлый
Дата добавления - 06.06.2019 в 13:32
Наталья83 Дата: Четверг, 06.06.2019, 15:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, добрый день!

Спасибо, с массивом формула работает, но, если ВЗ="ВСЕ" , то суммируется строка от D до M, а должно либо среднее считаться от E до М, либо браться данные из столбца D
 
Ответить
СообщениеСветлый, добрый день!

Спасибо, с массивом формула работает, но, если ВЗ="ВСЕ" , то суммируется строка от D до M, а должно либо среднее считаться от E до М, либо браться данные из столбца D

Автор - Наталья83
Дата добавления - 06.06.2019 в 15:43
bmv98rus Дата: Четверг, 06.06.2019, 16:15 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUMIFS(INDEX('средняя стоим рем'!$D:$M;;IF($B$3<>"все";MATCH($B$3;'средняя стоим рем'!$E$2:$M$2;);)+1);'средняя стоим рем'!$A:$A;$B$4;'средняя стоим рем'!$B:$B;$A7;'средняя стоим рем'!$C:$C;B$6)
К сообщению приложен файл: Copy_of_989.xlsx(42.1 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 06.06.2019, 16:19
 
Ответить
Сообщение
Код
=SUMIFS(INDEX('средняя стоим рем'!$D:$M;;IF($B$3<>"все";MATCH($B$3;'средняя стоим рем'!$E$2:$M$2;);)+1);'средняя стоим рем'!$A:$A;$B$4;'средняя стоим рем'!$B:$B;$A7;'средняя стоим рем'!$C:$C;B$6)

Автор - bmv98rus
Дата добавления - 06.06.2019 в 16:15
Наталья83 Дата: Четверг, 06.06.2019, 16:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, Спасибо, сработало!
 
Ответить
Сообщениеbmv98rus, Спасибо, сработало!

Автор - Наталья83
Дата добавления - 06.06.2019 в 16:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значений по ряду условий по горизонтали и вертикали (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!