Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод информации из многих критериев нескольких значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод информации из многих критериев нескольких значений (Формулы/Formulas)
Вывод информации из многих критериев нескольких значений
Andrey_svk Дата: Вторник, 25.06.2019, 12:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Пытаюсь написать формулу, что бы выводило определенное слово, при разных ситуациях (ситуация меняется), но что то не выходит.
К сообщению приложен файл: 111.xlsx(9.3 Kb)
 
Ответить
СообщениеПытаюсь написать формулу, что бы выводило определенное слово, при разных ситуациях (ситуация меняется), но что то не выходит.

Автор - Andrey_svk
Дата добавления - 25.06.2019 в 12:11
китин Дата: Вторник, 25.06.2019, 12:15 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5659
Репутация: 896 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам здравствуйте. вы бы прописали букавками при каких условиях надо МТ а при каких ВХТ или ОХТ ???


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам здравствуйте. вы бы прописали букавками при каких условиях надо МТ а при каких ВХТ или ОХТ ???

Автор - китин
Дата добавления - 25.06.2019 в 12:15
Andrey_svk Дата: Вторник, 25.06.2019, 12:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Если есть остаток начало, есть проход (или его нет), нет реализации, есть на остатке то это "МТ". Если есть нач.остаток (или его нет), есть приход (или его нет), есть реализация, нет на конец остатка то это "ОХТ", остальные вариации просто пустая ячейка получается. Спасибо.
 
Ответить
СообщениеЕсли есть остаток начало, есть проход (или его нет), нет реализации, есть на остатке то это "МТ". Если есть нач.остаток (или его нет), есть приход (или его нет), есть реализация, нет на конец остатка то это "ОХТ", остальные вариации просто пустая ячейка получается. Спасибо.

Автор - Andrey_svk
Дата добавления - 25.06.2019 в 12:31
ibapehuk Дата: Вторник, 25.06.2019, 12:33 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
и вам здравствуйте. вы бы прописали букавками при каких условиях надо МТ а при каких ВХТ или ОХТ ???


простите за глупый вопрос, что значат эти аббревиатуры?
 
Ответить
Сообщение
и вам здравствуйте. вы бы прописали букавками при каких условиях надо МТ а при каких ВХТ или ОХТ ???


простите за глупый вопрос, что значат эти аббревиатуры?

Автор - ibapehuk
Дата добавления - 25.06.2019 в 12:33
китин Дата: Вторник, 25.06.2019, 12:40 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5659
Репутация: 896 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как понял
Код
=ЕСЛИ(СУММ($B13:$E13)=0;"";ЕСЛИ(И($D13="";$E13<>"");"МТ";"ОХТ"))
К сообщению приложен файл: Andrey_svk.xlsx(9.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак понял
Код
=ЕСЛИ(СУММ($B13:$E13)=0;"";ЕСЛИ(И($D13="";$E13<>"");"МТ";"ОХТ"))

Автор - китин
Дата добавления - 25.06.2019 в 12:40
Andrey_svk Дата: Вторник, 25.06.2019, 12:44 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
ibapehuk, ОХТ -отсутствие ходового товара, МТ - мертвый товар (т.е. который не продается).
 
Ответить
Сообщениеibapehuk, ОХТ -отсутствие ходового товара, МТ - мертвый товар (т.е. который не продается).

Автор - Andrey_svk
Дата добавления - 25.06.2019 в 12:44
Andrey_svk Дата: Вторник, 25.06.2019, 13:01 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Спасибо, я и такую похожую писал, но у Вас точнее, но в данном случае на работает при ситуации по второй позиции (или код 15). Я повторно выкладываю все ситуации и там где нужная информация выводится я прописал вручную.
К сообщению приложен файл: 5150741.xlsx(9.4 Kb)
 
Ответить
Сообщениекитин, Спасибо, я и такую похожую писал, но у Вас точнее, но в данном случае на работает при ситуации по второй позиции (или код 15). Я повторно выкладываю все ситуации и там где нужная информация выводится я прописал вручную.

Автор - Andrey_svk
Дата добавления - 25.06.2019 в 13:01
_Boroda_ Дата: Вторник, 25.06.2019, 13:04 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ((D4="")*E4;"МТ";ЕСЛИ((E4="")*D4;"ОХТ";""))

Вот так лучше
Код
=ЕСЛИ((D4="")*E4;"МТ";ЕСЛИ(НЕ(E4)*D4;"ОХТ";""))


Разница с формулой Игоря в файле
К сообщению приложен файл: 111-17-2.xlsx(9.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ((D4="")*E4;"МТ";ЕСЛИ((E4="")*D4;"ОХТ";""))

Вот так лучше
Код
=ЕСЛИ((D4="")*E4;"МТ";ЕСЛИ(НЕ(E4)*D4;"ОХТ";""))


Разница с формулой Игоря в файле

Автор - _Boroda_
Дата добавления - 25.06.2019 в 13:04
Andrey_svk Дата: Вторник, 25.06.2019, 13:13 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо Вам за терпение, только по второй позиции выводит "МТ" а она таковой не является, по остальным ситуациям все работает четко).
 
Ответить
Сообщение_Boroda_, Спасибо Вам за терпение, только по второй позиции выводит "МТ" а она таковой не является, по остальным ситуациям все работает четко).

Автор - Andrey_svk
Дата добавления - 25.06.2019 в 13:13
_Boroda_ Дата: Вторник, 25.06.2019, 13:16 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
данном случае на работает при ситуации по второй позиции (или код 15)

Полагалось, что если нет расхода, то товар по-любому мертвый. Но если обязательно должен быть и остаток на начало, то
Код
=ЕСЛИ(НЕ(D4)*E4*B4;"МТ";ЕСЛИ(НЕ(E4)*D4;"ОХТ";""))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
данном случае на работает при ситуации по второй позиции (или код 15)

Полагалось, что если нет расхода, то товар по-любому мертвый. Но если обязательно должен быть и остаток на начало, то
Код
=ЕСЛИ(НЕ(D4)*E4*B4;"МТ";ЕСЛИ(НЕ(E4)*D4;"ОХТ";""))

Автор - _Boroda_
Дата добавления - 25.06.2019 в 13:16
Andrey_svk Дата: Вторник, 25.06.2019, 13:17 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо, Спасибо, Спасибо. Все работает!!!
 
Ответить
Сообщение_Boroda_, Спасибо, Спасибо, Спасибо. Все работает!!!

Автор - Andrey_svk
Дата добавления - 25.06.2019 в 13:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод информации из многих критериев нескольких значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!