Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создать список из тех, кого нет в другом списке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать список из тех, кого нет в другом списке (Формулы/Formulas)
Создать список из тех, кого нет в другом списке
Leem Дата: Пятница, 28.06.2019, 10:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья.

Имеется общий список сотрудников (в файле это Список 1)
Имеется второй список сотрудников (в файле это Список 2), которые работали в цеху. Эти же работники есть и в общем списке "Список 1"

Необходимо создать список (в файле это список 3, в котором будут отображаться только те работники, которые есть в общем списке (Список 1),
но которых нет в списке цеха (СПИСОК 3).
Я выделил их красным цветом для примера в файле.
К сообщению приложен файл: oror.xlsx(10.5 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья.

Имеется общий список сотрудников (в файле это Список 1)
Имеется второй список сотрудников (в файле это Список 2), которые работали в цеху. Эти же работники есть и в общем списке "Список 1"

Необходимо создать список (в файле это список 3, в котором будут отображаться только те работники, которые есть в общем списке (Список 1),
но которых нет в списке цеха (СПИСОК 3).
Я выделил их красным цветом для примера в файле.

Автор - Leem
Дата добавления - 28.06.2019 в 10:26
_Boroda_ Дата: Пятница, 28.06.2019, 10:36 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС('Список 1'!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ЕНД(ПОИСКПОЗ('Список 1'!A$1:A$99;'Список 2'!$A$1:$A$99;));СТРОКА('Список 1'!A$1:A$99));СТРОКА(A1)))&""

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/НЕ(СЧЁТЕСЛИ(F$1:F1;'Список 1'!A$1:A$99&"")+СЧЁТЕСЛИ('Список 2'!A:A;'Список 1'!A$1:A$99));'Список 1'!A$1:A$99);"")

Обычная формула со второй строки
К сообщению приложен файл: oror_2.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС('Список 1'!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ЕНД(ПОИСКПОЗ('Список 1'!A$1:A$99;'Список 2'!$A$1:$A$99;));СТРОКА('Список 1'!A$1:A$99));СТРОКА(A1)))&""

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/НЕ(СЧЁТЕСЛИ(F$1:F1;'Список 1'!A$1:A$99&"")+СЧЁТЕСЛИ('Список 2'!A:A;'Список 1'!A$1:A$99));'Список 1'!A$1:A$99);"")

Обычная формула со второй строки

Автор - _Boroda_
Дата добавления - 28.06.2019 в 10:36
Leem Дата: Пятница, 28.06.2019, 10:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так нужно?

Благодарю hands
А можно как-то применить генератор случайных чисел к третьему списку? Просто у меня в общем списке 300 фамилий. А в третьем списке необходимо получить 30 фамилий. Совершенно не важно каких, просто рандомно из общего списка тех кого нет во втором списке.
Или лучше создать новую тему?


Ктулху всех спасет
 
Ответить
Сообщение
Так нужно?

Благодарю hands
А можно как-то применить генератор случайных чисел к третьему списку? Просто у меня в общем списке 300 фамилий. А в третьем списке необходимо получить 30 фамилий. Совершенно не важно каких, просто рандомно из общего списка тех кого нет во втором списке.
Или лучше создать новую тему?

Автор - Leem
Дата добавления - 28.06.2019 в 10:52
_Boroda_ Дата: Пятница, 28.06.2019, 11:12 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Давайте в отдельную тему, это намного интереснее вопрос


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДавайте в отдельную тему, это намного интереснее вопрос

Автор - _Boroda_
Дата добавления - 28.06.2019 в 11:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать список из тех, кого нет в другом списке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!