Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух списков и получение третьего из них - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух списков и получение третьего из них (Формулы/Formulas)
Сравнение двух списков и получение третьего из них
Leem Дата: Вторник, 02.07.2019, 10:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья.

Есть два списка рабочих:
Один из тех, кто сейчас на смене.
Второй из тех, кто будет на смене завтра.

Третий список должен быть из тех, кто уезжает на выходной и не выходит завтра.

Я в своих силах уже разочаровался и засел за библию....
Выручите?
К сообщению приложен файл: Index_s.xlsx(9.8 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья.

Есть два списка рабочих:
Один из тех, кто сейчас на смене.
Второй из тех, кто будет на смене завтра.

Третий список должен быть из тех, кто уезжает на выходной и не выходит завтра.

Я в своих силах уже разочаровался и засел за библию....
Выручите?

Автор - Leem
Дата добавления - 02.07.2019 в 10:26
Nic70y Дата: Вторник, 02.07.2019, 11:10 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5402
Репутация: 1182 ±
Замечаний: 0% ±

ru13;10;03
вариант немассивный (с доп. столбцом)
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ('Список 1'!A2;'Список 2'!A:A;));A1+1;A1)
Код
=ЕСЛИОШИБКА(ИНДЕКС('Список 1'!A:A;ПОИСКПОЗ(СТРОКА(B1);A:A;))&"";"")
К сообщению приложен файл: Index_s-1-.xlsx(10.7 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениевариант немассивный (с доп. столбцом)
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ('Список 1'!A2;'Список 2'!A:A;));A1+1;A1)
Код
=ЕСЛИОШИБКА(ИНДЕКС('Список 1'!A:A;ПОИСКПОЗ(СТРОКА(B1);A:A;))&"";"")

Автор - Nic70y
Дата добавления - 02.07.2019 в 11:10
Leem Дата: Среда, 03.07.2019, 00:43 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
deal


Ктулху всех спасет

Сообщение отредактировал Leem - Среда, 03.07.2019, 17:31
 
Ответить
Сообщениеdeal

Автор - Leem
Дата добавления - 03.07.2019 в 00:43
Nic70y Дата: Среда, 03.07.2019, 08:32 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5402
Репутация: 1182 ±
Замечаний: 0% ±

ru13;10;03
вероятная (предположительно) ошибка
СТРОКА(B1)
формула должна начинаться с 1-й строки, не важно с какой строки начинается таблица.


ЯД(poison) 41001841029809
 
Ответить
Сообщениевероятная (предположительно) ошибка
СТРОКА(B1)
формула должна начинаться с 1-й строки, не важно с какой строки начинается таблица.

Автор - Nic70y
Дата добавления - 03.07.2019 в 08:32
_Boroda_ Дата: Среда, 03.07.2019, 09:09 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Leem, - Прочитайте Правила форума
- Удалите излишнее цитирование - это нарушение п.5j Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеLeem, - Прочитайте Правила форума
- Удалите излишнее цитирование - это нарушение п.5j Правил форума

Автор - _Boroda_
Дата добавления - 03.07.2019 в 09:09
Leem Дата: Суббота, 06.07.2019, 17:54 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Две недели без ПК. Попробую на смартфоне со стройкой B1 эксперимент. Если не выйдет то через 2 недели напишу.


Ктулху всех спасет
 
Ответить
СообщениеДве недели без ПК. Попробую на смартфоне со стройкой B1 эксперимент. Если не выйдет то через 2 недели напишу.

Автор - Leem
Дата добавления - 06.07.2019 в 17:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух списков и получение третьего из них (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!