Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск части наименования и возврат необходимого значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск части наименования и возврат необходимого значения (Формулы/Formulas)
Поиск части наименования и возврат необходимого значения
Olga1981 Дата: Среда, 03.07.2019, 13:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,

Прошу вашей помощи в создании формулы для следующей задачи:

На листе "продажи" необходимо подтянуть значения себестоимости из листа "сс" в соответствии с наименованиями позиций. Проблема в том, что названия позиций в первом листе могут содержать дополнительные данные, т.е. поиск по полному соответствию не работает.
Пожалуйста подскажите, какую формулу можно здесь использовать для корректного поиска и возврата значения себестоимости в нужную колонку.

Заранее благодарю за помощь.
 
Ответить
СообщениеДобрый день,

Прошу вашей помощи в создании формулы для следующей задачи:

На листе "продажи" необходимо подтянуть значения себестоимости из листа "сс" в соответствии с наименованиями позиций. Проблема в том, что названия позиций в первом листе могут содержать дополнительные данные, т.е. поиск по полному соответствию не работает.
Пожалуйста подскажите, какую формулу можно здесь использовать для корректного поиска и возврата значения себестоимости в нужную колонку.

Заранее благодарю за помощь.

Автор - Olga1981
Дата добавления - 03.07.2019 в 13:02
Nic70y Дата: Среда, 03.07.2019, 13:06 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5402
Репутация: 1182 ±
Замечаний: 0% ±

ru13;10;03
без Вашего файла часть_наим*


ЯД(poison) 41001841029809
 
Ответить
Сообщениебез Вашего файла часть_наим*

Автор - Nic70y
Дата добавления - 03.07.2019 в 13:06
Olga1981 Дата: Среда, 03.07.2019, 13:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Я вроде бы прикрепляла.
Извините, дублирую.
К сообщению приложен файл: test3.rar(74.9 Kb)
 
Ответить
СообщениеЯ вроде бы прикрепляла.
Извините, дублирую.

Автор - Olga1981
Дата добавления - 03.07.2019 в 13:09
Nic70y Дата: Среда, 03.07.2019, 13:57 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5402
Репутация: 1182 ±
Замечаний: 0% ±

ru13;10;03
rar :(
Код
=ВПР(СЖПРОБЕЛЫ(ЛЕВСИМВ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A4;" ";",");","; ПОВТОР(" ";200));200))&"*";сс2012!$A$7:$D$2881;4;0)
не знаю: правильно, неправильно,
не проверял


ЯД(poison) 41001841029809
 
Ответить
Сообщениеrar :(
Код
=ВПР(СЖПРОБЕЛЫ(ЛЕВСИМВ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A4;" ";",");","; ПОВТОР(" ";200));200))&"*";сс2012!$A$7:$D$2881;4;0)
не знаю: правильно, неправильно,
не проверял

Автор - Nic70y
Дата добавления - 03.07.2019 в 13:57
Olga1981 Дата: Среда, 03.07.2019, 15:07 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Огромное вам спасибо! Заработало! hands

рано обрадовалась. Excel не хочет со мной дружить :(


Сообщение отредактировал Olga1981 - Среда, 03.07.2019, 15:51
 
Ответить
СообщениеОгромное вам спасибо! Заработало! hands

рано обрадовалась. Excel не хочет со мной дружить :(

Автор - Olga1981
Дата добавления - 03.07.2019 в 15:07
Olga1981 Дата: Среда, 03.07.2019, 15:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Эх... формула заработала, но подставляет неверные значения...
Не понимаю где искать ошибку

Прошу помощи у гуру pray
К сообщению приложен файл: test4.xls(27.5 Kb)


Сообщение отредактировал Olga1981 - Среда, 03.07.2019, 15:53
 
Ответить
СообщениеЭх... формула заработала, но подставляет неверные значения...
Не понимаю где искать ошибку

Прошу помощи у гуру pray

Автор - Olga1981
Дата добавления - 03.07.2019 в 15:49
_Boroda_ Дата: Среда, 03.07.2019, 16:10 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(A4;-ПРОСМОТР(;-(ПОИСКПОЗ(ЛЕВБ(A4;СТРОКА($6:$45))&"*";Лист2!A$4:A$99;))))&"*";Лист2!A$4:D$99;4;)*(ДЛСТР(A4)>5);)
К сообщению приложен файл: test4_1.xls(29.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(A4;-ПРОСМОТР(;-(ПОИСКПОЗ(ЛЕВБ(A4;СТРОКА($6:$45))&"*";Лист2!A$4:A$99;))))&"*";Лист2!A$4:D$99;4;)*(ДЛСТР(A4)>5);)

Автор - _Boroda_
Дата добавления - 03.07.2019 в 16:10
Olga1981 Дата: Среда, 03.07.2019, 17:00 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Благодарю! Теперь все корректно. flowers
 
Ответить
СообщениеБлагодарю! Теперь все корректно. flowers

Автор - Olga1981
Дата добавления - 03.07.2019 в 17:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск части наименования и возврат необходимого значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!