Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск соответствия части фразы- целой фразе.(частей неск-ко) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск соответствия части фразы- целой фразе.(частей неск-ко) (Формулы/Formulas)
Поиск соответствия части фразы- целой фразе.(частей неск-ко)
serg52 Дата: Пятница, 05.07.2019, 15:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть список позиций в колонке. Необходимо сравнить каждую позицию в колонке с наименованием позиции в ячейке. НО! Список - это *часть фразы* из наименования позиции в ячейке. =ВПР ищет точное соответствие и не подходит.
По старинке я составлял список фраз, но он периодически меняется и очень трудно добавлять новые вариации. Делал это так:
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК("*Кровать больничная**"; $B11));ЕЧИСЛО(ПОИСК("*Кресло**";$B11));ЕЧИСЛО(ПОИСК("*Стол операционный**";$B11)));$L11;0)

Все о чем пишу, есть в приложенном экселе с пояснениями. Помогите ,уже неделю бьюсь.
К сообщению приложен файл: ____1.xls(95.0 Kb)
 
Ответить
СообщениеЕсть список позиций в колонке. Необходимо сравнить каждую позицию в колонке с наименованием позиции в ячейке. НО! Список - это *часть фразы* из наименования позиции в ячейке. =ВПР ищет точное соответствие и не подходит.
По старинке я составлял список фраз, но он периодически меняется и очень трудно добавлять новые вариации. Делал это так:
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК("*Кровать больничная**"; $B11));ЕЧИСЛО(ПОИСК("*Кресло**";$B11));ЕЧИСЛО(ПОИСК("*Стол операционный**";$B11)));$L11;0)

Все о чем пишу, есть в приложенном экселе с пояснениями. Помогите ,уже неделю бьюсь.

Автор - serg52
Дата добавления - 05.07.2019 в 15:20
sboy Дата: Пятница, 05.07.2019, 15:32 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 721 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял, формула массива
Код
=L11*СУММ(--ЕЧИСЛО(ПОИСК($S$2:$S$5;B11)))
К сообщению приложен файл: _1.xls(93.0 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Если правильно понял, формула массива
Код
=L11*СУММ(--ЕЧИСЛО(ПОИСК($S$2:$S$5;B11)))

Автор - sboy
Дата добавления - 05.07.2019 в 15:32
_Boroda_ Дата: Пятница, 05.07.2019, 15:36 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(СЧЁТ(ПОИСК(S$2:S$5;B11));L11;)
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Или обычная формула
Код
=ЕСЛИ(СЧЁТ(ИНДЕКС(ПОИСК(S$2:S$5;B11);));L11;)


sboy, а если больше одного совпадения найдется?
К сообщению приложен файл: _1_1.xls(91.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(СЧЁТ(ПОИСК(S$2:S$5;B11));L11;)
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Или обычная формула
Код
=ЕСЛИ(СЧЁТ(ИНДЕКС(ПОИСК(S$2:S$5;B11);));L11;)


sboy, а если больше одного совпадения найдется?

Автор - _Boroda_
Дата добавления - 05.07.2019 в 15:36
sboy Дата: Пятница, 05.07.2019, 15:40 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 721 ±
Замечаний: 0% ±

Excel 2010
а если больше одного совпадения найдется?

можно поделить на СЧЁТ :)


Яндекс: 410016850021169
 
Ответить
Сообщение
а если больше одного совпадения найдется?

можно поделить на СЧЁТ :)

Автор - sboy
Дата добавления - 05.07.2019 в 15:40
serg52 Дата: Пятница, 05.07.2019, 16:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное ребята! Вы просто мастера.
Можно для улучшения форума добавить вариант с делением на счет и вопрос исчерпан !
 
Ответить
СообщениеСпасибо огромное ребята! Вы просто мастера.
Можно для улучшения форума добавить вариант с делением на счет и вопрос исчерпан !

Автор - serg52
Дата добавления - 05.07.2019 в 16:30
Светлый Дата: Пятница, 05.07.2019, 18:59 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1147
Репутация: 292 ±
Замечаний: 0% ±

Excel 2010
можно поделить на СЧЁТ
Зачем?
Код
=L11*ИЛИ(ЕЧИСЛО(ПОИСК($S$2:$S$5;B11)))


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
можно поделить на СЧЁТ
Зачем?
Код
=L11*ИЛИ(ЕЧИСЛО(ПОИСК($S$2:$S$5;B11)))

Автор - Светлый
Дата добавления - 05.07.2019 в 18:59
serg52 Дата: Вторник, 16.07.2019, 12:43 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Еще одна просьба, допилить файл. Дело в том, что появился вариант такой, что: нужно из списка массива совпадений, после самого совпадения, возвращать значение числа, которое находится правее совпавшей ячейки. Файл прилагаю, в строке Q11 написано, что я хочу получить, т.к. не уверен, что здесь четко сформулировал.
К сообщению приложен файл: -1_1.xls(91.0 Kb)
 
Ответить
СообщениеЕще одна просьба, допилить файл. Дело в том, что появился вариант такой, что: нужно из списка массива совпадений, после самого совпадения, возвращать значение числа, которое находится правее совпавшей ячейки. Файл прилагаю, в строке Q11 написано, что я хочу получить, т.к. не уверен, что здесь четко сформулировал.

Автор - serg52
Дата добавления - 16.07.2019 в 12:43
serg52 Дата: Вторник, 16.07.2019, 16:01 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Может так проще будет: сделал таблицу в которую будут заполняться данные непосредственно.
Есть список неполных совпадений. Хочу сделать так, что бы в колонке "Название из списка совпадений"появлялось название, совпавшее с "Наименование помещения", а в колонке "Норм осещенность (лк)" соответствующая цифра (хотел при помощи =ВПР сделать, ничего не выходит, выдает какое то левое значение). Помогите плиз, пример прилагаю. Уже весь день на работе проковырялся, результатов - 0.
К сообщению приложен файл: 0425643.xls(34.0 Kb)
 
Ответить
СообщениеМожет так проще будет: сделал таблицу в которую будут заполняться данные непосредственно.
Есть список неполных совпадений. Хочу сделать так, что бы в колонке "Название из списка совпадений"появлялось название, совпавшее с "Наименование помещения", а в колонке "Норм осещенность (лк)" соответствующая цифра (хотел при помощи =ВПР сделать, ничего не выходит, выдает какое то левое значение). Помогите плиз, пример прилагаю. Уже весь день на работе проковырялся, результатов - 0.

Автор - serg52
Дата добавления - 16.07.2019 в 16:01
Pelena Дата: Вторник, 16.07.2019, 16:28 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14216
Репутация: 3106 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
хотел при помощи =ВПР сделать
Забыли четвертый аргумент
Код
=ВПР(A13;M$3:N$23;2;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
хотел при помощи =ВПР сделать
Забыли четвертый аргумент
Код
=ВПР(A13;M$3:N$23;2;0)

Автор - Pelena
Дата добавления - 16.07.2019 в 16:28
serg52 Дата: Вторник, 16.07.2019, 16:44 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, спасибо, вторая часть заработала =) А как первую реализовать, что бы в первой колонке заполнение было? Без точного совпадения, функция ВПР не будет работать!


Сообщение отредактировал serg52 - Вторник, 16.07.2019, 17:26
 
Ответить
СообщениеPelena, спасибо, вторая часть заработала =) А как первую реализовать, что бы в первой колонке заполнение было? Без точного совпадения, функция ВПР не будет работать!

Автор - serg52
Дата добавления - 16.07.2019 в 16:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск соответствия части фразы- целой фразе.(частей неск-ко) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!