Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ограничитель повторов в формуле суммирования ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ограничитель повторов в формуле суммирования ячеек (Формулы/Formulas)
Ограничитель повторов в формуле суммирования ячеек
Che79 Дата: Пятница, 26.07.2019, 18:32 | Сообщение № 1
Группа: Проверенные
Ранг: Старожил
Сообщений: 1374
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
Всех приветствую!
В пятницу голова не варит, поэтому я с вопросом)
Такая задачка. В столбце A динамический числовой массив, количество заполненных вниз ячеек либо увеличивается, либо уменьшается. В идеале, в соседнем столбце нужно вывести протягиваемую формулу, которая суммирует значение первой ячейки с последней, вторую с предпоследней, третью с третьей снизу и т.д. Саму формулу я не особо думая написал так
Код
=ИНДЕКС(A:A;СЧЁТ(A$1:A1))+ИНДЕКС(A:A;СЧЁТ(A1:ИНДЕКС(A:A;ПОИСКПОЗ(9^9;A:A))))

А вот как всунуть в формулу обработчик-ограничитель повторов? Когда этот ряд слагаемых сверху и снизу сомкнулся, чтобы Excel больше не считал суммы в обратном порядке. Что-то с ходу пока не соображу.
Желтые ячейке в файле-примере - как получается, зелёные - как нужно.
Крайне признателен за отклики! Сильно не пинайте, если спросил глупость.
К сообщению приложен файл: 010715.xlsx(9.9 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВсех приветствую!
В пятницу голова не варит, поэтому я с вопросом)
Такая задачка. В столбце A динамический числовой массив, количество заполненных вниз ячеек либо увеличивается, либо уменьшается. В идеале, в соседнем столбце нужно вывести протягиваемую формулу, которая суммирует значение первой ячейки с последней, вторую с предпоследней, третью с третьей снизу и т.д. Саму формулу я не особо думая написал так
Код
=ИНДЕКС(A:A;СЧЁТ(A$1:A1))+ИНДЕКС(A:A;СЧЁТ(A1:ИНДЕКС(A:A;ПОИСКПОЗ(9^9;A:A))))

А вот как всунуть в формулу обработчик-ограничитель повторов? Когда этот ряд слагаемых сверху и снизу сомкнулся, чтобы Excel больше не считал суммы в обратном порядке. Что-то с ходу пока не соображу.
Желтые ячейке в файле-примере - как получается, зелёные - как нужно.
Крайне признателен за отклики! Сильно не пинайте, если спросил глупость.

Автор - Che79
Дата добавления - 26.07.2019 в 18:32
Kostya_Ye Дата: Пятница, 26.07.2019, 18:39 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 89
Репутация: 16 ±
Замечаний: 0% ±

Excel 2016
Che79,
добрый день,

так ?
Код
=IF(ROW()<=COUNT(A:A)/2;A1+INDEX(A:A;COUNT(A:A)+1-ROW());"")

неясно только как должно считаться при нечетном количестве значений в А:А


Сообщение отредактировал Kostya_Ye - Пятница, 26.07.2019, 18:41
 
Ответить
СообщениеChe79,
добрый день,

так ?
Код
=IF(ROW()<=COUNT(A:A)/2;A1+INDEX(A:A;COUNT(A:A)+1-ROW());"")

неясно только как должно считаться при нечетном количестве значений в А:А

Автор - Kostya_Ye
Дата добавления - 26.07.2019 в 18:39
Светлый Дата: Пятница, 26.07.2019, 18:51 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
При нечётном количестве центральная будет дважды:
Код
=ЕСЛИ(СЧЁТ(A:A)>=СТРОКА()*2-1;A1+ИНДЕКС(A:A;СЧЁТ(A:A)-СТРОКА()+1);"")
*А пропуски могут быть?


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 26.07.2019, 18:56
 
Ответить
СообщениеПри нечётном количестве центральная будет дважды:
Код
=ЕСЛИ(СЧЁТ(A:A)>=СТРОКА()*2-1;A1+ИНДЕКС(A:A;СЧЁТ(A:A)-СТРОКА()+1);"")
*А пропуски могут быть?

Автор - Светлый
Дата добавления - 26.07.2019 в 18:51
Che79 Дата: Пятница, 26.07.2019, 18:52 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1374
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
Константин, спасибо, оно)
при нечетном количестве значений в А:А
последнее значение суммируется само с собой..


Делай нормально и будет нормально!
 
Ответить
СообщениеКонстантин, спасибо, оно)
при нечетном количестве значений в А:А
последнее значение суммируется само с собой..

Автор - Che79
Дата добавления - 26.07.2019 в 18:52
Che79 Дата: Пятница, 26.07.2019, 18:54 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1374
Репутация: 246 ±
Замечаний: 0% ±

Excel 2013
Светлый, спасибо, как всегда в точку!
Цитата Светлый, 26.07.2019 в 18:51, в сообщении № 3 ()
А пропуски могут быть?
*нет, к счастью массив без пропусков


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 26.07.2019, 19:00
 
Ответить
СообщениеСветлый, спасибо, как всегда в точку!
Цитата Светлый, 26.07.2019 в 18:51, в сообщении № 3 ()
А пропуски могут быть?
*нет, к счастью массив без пропусков

Автор - Che79
Дата добавления - 26.07.2019 в 18:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ограничитель повторов в формуле суммирования ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!