Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР и Индекс не находят соответствие - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР и Индекс не находят соответствие (Excel)
ВПР и Индекс не находят соответствие
Koneu Дата: Понедельник, 29.07.2019, 17:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть задача нужно сравнить 2 столбца, но как ВПР так и Индекс дают #Н/Д, подскажите как решить эту проблему... Может быть есть какое либо другое решение более точное и рациональное. Мне нужно чтобы рядом со значениями "Артикул1" встали данные из Столбца "Цена", которые соответствуют Столбцу "Артикул 2". Наглядно в приложении к теме
К сообщению приложен файл: 0966659.xlsx(28.2 Kb)
 
Ответить
СообщениеЕсть задача нужно сравнить 2 столбца, но как ВПР так и Индекс дают #Н/Д, подскажите как решить эту проблему... Может быть есть какое либо другое решение более точное и рациональное. Мне нужно чтобы рядом со значениями "Артикул1" встали данные из Столбца "Цена", которые соответствуют Столбцу "Артикул 2". Наглядно в приложении к теме

Автор - Koneu
Дата добавления - 29.07.2019 в 17:34
_Boroda_ Дата: Понедельник, 29.07.2019, 18:15 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15646
Репутация: 6115 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы забыли закрепить области диапазона
Код
=ВПР(C2;F$2:G$158;2;)

Код
=ИНДЕКС(G$2:G$158;ПОИСКПОЗ(B2;E$2:E$158;))

Почитайте про абсолютные и относительные ссылки
К сообщению приложен файл: 0966659_1.xlsx(26.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы забыли закрепить области диапазона
Код
=ВПР(C2;F$2:G$158;2;)

Код
=ИНДЕКС(G$2:G$158;ПОИСКПОЗ(B2;E$2:E$158;))

Почитайте про абсолютные и относительные ссылки

Автор - _Boroda_
Дата добавления - 29.07.2019 в 18:15
Koneu Дата: Понедельник, 29.07.2019, 22:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Большое спасибо снова выручили! )
 
Ответить
Сообщение_Boroda_, Большое спасибо снова выручили! )

Автор - Koneu
Дата добавления - 29.07.2019 в 22:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР и Индекс не находят соответствие (Excel)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!