Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматический перенос номеров тел. по фамилиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический перенос номеров тел. по фамилиям (Формулы/Formulas)
Автоматический перенос номеров тел. по фамилиям
kenn Дата: Вторник, 13.08.2019, 12:55 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Добрый день!Прошу помощи! Есть две вкладки на листе! Нужно что бы на лист1 подтягивались данные номера телефонов согласно ФИО из лист2!
К сообщению приложен файл: 2310019.xlsx(16.2 Kb)
 
Ответить
СообщениеДобрый день!Прошу помощи! Есть две вкладки на листе! Нужно что бы на лист1 подтягивались данные номера телефонов согласно ФИО из лист2!

Автор - kenn
Дата добавления - 13.08.2019 в 12:55
китин Дата: Вторник, 13.08.2019, 13:05 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
В ячейку G2 Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter и протянуть
Код
=ИНДЕКС(Лист2!$C$4:$C$6;ПОИСКПОЗ(СЖПРОБЕЛЫ(ПСТР($E3;1;ПОИСК("Распоряжение";$E3)-1));СЖПРОБЕЛЫ(ПСТР(Лист2!$B$4:$B$6;1;ПОИСК("Распоряжение";Лист2!$B$4:$B$6)-1));0))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВ ячейку G2 Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter и протянуть
Код
=ИНДЕКС(Лист2!$C$4:$C$6;ПОИСКПОЗ(СЖПРОБЕЛЫ(ПСТР($E3;1;ПОИСК("Распоряжение";$E3)-1));СЖПРОБЕЛЫ(ПСТР(Лист2!$B$4:$B$6;1;ПОИСК("Распоряжение";Лист2!$B$4:$B$6)-1));0))

Автор - китин
Дата добавления - 13.08.2019 в 13:05
_Boroda_ Дата: Вторник, 13.08.2019, 13:12 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/(СЖПРОБЕЛЫ(E3)=СЖПРОБЕЛЫ(Лист2!B$4:B$9));Лист2!C$4:C$9)


А, подождите, только ФИО? Тогда сейчас
Во
Код
=ПРОСМОТР(;-ПОИСК(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(E3;" ";ПОВТОР(" ";99);3);99));Лист2!B$4:B$9);Лист2!C$4:C$9)
К сообщению приложен файл: 2310019_1.xlsx(12.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/(СЖПРОБЕЛЫ(E3)=СЖПРОБЕЛЫ(Лист2!B$4:B$9));Лист2!C$4:C$9)


А, подождите, только ФИО? Тогда сейчас
Во
Код
=ПРОСМОТР(;-ПОИСК(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(E3;" ";ПОВТОР(" ";99);3);99));Лист2!B$4:B$9);Лист2!C$4:C$9)

Автор - _Boroda_
Дата добавления - 13.08.2019 в 13:12
kenn Дата: Вторник, 13.08.2019, 14:02 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, китин, Огромное Спасибо! Всё работает! hands
 
Ответить
Сообщение_Boroda_, китин, Огромное Спасибо! Всё работает! hands

Автор - kenn
Дата добавления - 13.08.2019 в 14:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический перенос номеров тел. по фамилиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!