Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных по дате и вставка в отчетную форму - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных по дате и вставка в отчетную форму (Формулы/Formulas)
Сбор данных по дате и вставка в отчетную форму
Hermes Дата: Пятница, 16.08.2019, 09:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, друзья.

Есть 2 листа - на одном накапливается данные по продажам по регионам на ежедневной основе, на другом - универсальная форма отчета, куда должны попадать данные с первого листа по выбранной дате и по региону. Задача состоит в том, чтобы перенести необходимые данные с таблицы накопителя в таблицу отчетной формы При этом без применения VBA и макросов. Продажи приведены для примера. Пока встал в тупик, из которого сам выбраться не могу. Может быть взгляд со стороны поможет.

Хорошо бы конечно чтобы форма менялась динамически (в зависимости от количества данных в общей таблице убирались пустые строки или добавлялись необходимые), но здесь вполне возможна банальная фильтрация по пустым ячейкам. (пустая ячейка не отображается)

Спасибо
К сообщению приложен файл: 5988590.xlsx(15.4 Kb)
 
Ответить
СообщениеДобрый день, друзья.

Есть 2 листа - на одном накапливается данные по продажам по регионам на ежедневной основе, на другом - универсальная форма отчета, куда должны попадать данные с первого листа по выбранной дате и по региону. Задача состоит в том, чтобы перенести необходимые данные с таблицы накопителя в таблицу отчетной формы При этом без применения VBA и макросов. Продажи приведены для примера. Пока встал в тупик, из которого сам выбраться не могу. Может быть взгляд со стороны поможет.

Хорошо бы конечно чтобы форма менялась динамически (в зависимости от количества данных в общей таблице убирались пустые строки или добавлялись необходимые), но здесь вполне возможна банальная фильтрация по пустым ячейкам. (пустая ячейка не отображается)

Спасибо

Автор - Hermes
Дата добавления - 16.08.2019 в 09:30
китин Дата: Пятница, 16.08.2019, 09:52 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а что мешает использовать сводную таблицу?
К сообщению приложен файл: 8454961.xlsx(22.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа что мешает использовать сводную таблицу?

Автор - китин
Дата добавления - 16.08.2019 в 09:52
Светлый Дата: Пятница, 16.08.2019, 10:09 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Можно вот такой массивной (Ctrl+Shift+Enter) формулой для наименования покупателя воспользоваться:
Код
=ЕСЛИОШИБКА(ИНДЕКС('Сводная таблица'!D:D;НАИМЕНЬШИЙ(ЕСЛИ((ПРОСМОТР(;-1/(Т(+$A$1:$A5)<>"");$A$1:$A5)='Сводная таблица'!$C$3:$C$99)*($C$1='Сводная таблица'!$B$3:$B$99);СТРОКА($3:$99));$A6));"")
Формула копируется на весь столбец. Можно с перерывами.
Можно для наименований городов и нумерации придумать формулу для автоматической вставки.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно вот такой массивной (Ctrl+Shift+Enter) формулой для наименования покупателя воспользоваться:
Код
=ЕСЛИОШИБКА(ИНДЕКС('Сводная таблица'!D:D;НАИМЕНЬШИЙ(ЕСЛИ((ПРОСМОТР(;-1/(Т(+$A$1:$A5)<>"");$A$1:$A5)='Сводная таблица'!$C$3:$C$99)*($C$1='Сводная таблица'!$B$3:$B$99);СТРОКА($3:$99));$A6));"")
Формула копируется на весь столбец. Можно с перерывами.
Можно для наименований городов и нумерации придумать формулу для автоматической вставки.

Автор - Светлый
Дата добавления - 16.08.2019 в 10:09
Hermes Дата: Пятница, 16.08.2019, 10:34 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Сводную форму мешает использовать установленная форма заполнения отчета.
 
Ответить
СообщениеСводную форму мешает использовать установленная форма заполнения отчета.

Автор - Hermes
Дата добавления - 16.08.2019 в 10:34
Hermes Дата: Пятница, 16.08.2019, 11:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Не совсем так. Мне нужно чтобы например за 1-е число в раздел Москва прогрузились (скопировались, отфильтровались) все ячейки которые относятся к этой дате и регионе.
Я вручую сейчас перекинул данные и выделил цветом, чтобы было понятнее

Так то можно было бы использовать например ВПР, ориенируясь на дату и на регион. Но тут пришлось бы ввести дополнительный столбец с несквозной нумерацией, что может привести к ошибкам.
К сообщению приложен файл: 5881831.xlsx(15.9 Kb)


Сообщение отредактировал Hermes - Пятница, 16.08.2019, 11:31
 
Ответить
СообщениеНе совсем так. Мне нужно чтобы например за 1-е число в раздел Москва прогрузились (скопировались, отфильтровались) все ячейки которые относятся к этой дате и регионе.
Я вручую сейчас перекинул данные и выделил цветом, чтобы было понятнее

Так то можно было бы использовать например ВПР, ориенируясь на дату и на регион. Но тут пришлось бы ввести дополнительный столбец с несквозной нумерацией, что может привести к ошибкам.

Автор - Hermes
Дата добавления - 16.08.2019 в 11:28
Светлый Дата: Пятница, 16.08.2019, 11:46 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
установленная форма
Попробуем оставить эту форму. Добавил разные формулы и УФ.
К сообщению приложен файл: 5988590-1.xlsx(19.4 Kb)


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
установленная форма
Попробуем оставить эту форму. Добавил разные формулы и УФ.

Автор - Светлый
Дата добавления - 16.08.2019 в 11:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных по дате и вставка в отчетную форму (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!