Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение цифр в скобках в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение цифр в скобках в ячейке (Формулы/Formulas)
Сложение цифр в скобках в ячейке
Silver777 Дата: Среда, 21.08.2019, 14:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
В ячейке вот такое значение : " 50*70 (2) и 70*70 (2) " , нужно сложить то что в скобках ,подскажите пожалуйста формулу ,спасибо!
 
Ответить
СообщениеВ ячейке вот такое значение : " 50*70 (2) и 70*70 (2) " , нужно сложить то что в скобках ,подскажите пожалуйста формулу ,спасибо!

Автор - Silver777
Дата добавления - 21.08.2019 в 14:00
Nic70y Дата: Среда, 21.08.2019, 14:29 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
какие еще варианты бывают?
файл бы с примерами так 18-19 ячеек приложили бы.


ЯД(poison) 41001841029809
 
Ответить
Сообщениекакие еще варианты бывают?
файл бы с примерами так 18-19 ячеек приложили бы.

Автор - Nic70y
Дата добавления - 21.08.2019 в 14:29
Silver777 Дата: Среда, 21.08.2019, 15:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, приложил файл, вариантов значений не так и много
К сообщению приложен файл: 8876471.xlsx(8.2 Kb)


Сообщение отредактировал Silver777 - Среда, 21.08.2019, 15:19
 
Ответить
СообщениеNic70y, приложил файл, вариантов значений не так и много

Автор - Silver777
Дата добавления - 21.08.2019 в 15:18
Silver777 Дата: Среда, 21.08.2019, 15:21 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
можно конечно сделать через перебор функцией "если", но может есть более простой механизм? на другие случаи


Сообщение отредактировал Silver777 - Среда, 21.08.2019, 15:21
 
Ответить
Сообщениеможно конечно сделать через перебор функцией "если", но может есть более простой механизм? на другие случаи

Автор - Silver777
Дата добавления - 21.08.2019 в 15:21
Nic70y Дата: Среда, 21.08.2019, 15:29 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
строго по Вашему примеру
Код
=-(ПСТР(A1;7;3)+ПСТР(A1&"000000000000";19;3))
К сообщению приложен файл: 6361006.xlsx(8.5 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениестрого по Вашему примеру
Код
=-(ПСТР(A1;7;3)+ПСТР(A1&"000000000000";19;3))

Автор - Nic70y
Дата добавления - 21.08.2019 в 15:29
bmv98rus Дата: Среда, 21.08.2019, 15:30 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2528
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
Если в скобках от 1 до 9 может быть , то например так
Код
=SUM((LEN(A1)-LEN(SUBSTITUTE(A1;"("&{1;2;3;4;5;6;7;8;9}&")";)))/3*{1;2;3;4;5;6;7;8;9})
К сообщению приложен файл: Copy_of_1104.xlsx(13.8 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 21.08.2019, 16:02
 
Ответить
СообщениеЕсли в скобках от 1 до 9 может быть , то например так
Код
=SUM((LEN(A1)-LEN(SUBSTITUTE(A1;"("&{1;2;3;4;5;6;7;8;9}&")";)))/3*{1;2;3;4;5;6;7;8;9})

Автор - bmv98rus
Дата добавления - 21.08.2019 в 15:30
Silver777 Дата: Среда, 21.08.2019, 15:36 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
отлично, спасибо! , смысл понятен, ищет нужное значение в строке по номеру положения
 
Ответить
Сообщениеотлично, спасибо! , смысл понятен, ищет нужное значение в строке по номеру положения

Автор - Silver777
Дата добавления - 21.08.2019 в 15:36
Silver777 Дата: Среда, 21.08.2019, 16:00 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, есть файл работающей формулой?, у меня ошибку выдает
 
Ответить
Сообщениеbmv98rus, есть файл работающей формулой?, у меня ошибку выдает

Автор - Silver777
Дата добавления - 21.08.2019 в 16:00
Светлый Дата: Среда, 21.08.2019, 17:50 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Ещё вариант массивной (Ctrl+Shift+Enter) формулы:
Код
=СУММ(ЕСЛИОШИБКА(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A1;(ПСТР(A1;СТРОКА($1:$99);1)="(")*СТРОКА($1:$99);8);")";")     ");8);))
*Или так можно:
Код
=СУММ(ЕСЛИОШИБКА(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(A1;"(";"#(");СТРОКА($1:$99);8);")";")     ");8);))
**Тоже массивная:
Код
=СУММ(ЕСЛИОШИБКА(-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"(";"#(");")";")     ");СТРОКА($1:$99);8);))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 21.08.2019, 18:39
 
Ответить
СообщениеЕщё вариант массивной (Ctrl+Shift+Enter) формулы:
Код
=СУММ(ЕСЛИОШИБКА(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A1;(ПСТР(A1;СТРОКА($1:$99);1)="(")*СТРОКА($1:$99);8);")";")     ");8);))
*Или так можно:
Код
=СУММ(ЕСЛИОШИБКА(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(A1;"(";"#(");СТРОКА($1:$99);8);")";")     ");8);))
**Тоже массивная:
Код
=СУММ(ЕСЛИОШИБКА(-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"(";"#(");")";")     ");СТРОКА($1:$99);8);))

Автор - Светлый
Дата добавления - 21.08.2019 в 17:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение цифр в скобках в ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!