Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сколько раз, после одного значения следовали другие - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько раз, после одного значения следовали другие (Формулы/Formulas)
Сколько раз, после одного значения следовали другие
freedom0506 Дата: Суббота, 24.08.2019, 23:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Приветствую всех. Помогите справится с задачей: Сколько раз в столбце после каждого значения, по порядку, следовали другие значения. Пример заполнения таблицы в прицепе. Уважаемые знатоки, буду признателен за формулу.
К сообщению приложен файл: Microsoft_Excel.xlsx(8.6 Kb)


Сообщение отредактировал freedom0506 - Воскресенье, 25.08.2019, 00:37
 
Ответить
СообщениеПриветствую всех. Помогите справится с задачей: Сколько раз в столбце после каждого значения, по порядку, следовали другие значения. Пример заполнения таблицы в прицепе. Уважаемые знатоки, буду признателен за формулу.

Автор - freedom0506
Дата добавления - 24.08.2019 в 23:17
Pelena Дата: Суббота, 24.08.2019, 23:40 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14473
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Дайте теме более конкретное название, отражающее суть задачи, в соответствии с Правилами форума.
И файл с примером желательно, в каком виде нужен результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДайте теме более конкретное название, отражающее суть задачи, в соответствии с Правилами форума.
И файл с примером желательно, в каком виде нужен результат

Автор - Pelena
Дата добавления - 24.08.2019 в 23:40
Светлый Дата: Воскресенье, 25.08.2019, 12:47 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Код
=СУММПРОИЗВ(($A$1:$A$9=СТРОКА(C1))*($A$2:$A$10=C$1))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Код
=СУММПРОИЗВ(($A$1:$A$9=СТРОКА(C1))*($A$2:$A$10=C$1))

Автор - Светлый
Дата добавления - 25.08.2019 в 12:47
freedom0506 Дата: Воскресенье, 25.08.2019, 13:31 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Вот это силища, спасибо огромное.
 
Ответить
СообщениеВот это силища, спасибо огромное.

Автор - freedom0506
Дата добавления - 25.08.2019 в 13:31
freedom0506 Дата: Воскресенье, 25.08.2019, 14:06 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
строка для нуля не считается. Будте добры, подправте пожалуйста.
К сообщению приложен файл: 9167684.xlsx(9.5 Kb)
 
Ответить
Сообщениестрока для нуля не считается. Будте добры, подправте пожалуйста.

Автор - freedom0506
Дата добавления - 25.08.2019 в 14:06
Светлый Дата: Воскресенье, 25.08.2019, 14:24 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Как пожелаете.
Код
=СУММПРОИЗВ(($A$2:$A$17=СТРОКА(C1)-1)*($A$3:$A$18=C$1))
*Можно и так:
Код
=СУММПРОИЗВ(($A$2:$A$17=--ПРАВБ($B2))*($A$3:$A$18=C$1))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Воскресенье, 25.08.2019, 14:47
 
Ответить
СообщениеКак пожелаете.
Код
=СУММПРОИЗВ(($A$2:$A$17=СТРОКА(C1)-1)*($A$3:$A$18=C$1))
*Можно и так:
Код
=СУММПРОИЗВ(($A$2:$A$17=--ПРАВБ($B2))*($A$3:$A$18=C$1))

Автор - Светлый
Дата добавления - 25.08.2019 в 14:24
freedom0506 Дата: Воскресенье, 25.08.2019, 14:28 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
волшебник
 
Ответить
Сообщениеволшебник

Автор - freedom0506
Дата добавления - 25.08.2019 в 14:28
freedom0506 Дата: Понедельник, 26.08.2019, 22:18 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемый старожил форума, не хотел бы злоупотреблять Вашим внимание, но помогите в крайний раз пожалуйста. Сейчас, по столбцу А, считаем с верху вниз, а надо снизу в верх.
К сообщению приложен файл: 5549044.xlsx(10.2 Kb)


Сообщение отредактировал freedom0506 - Понедельник, 26.08.2019, 22:19
 
Ответить
СообщениеУважаемый старожил форума, не хотел бы злоупотреблять Вашим внимание, но помогите в крайний раз пожалуйста. Сейчас, по столбцу А, считаем с верху вниз, а надо снизу в верх.

Автор - freedom0506
Дата добавления - 26.08.2019 в 22:18
Светлый Дата: Вторник, 27.08.2019, 06:09 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(($A$3:$A$18=СТРОКА(C1)-1)*($A$2:$A$17=C$1))


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($A$3:$A$18=СТРОКА(C1)-1)*($A$2:$A$17=C$1))

Автор - Светлый
Дата добавления - 27.08.2019 в 06:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько раз, после одного значения следовали другие (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!