Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор данных из массива по заданному условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных из массива по заданному условию (Формулы/Formulas)
Выбор данных из массива по заданному условию
Маруся_Эврика Дата: Воскресенье, 25.08.2019, 14:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не получается разобраться почему выдает ошибку. При выборе наименования из выпадающего списка выдавать данные по отгрузке на определенную дату.
К сообщению приложен файл: 8256499.xlsx(13.2 Kb)
 
Ответить
СообщениеНе получается разобраться почему выдает ошибку. При выборе наименования из выпадающего списка выдавать данные по отгрузке на определенную дату.

Автор - Маруся_Эврика
Дата добавления - 25.08.2019 в 14:33
Светлый Дата: Воскресенье, 25.08.2019, 15:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
И Вам здравствуйте!
Формула массива (одновременное нажатие Ctrl+Shift+Enter):
Код
=ИНДЕКС($C$2:$L$10;ПОИСКПОЗ(B20&$F$32;$B$2:$B$10&$A$2:$A$10;);ПОИСКПОЗ($F$16;$C$1:$L$1;))
Или простая:
Код
=СУММПРОИЗВ((B20&F$32=B$2:B$10&A$2:A$10)*(F$16=C$1:L$1);C$2:L$10)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ Вам здравствуйте!
Формула массива (одновременное нажатие Ctrl+Shift+Enter):
Код
=ИНДЕКС($C$2:$L$10;ПОИСКПОЗ(B20&$F$32;$B$2:$B$10&$A$2:$A$10;);ПОИСКПОЗ($F$16;$C$1:$L$1;))
Или простая:
Код
=СУММПРОИЗВ((B20&F$32=B$2:B$10&A$2:A$10)*(F$16=C$1:L$1);C$2:L$10)

Автор - Светлый
Дата добавления - 25.08.2019 в 15:22
Маруся_Эврика Дата: Воскресенье, 25.08.2019, 16:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, добрый день! Спасибо большое.
 
Ответить
СообщениеСветлый, добрый день! Спасибо большое.

Автор - Маруся_Эврика
Дата добавления - 25.08.2019 в 16:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных из массива по заданному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!