Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Учёт равнозначных критериев в подсчёте со многими условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учёт равнозначных критериев в подсчёте со многими условиями (Формулы/Formulas)
Учёт равнозначных критериев в подсчёте со многими условиями
Chesse Дата: Суббота, 31.08.2019, 14:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Подскажите, пожалуйста, чем заменить функцию ИЛИ() внутри функции СЧЁТЕСЛИМН(). Знаю, что самое простое - это сделать СЧЁТЕСЛИМН()+СЧЁТЕСЛИМН(), но у меня длинная формула (уже на 10 строк), если я каждую эту формулу удвою, у меня минимум удвоится количество строк и увеличится шанс запутаться и где-то ошибиться. На форумах вычитала, что можно использовать {}, внутри которых перечисляются условия, но у меня формула в этом случае считает только по первому критерию. Если кто-то предложит что-то полезное, буду очень благодарна!
К сообщению приложен файл: _31.08.2019.xlsx(57.1 Kb)


Сообщение отредактировал Chesse - Суббота, 31.08.2019, 19:16
 
Ответить
СообщениеЗдравствуйте. Подскажите, пожалуйста, чем заменить функцию ИЛИ() внутри функции СЧЁТЕСЛИМН(). Знаю, что самое простое - это сделать СЧЁТЕСЛИМН()+СЧЁТЕСЛИМН(), но у меня длинная формула (уже на 10 строк), если я каждую эту формулу удвою, у меня минимум удвоится количество строк и увеличится шанс запутаться и где-то ошибиться. На форумах вычитала, что можно использовать {}, внутри которых перечисляются условия, но у меня формула в этом случае считает только по первому критерию. Если кто-то предложит что-то полезное, буду очень благодарна!

Автор - Chesse
Дата добавления - 31.08.2019 в 14:53
прохожий2019 Дата: Суббота, 31.08.2019, 16:12 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
а банальной сводной таблицей никак?
 
Ответить
Сообщениеа банальной сводной таблицей никак?

Автор - прохожий2019
Дата добавления - 31.08.2019 в 16:12
Chesse Дата: Суббота, 31.08.2019, 16:24 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Нет, мне не удобно использовать сводные таблицы при работе через гугл таблицы или с телефона.
Я пока развлекаюсь СЧЁТЕСЛИМН+СЧЁТЕСЛИМН, но это слишком громоздко получается
 
Ответить
СообщениеНет, мне не удобно использовать сводные таблицы при работе через гугл таблицы или с телефона.
Я пока развлекаюсь СЧЁТЕСЛИМН+СЧЁТЕСЛИМН, но это слишком громоздко получается

Автор - Chesse
Дата добавления - 31.08.2019 в 16:24
прохожий2019 Дата: Суббота, 31.08.2019, 16:48 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
через гугл таблицы или с телефона
так с этого и надо было начинать...
 
Ответить
Сообщение
через гугл таблицы или с телефона
так с этого и надо было начинать...

Автор - прохожий2019
Дата добавления - 31.08.2019 в 16:48
Chesse Дата: Суббота, 31.08.2019, 17:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата прохожий2019, 31.08.2019 в 16:48, в сообщении № 4 ()
так с этого и надо было начинать...

С чего? Формулу я делаю в экселе, а не в гугл таблицах.
Вопрос в формуле, а не в том, как использовать сводные таблицы. ИЛИ() не работает в СЧЁТЕСЛИМН(), если вы знаете, чем ИЛИ() можно заменить, будет здорово)
 
Ответить
Сообщение
Цитата прохожий2019, 31.08.2019 в 16:48, в сообщении № 4 ()
так с этого и надо было начинать...

С чего? Формулу я делаю в экселе, а не в гугл таблицах.
Вопрос в формуле, а не в том, как использовать сводные таблицы. ИЛИ() не работает в СЧЁТЕСЛИМН(), если вы знаете, чем ИЛИ() можно заменить, будет здорово)

Автор - Chesse
Дата добавления - 31.08.2019 в 17:02
прохожий2019 Дата: Суббота, 31.08.2019, 17:12 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
чем ИЛИ() можно заменить
ничем, заменить можно СЧЁТЕСЛИМН на СУММПРОИЗВ
можно использовать {}, внутри которых перечисляются условия, но у меня формула в этом случае считает только по первому критерию
значит ввели не как формулу массива Ctrl+Shift+Enter
Было бы гораздо проще, если бы показали в файле, чего хотите добиться
 
Ответить
Сообщение
чем ИЛИ() можно заменить
ничем, заменить можно СЧЁТЕСЛИМН на СУММПРОИЗВ
можно использовать {}, внутри которых перечисляются условия, но у меня формула в этом случае считает только по первому критерию
значит ввели не как формулу массива Ctrl+Shift+Enter
Было бы гораздо проще, если бы показали в файле, чего хотите добиться

Автор - прохожий2019
Дата добавления - 31.08.2019 в 17:12
Chesse Дата: Суббота, 31.08.2019, 17:22 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата прохожий2019, 31.08.2019 в 17:12, в сообщении № 6 ()
значит ввели не как формулу массива Ctrl+Shift+Enter

Не как формулу массива, да. Попробую сейчас

Цитата прохожий2019, 31.08.2019 в 17:12, в сообщении № 6 ()
СУММПРОИЗВ

Возможно, я не очень хорошо знаю эту формулу, но в моём случае она, скорее всего, не подойдёт

Цитата прохожий2019, 31.08.2019 в 17:12, в сообщении № 6 ()
Было бы гораздо проще, если бы показали в файле, чего хотите добиться

Файл я приложила, там есть формула, которая фиксирует количество записей, удовлетворяющих условиям поиска. Я хочу добавить к этой формуле дополнительный критерий, значение ячеек столбца K либо равно "Ответил", либо - "Входящие". Если вы хотите уже результат того, чего я хочу, то когда я закончу делать это через СЧЁТЕСЛИМН()+СЧЁТЕСЛИМН(), могу снова кинуть.
 
Ответить
Сообщение
Цитата прохожий2019, 31.08.2019 в 17:12, в сообщении № 6 ()
значит ввели не как формулу массива Ctrl+Shift+Enter

Не как формулу массива, да. Попробую сейчас

Цитата прохожий2019, 31.08.2019 в 17:12, в сообщении № 6 ()
СУММПРОИЗВ

Возможно, я не очень хорошо знаю эту формулу, но в моём случае она, скорее всего, не подойдёт

Цитата прохожий2019, 31.08.2019 в 17:12, в сообщении № 6 ()
Было бы гораздо проще, если бы показали в файле, чего хотите добиться

Файл я приложила, там есть формула, которая фиксирует количество записей, удовлетворяющих условиям поиска. Я хочу добавить к этой формуле дополнительный критерий, значение ячеек столбца K либо равно "Ответил", либо - "Входящие". Если вы хотите уже результат того, чего я хочу, то когда я закончу делать это через СЧЁТЕСЛИМН()+СЧЁТЕСЛИМН(), могу снова кинуть.

Автор - Chesse
Дата добавления - 31.08.2019 в 17:22
Pelena Дата: Суббота, 31.08.2019, 17:30 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14473
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Chesse, зачем ИЛИ, если Вы хотите посчитать
Цитата
Записи за минусом тех, у кого в ячейке K на листе 'Ежедневник!' стоит "Ответил" и "Входящие"
то есть нужны те в которых <>"Ответил" И <>"Входящие


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеChesse, зачем ИЛИ, если Вы хотите посчитать
Цитата
Записи за минусом тех, у кого в ячейке K на листе 'Ежедневник!' стоит "Ответил" и "Входящие"
то есть нужны те в которых <>"Ответил" И <>"Входящие

Автор - Pelena
Дата добавления - 31.08.2019 в 17:30
прохожий2019 Дата: Суббота, 31.08.2019, 17:32 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
скорее всего, не подойдёт
мдя, ну ладно - пойду отсюда
Пы Сы текущая формула сводится к
Код
=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3))

а с доп условиями к
Код
=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3)*(Ежедневник!$K$4:$K$74<>"Ответил")*(Ежедневник!$K$4:$K$74<>"Входящие"))
К сообщению приложен файл: _31.08.2019-2-.xlsx(59.8 Kb)
 
Ответить
Сообщение
скорее всего, не подойдёт
мдя, ну ладно - пойду отсюда
Пы Сы текущая формула сводится к
Код
=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3))

а с доп условиями к
Код
=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3)*(Ежедневник!$K$4:$K$74<>"Ответил")*(Ежедневник!$K$4:$K$74<>"Входящие"))

Автор - прохожий2019
Дата добавления - 31.08.2019 в 17:32
Chesse Дата: Суббота, 31.08.2019, 17:44 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата прохожий2019, 31.08.2019 в 17:32, в сообщении № 9 ()
Пы Сы текущая формула сводится к

=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3))

а с доп условиями к

=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3)*(Ежедневник!$K$4:$K$74<>"Ответил")*(Ежедневник!$K$4:$K$74<>"Входящие"))


Они не учитывают три условия из моего примера, но это уже значительно сократит формулу, пойду разбираться и переделывать вашу формулу. Спасибо за неё)
 
Ответить
Сообщение
Цитата прохожий2019, 31.08.2019 в 17:32, в сообщении № 9 ()
Пы Сы текущая формула сводится к

=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3))

а с доп условиями к

=СУММПРОИЗВ((Ежедневник!$B$4:$B$74>=D3)*(Ежедневник!$B$4:$B$74<=F3)*(Ежедневник!$E$4:$E$74=J3)*(Ежедневник!$J$4:$J$74=M3)*(Ежедневник!$K$4:$K$74<>"Ответил")*(Ежедневник!$K$4:$K$74<>"Входящие"))


Они не учитывают три условия из моего примера, но это уже значительно сократит формулу, пойду разбираться и переделывать вашу формулу. Спасибо за неё)

Автор - Chesse
Дата добавления - 31.08.2019 в 17:44
Pelena Дата: Суббота, 31.08.2019, 17:49 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 14473
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если точно по теме, то примерно так
Код
=СУММ(СЧЁТЕСЛИМН(Ежедневник!B4:B1000;СЕГОДНЯ();Ежедневник!E4:E1000;J3;Ежедневник!J4:J1000;M3;Ежедневник!$K$4:$K$1000;{"Ответил";"Входящие"}))

Если предложенные ранее варианты подходят, то измените название темы, чтобы оно отражало суть задачи, а не Ваш способ решения


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли точно по теме, то примерно так
Код
=СУММ(СЧЁТЕСЛИМН(Ежедневник!B4:B1000;СЕГОДНЯ();Ежедневник!E4:E1000;J3;Ежедневник!J4:J1000;M3;Ежедневник!$K$4:$K$1000;{"Ответил";"Входящие"}))

Если предложенные ранее варианты подходят, то измените название темы, чтобы оно отражало суть задачи, а не Ваш способ решения

Автор - Pelena
Дата добавления - 31.08.2019 в 17:49
bmv98rus Дата: Суббота, 31.08.2019, 18:00 | Сообщение № 12
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2527
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
да почти то, что выше
Код
=D6-SUM(COUNTIFS(Ежедневник!K:K;{"Входящие";"Ответил"};Ежедневник!E:E;Статистика!J3;Ежедневник!J:J;Статистика!M3;Ежедневник!B:B;">="&IF(B3;TODAY();D3);Ежедневник!B:B;"<="&IF(B3;TODAY();F3)))
Диапазон, если таких формул не много можно столбцом оставить, а вот если много, то лучше ограничить.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 31.08.2019, 18:10
 
Ответить
Сообщениеда почти то, что выше
Код
=D6-SUM(COUNTIFS(Ежедневник!K:K;{"Входящие";"Ответил"};Ежедневник!E:E;Статистика!J3;Ежедневник!J:J;Статистика!M3;Ежедневник!B:B;">="&IF(B3;TODAY();D3);Ежедневник!B:B;"<="&IF(B3;TODAY();F3)))
Диапазон, если таких формул не много можно столбцом оставить, а вот если много, то лучше ограничить.

Автор - bmv98rus
Дата добавления - 31.08.2019 в 18:00
Chesse Дата: Суббота, 31.08.2019, 19:10 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата прохожий2019, 31.08.2019 в 17:32, в сообщении № 9 ()
Если точно по теме, то примерно так

Спасибо, посмотрю вашу формулу)


Сообщение отредактировал Chesse - Суббота, 31.08.2019, 20:46
 
Ответить
Сообщение
Цитата прохожий2019, 31.08.2019 в 17:32, в сообщении № 9 ()
Если точно по теме, то примерно так

Спасибо, посмотрю вашу формулу)

Автор - Chesse
Дата добавления - 31.08.2019 в 19:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учёт равнозначных критериев в подсчёте со многими условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!