Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СЧЁТЕСЛИ с множеством условий в нескольких диапозонах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СЧЁТЕСЛИ с множеством условий в нескольких диапозонах (Формулы/Formulas)
СЧЁТЕСЛИ с множеством условий в нескольких диапозонах
xS0ul Дата: Суббота, 07.09.2019, 19:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Второй день мучаюсь, не могу написать формулу. Никак не получается "поженить" счетеслимн+и+или

Нужно посчитать кол-во значений с несколькими условиями в одном диапазоне и несколькими в другом.

Примерный файл прилагаю. в нём всё подробно описал.

Формулы массива не подойдут, т.к. кол-во строк в исходном файле более 500 000,считать будет очень долго.
К сообщению приложен файл: 9642194.xlsx(10.9 Kb)
 
Ответить
СообщениеДобрый день!
Второй день мучаюсь, не могу написать формулу. Никак не получается "поженить" счетеслимн+и+или

Нужно посчитать кол-во значений с несколькими условиями в одном диапазоне и несколькими в другом.

Примерный файл прилагаю. в нём всё подробно описал.

Формулы массива не подойдут, т.к. кол-во строк в исходном файле более 500 000,считать будет очень долго.

Автор - xS0ul
Дата добавления - 07.09.2019 в 19:54
bmv98rus Дата: Суббота, 07.09.2019, 20:05 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2528
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениекросс

Автор - bmv98rus
Дата добавления - 07.09.2019 в 20:05
Светлый Дата: Суббота, 07.09.2019, 21:31 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Вот так устроит?
Код
=СУММ(СЧЁТЕСЛИМН(B8:B26;{"активный";"сезонный"};D8:D26;{"активный":"сезонный"};F8:F26;1))
А про нули не понял.
*В H9:
Код
=СУММ(СЧЁТЕСЛИ(B8:B26;{"активный";"сезонный"}))
**Можно немного сократить:
Код
=СУММ(СЧЁТЕСЛИМН(B8:B26;{"ак*";"се*"};D8:D26;{"ак*":"се*"};F8:F26;1))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 07.09.2019, 22:33
 
Ответить
СообщениеДобрый вечер!
Вот так устроит?
Код
=СУММ(СЧЁТЕСЛИМН(B8:B26;{"активный";"сезонный"};D8:D26;{"активный":"сезонный"};F8:F26;1))
А про нули не понял.
*В H9:
Код
=СУММ(СЧЁТЕСЛИ(B8:B26;{"активный";"сезонный"}))
**Можно немного сократить:
Код
=СУММ(СЧЁТЕСЛИМН(B8:B26;{"ак*";"се*"};D8:D26;{"ак*":"се*"};F8:F26;1))

Автор - Светлый
Дата добавления - 07.09.2019 в 21:31
like_Excel Дата: Воскресенье, 08.09.2019, 12:28 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Попробуй поискать на канале Excel frm A to Z. Много инфы выложено.

Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума


Всем привет!
 
Ответить
СообщениеПопробуй поискать на канале Excel frm A to Z. Много инфы выложено.

Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума

Автор - like_Excel
Дата добавления - 08.09.2019 в 12:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СЧЁТЕСЛИ с множеством условий в нескольких диапозонах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!