Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отталкиваясь от имени поля выводить в др. поле нужную цифру - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отталкиваясь от имени поля выводить в др. поле нужную цифру (Формулы/Formulas)
Отталкиваясь от имени поля выводить в др. поле нужную цифру
ebokbak Дата: Четверг, 12.09.2019, 15:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть вот такая таблица:



Необходимо поле B4 проверять по названию с полем M3 и исходя из этого выдавать цифру из поля N3 в поле E4
И как то это автоматизировать что бы проверка шла по всем полям, так как ниже будут повторяться эти названия и надо что бы там все вводилась как и выше, тоже самое и для других имен, может как то можно упростить
Я сделал вот так для поля E4 =ЕСЛИ(B4="ВЕСЕННИЙ";N3) но в идеале мне надо в это поле засунуть все значения, так как они будут меняться.
Пример:
=ЕСЛИ(B4="ВЕСЕННИЙ";N3) =ЕСЛИ(B4="СНЕЖНЫЙ";N3) =ЕСЛИ(B4="СНЕЖНЫЙ";N3) =ЕСЛИ(B4="БЕРЛИНСКИЙ";N3) и так далее для каждого поля, ну или как то упростить можно ли это? и вообще можно ли в одно поле засунуть кучу условий и как это моно сделать?
К сообщению приложен файл: 0630910.jpg(68.4 Kb) · 1234.xlsx(12.9 Kb)


Сообщение отредактировал ebokbak - Четверг, 12.09.2019, 17:28
 
Ответить
СообщениеЕсть вот такая таблица:



Необходимо поле B4 проверять по названию с полем M3 и исходя из этого выдавать цифру из поля N3 в поле E4
И как то это автоматизировать что бы проверка шла по всем полям, так как ниже будут повторяться эти названия и надо что бы там все вводилась как и выше, тоже самое и для других имен, может как то можно упростить
Я сделал вот так для поля E4 =ЕСЛИ(B4="ВЕСЕННИЙ";N3) но в идеале мне надо в это поле засунуть все значения, так как они будут меняться.
Пример:
=ЕСЛИ(B4="ВЕСЕННИЙ";N3) =ЕСЛИ(B4="СНЕЖНЫЙ";N3) =ЕСЛИ(B4="СНЕЖНЫЙ";N3) =ЕСЛИ(B4="БЕРЛИНСКИЙ";N3) и так далее для каждого поля, ну или как то упростить можно ли это? и вообще можно ли в одно поле засунуть кучу условий и как это моно сделать?

Автор - ebokbak
Дата добавления - 12.09.2019 в 15:33
Kostya_Ye Дата: Четверг, 12.09.2019, 16:46 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 46 ±
Замечаний: 0% ±

Excel 2016
ebokbak,
прикладывайте к сообщению не картинку, а файл с примером. в примере показывайте в каких ячейках какой результат хотите получить. после этого вам можно будет помочь с решением.
 
Ответить
Сообщениеebokbak,
прикладывайте к сообщению не картинку, а файл с примером. в примере показывайте в каких ячейках какой результат хотите получить. после этого вам можно будет помочь с решением.

Автор - Kostya_Ye
Дата добавления - 12.09.2019 в 16:46
ebokbak Дата: Четверг, 12.09.2019, 17:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Kostya_Ye, прикрепил - http://www.excelworld.ru/_fr/428/1234.xlsx
 
Ответить
СообщениеKostya_Ye, прикрепил - http://www.excelworld.ru/_fr/428/1234.xlsx

Автор - ebokbak
Дата добавления - 12.09.2019 в 17:28
bigor Дата: Четверг, 12.09.2019, 19:32 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 23 ±
Замечаний: 0% ±

Excel 2016
Так :

Код
=SUMPRODUCT(($M$3:$M$31=B4)*$N$3:$N$31)
К сообщению приложен файл: 1234_1.xlsx(9.8 Kb)
 
Ответить
СообщениеТак :

Код
=SUMPRODUCT(($M$3:$M$31=B4)*$N$3:$N$31)

Автор - bigor
Дата добавления - 12.09.2019 в 19:32
bmv98rus Дата: Четверг, 12.09.2019, 19:38 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2780
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
bigor, возможно и так, но не стоит где надо и где не надо SUMPRODUCT использовать. То что написано компактнее и быстрее
Код
=SUMIF($M:$M;$B5;$N:$N)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 12.09.2019, 19:38
 
Ответить
Сообщениеbigor, возможно и так, но не стоит где надо и где не надо SUMPRODUCT использовать. То что написано компактнее и быстрее
Код
=SUMIF($M:$M;$B5;$N:$N)

Автор - bmv98rus
Дата добавления - 12.09.2019 в 19:38
bigor Дата: Четверг, 12.09.2019, 19:46 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 23 ±
Замечаний: 0% ±

Excel 2016
но не стоит где надо и где не надо SUMPRODUCT использовать

он в автоподстановке проще набирается :)
 
Ответить
Сообщение
но не стоит где надо и где не надо SUMPRODUCT использовать

он в автоподстановке проще набирается :)

Автор - bigor
Дата добавления - 12.09.2019 в 19:46
ebokbak Дата: Пятница, 13.09.2019, 08:49 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bigor, Спасибо!!! То что нужно, очень классно и удобно! Благодарю ;)
 
Ответить
Сообщениеbigor, Спасибо!!! То что нужно, очень классно и удобно! Благодарю ;)

Автор - ebokbak
Дата добавления - 13.09.2019 в 08:49
ebokbak Дата: Пятница, 13.09.2019, 08:54 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
И еще вопрос, как сделать что бы эта формула из вкладки под названием "Понедельник" подтягивалось на другие вкладки под другими названиями из Понедельника?
 
Ответить
СообщениеИ еще вопрос, как сделать что бы эта формула из вкладки под названием "Понедельник" подтягивалось на другие вкладки под другими названиями из Понедельника?

Автор - ebokbak
Дата добавления - 13.09.2019 в 08:54
bigor Дата: Пятница, 13.09.2019, 11:19 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 23 ±
Замечаний: 0% ±

Excel 2016
из вкладки под названием "Понедельник" подтягивалось на другие вкладки

А где у Вас вкладка "понедельник" ? и вкладка это лист?
 
Ответить
Сообщение
из вкладки под названием "Понедельник" подтягивалось на другие вкладки

А где у Вас вкладка "понедельник" ? и вкладка это лист?

Автор - bigor
Дата добавления - 13.09.2019 в 11:19
ebokbak Дата: Понедельник, 16.09.2019, 08:20 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bigor, да вкладка это лист, сейчас отправлю с листом.
К сообщению приложен файл: 12345.xlsx(39.3 Kb)
 
Ответить
Сообщениеbigor, да вкладка это лист, сейчас отправлю с листом.

Автор - ebokbak
Дата добавления - 16.09.2019 в 08:20
bigor Дата: Понедельник, 16.09.2019, 10:43 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 23 ±
Замечаний: 0% ±

Excel 2016
Если я правильно понял, Вы хотите, что бы данные в ячейках m2:n71 были только на листе "Понедельник", и формулы с других листов обращались к этим данным?

Если так, то для вторник
Код
=СУММЕСЛИ(ПОНЕДЕЛЬНИК!$M$2:$M$71;B5;ПОНЕДЕЛЬНИК!$N$2:$N$71)
 
Ответить
СообщениеЕсли я правильно понял, Вы хотите, что бы данные в ячейках m2:n71 были только на листе "Понедельник", и формулы с других листов обращались к этим данным?

Если так, то для вторник
Код
=СУММЕСЛИ(ПОНЕДЕЛЬНИК!$M$2:$M$71;B5;ПОНЕДЕЛЬНИК!$N$2:$N$71)

Автор - bigor
Дата добавления - 16.09.2019 в 10:43
ebokbak Дата: Понедельник, 16.09.2019, 14:57 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bigor, да, именно это и имел ввиду. Спасибо за подсказку! hands :)
 
Ответить
Сообщениеbigor, да, именно это и имел ввиду. Спасибо за подсказку! hands :)

Автор - ebokbak
Дата добавления - 16.09.2019 в 14:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отталкиваясь от имени поля выводить в др. поле нужную цифру (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!