Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание накладной из списков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание накладной из списков (Формулы/Formulas)
Создание накладной из списков
Tomtik Дата: Воскресенье, 15.09.2019, 22:52 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток. Встал остро вопрос. Как правильно сформировать накладную.
Имеется справочник: получатель, наименование, ед. изм.
Имеется таблица движения: получатель, наименование, ед. изм., кол-во
Надо: при введении на листе "накладная" в ячейку В8, чтобы в строку18 погружалась информация о наименовании, ед.изм, количестве, но, только если она вносилась в таблицу "движение".
т.е. в ячейке В8 выбираешь человека, а к нему в строку 18 и ниже подгружаются все его требования из таблицы "движение".
Наверное сумбурно объяснила, поэтому прикладываю файл.
К сообщению приложен файл: 3431621.xlsx(48.5 Kb)
 
Ответить
СообщениеДоброго времени суток. Встал остро вопрос. Как правильно сформировать накладную.
Имеется справочник: получатель, наименование, ед. изм.
Имеется таблица движения: получатель, наименование, ед. изм., кол-во
Надо: при введении на листе "накладная" в ячейку В8, чтобы в строку18 погружалась информация о наименовании, ед.изм, количестве, но, только если она вносилась в таблицу "движение".
т.е. в ячейке В8 выбираешь человека, а к нему в строку 18 и ниже подгружаются все его требования из таблицы "движение".
Наверное сумбурно объяснила, поэтому прикладываю файл.

Автор - Tomtik
Дата добавления - 15.09.2019 в 22:52
Pelena Дата: Воскресенье, 15.09.2019, 23:03 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14585
Репутация: 3196 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
На примере Наименования. Формула массива вводится одновременным нажатием сочетания клавиш Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица4[Наименование];НАИМЕНЬШИЙ(ЕСЛИ(Таблица4[Получатель]=$B$8;СТРОКА(Таблица4[Наименование])-2);СТРОКА(A1)));"")

С количеством не совсем поняла, откуда что переносить
К сообщению приложен файл: 7445708.xlsx(51.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
На примере Наименования. Формула массива вводится одновременным нажатием сочетания клавиш Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица4[Наименование];НАИМЕНЬШИЙ(ЕСЛИ(Таблица4[Получатель]=$B$8;СТРОКА(Таблица4[Наименование])-2);СТРОКА(A1)));"")

С количеством не совсем поняла, откуда что переносить

Автор - Pelena
Дата добавления - 15.09.2019 в 23:03
Tomtik Дата: Воскресенье, 15.09.2019, 23:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Количество переносится из красивого розово-зеленого столбца, которое подмечено вводим
 
Ответить
СообщениеКоличество переносится из красивого розово-зеленого столбца, которое подмечено вводим

Автор - Tomtik
Дата добавления - 15.09.2019 в 23:07
Pelena Дата: Воскресенье, 15.09.2019, 23:12 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14585
Репутация: 3196 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула аналогичная, только замените [Наименование] на нужный столбец


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула аналогичная, только замените [Наименование] на нужный столбец

Автор - Pelena
Дата добавления - 15.09.2019 в 23:12
Tomtik Дата: Воскресенье, 15.09.2019, 23:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Спасибо, буду пробовать
 
Ответить
СообщениеСпасибо, буду пробовать

Автор - Tomtik
Дата добавления - 15.09.2019 в 23:21
Tomtik Дата: Понедельник, 16.09.2019, 19:56 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Всё равно пусто в таблице накладной. Что я не так делаю?
К сообщению приложен файл: 8304545.xlsx(50.7 Kb)
 
Ответить
СообщениеВсё равно пусто в таблице накладной. Что я не так делаю?

Автор - Tomtik
Дата добавления - 16.09.2019 в 19:56
bigor Дата: Понедельник, 16.09.2019, 20:21 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 90
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Что я не так делаю?

не те кнопки жмете. Формула массивная.
Цитата
вводится одновременным нажатием сочетания клавиш Ctrl+Shift+Enter
 
Ответить
Сообщение
Что я не так делаю?

не те кнопки жмете. Формула массивная.
Цитата
вводится одновременным нажатием сочетания клавиш Ctrl+Shift+Enter

Автор - bigor
Дата добавления - 16.09.2019 в 20:21
Tomtik Дата: Понедельник, 16.09.2019, 20:27 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
А-а-а-а-а, ну я и чукча. Спасибо огромное. Вы чудо!!!!
 
Ответить
СообщениеА-а-а-а-а, ну я и чукча. Спасибо огромное. Вы чудо!!!!

Автор - Tomtik
Дата добавления - 16.09.2019 в 20:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание накладной из списков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!